Mint 15 - Samsung backlit keyboard

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Mint 15 - Samsung backlit keyboard

Postby cpreisler on Sat Jun 01, 2013 3:37 pm

Hello,

I just installed Linux Mint 15 on a Samsung series 7 Chronos laptop. Everything is working really well, except the backlit keyboard is always on and the FN9 and FN10 keys do not work. I tried to install the "Samsung Tools" from https://launchpad.net/~voria/+archive/ppa, however, that ppa does not appear to work with Mint15. The following error is given when trying to run apt-get update.

Fetched 553 kB in 20s (27.5 kB/s)
W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... ce/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... 4/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ ... 6/Packages 404 Not Found

I've found some posts on the internet that talk about different script files and key bindings, but many of them reference the Samsung tools mentioned above. Can anyone give me a sure fire way to fix the keyboard issue? Just getting the function keys working would be great.

Thanks,
Chad
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Linux Mint is funded by ads and donations.
 

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Sun Jun 02, 2013 10:15 am

In Mint 15 go to the Menu > System Tools> System Settings > Software Sources. If Software Sources does not show, then click
“Switch to Advanced Mode” at the bottom. On the left click PPAs. Click “Add a new PPA”.
Type: ppa:voria/ppa
Click “Update the Cache”.

Open the Terminal and type: sudo apt-get install samsung-tools

The Samsung Tools Preferences utility should now appear in the Menu > Preferences
For other help on using the utility you can type in the Terminal: samsung-tools --help
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 15 - Samsung backlit keyboard

Postby cpreisler on Sun Jun 02, 2013 11:30 pm

Thank you for the answer. The suggestion worked for installing the samsung-tools. However, It didn't seem to help me with my Fn-F9 and Fn-10 keys. I'm not sure it helped at all.

Anyway, the ambient light sensor for the backlit keyboard appars to work. However, the laptop pretty much needs to be right under a light for the keyboard lights to turn off. Not sure if there is a file some file that I can change to make it dim under less light.

For the Fn-F9 and Fn-F10 keys, I think I need to change the following line in the 95-keymap.rules file.

ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z*", RUN+="keymap $name 0xBA ejectcd 0x96 keyboardbrightnessup 0x97 keyboardbrightnessdown"

I think the 0x97 key is Fn-F7, and if I'm reading this correct the keyboardbrightnessdown key isn't even set. Problem is I can't figure out what the correct hex values are for Fn-F9 and Fn-F10. Am I looking the right place? Do I need to change this? If so, what do I change it to?

Any help is apprciated.
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Mon Jun 03, 2013 5:26 pm

Do you need to use the keyboard backlight? If not, then the ambient light sensor can be turned off in the BIOS, right?
Do your function keys for screen brightness work, and are they F2 and F3?.
Do your keys for volume control work, and are they F7 and F8?
Your laptop problem can be dealt with in two ways. You can try some of the methods listed in the topic below:
viewtopic.php?f=49&t=133622
Note that some methods may cause significant problems. You may not experience the same problems as the person in that topic did.
Ideally you should have a backup image of your linux partition or drive.

EDITED: The method below works for Mint 14 &15 but not Mint 16. For Mint 16 see the last post in this topic.

Or you can try to configure the “95-keymap.rules” file which you listed and work with other configuration files.
The only information I have come across that deals with this subject is at this link:
http://natjohan.info/linux-on-samsung-np900x3c.html
Even though the info is from a Linux RedHat site, it may still work or be modified to work for you.

So you would need to go to /lib/udev/keymaps. Right click on keymaps and select "Open as Root". Note that the keymaps folder must be
listed in the window on the right side. Don't right click on the word keymaps if it is listed in the column on the left.

Then right click in the empty space and select “Create New Document” > “Empty Document”.
Name it “samsung-700Z” and copy the contents from the file in line 1 from the site above into it.
Then open the folder "/lib/udev/keymaps/force-release" and create another "samsung-700Z" file to put in it and copy the contents from the file in line 2 from the site above into it.

Then follow the instructions in line 3, so your file would be:
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z*", RUN+="keymap $name samsung-700Z"
and this would be added to the "/lib/udev/rules.d/95-keymap.rules file" in the Samsung section.

Then follow the instructions in line 4, so your file would be:
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z*", RUN+="keyboard-force-release.sh $devpath samsung-700Z"
and this would be added to the "/lib/udev/rules.d/95-keyboard-force-release.rules" file in the Samsung section.

Be sure to check over everything I did. Then reboot and test your function keys.

Note: I have edited this post several times to get the information correct. This was finished on Saturday, 6-8-13 at 8:00 pm.
Last edited by roblm on Fri Jan 17, 2014 9:01 pm, edited 7 times in total.
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 15 - Samsung backlit keyboard

Postby cpreisler on Tue Jun 04, 2013 6:36 pm

To answer your questions.

Do you need to use the keyboard backlight? -- Yes
Do your function keys for screen brightness work, and are they F2 and F3?. -- Yes, Yes
Do your keys for volume control work, and are they F7 and F8? -- Yes, Yes

As a side note the F5 key works. It appears to disable the mouse track pad.

I will study the rest of the answer, and give it a try for my F9 and F10 keys (F9 dim keyboard backlight, F10 increase keyboard backlight). I hope to get some time this week.

Thanks for the help.

Chad
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Re: Mint 15 - Samsung backlit keyboard

Postby cpreisler on Wed Jun 26, 2013 8:26 am

Hello,

First, sorry it took so long to try this. The above did enable the F9 and F10 key. The icon for keyboard brighness comes up on the screen when I push the F9 and F10 keys. However, it has no effect on the keyboard brightness. The little bar at the bottom of the icon is empty and does not change when I press the keys.

Any help with this last issue.
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Fri Jun 28, 2013 7:56 am

Did you make any changes to the /etc/default/grub file?
Did you follow the four steps in the bottom part of my last post completely? You created a
/lib/udev/keymaps/samsung-700Z file with the contents below:

0xCE prog1 # FN+F1 System Settings
0x89 brightnessdown # FN+F2 Brightness down
0x88 brightnessup # FN+F3 Brightness up
0x82 switchvideomode # FN+F4 Switch video mode
0xF9 f23 # FN+F5 Turn touchpad off
0xA0 mute # FN+F6 Mute
0xAE volumedown # FN+F7 Volume down
0xB0 volumeup # FN+F8 Volume up
0x97 kbdillumdown # FN+F9 Keyboard backlight down
0x96 kbdillumup # FN+F10 Keyboard backlight up
0xB3 silentmode # FN+F11 Silentmode
0xD5 wlan # FN+F12 WiFi

Then you created a /lib/udev/keymaps/force-release/samsung-700Z file with the contents below:

0xCE # FN+F1 System Settings
0x89 # FN+F2 Brightness down
0x88 # FN+F3 Brightness up
0x82 # FN+F4 Switch video mode
0xF9 # FN+F5 Turn touchpad off
0xA0 # FN+F6 Mute
0xAE # FN+F7 Volume down
0xB0 # FN+F8 Volume up
0x97 # FN+F9 Keyboard backlight down
0x96 # FN+F10 Keyboard backlight up
0xB3 # FN+F11 Silentmode
0xD5 # FN+F12 WiFi

Then you added a line to the /lib/udev/rules.d/95-keymap.rules file, and a line to the /lib/udev/rules.d/95-keyboard-force-release.rules file.
If you did all of that, then proceed below.

First run this command in the Terminal to reload udev rules: udevadm control - -reload-rules (UPDATED: Use: sudo adevadm trigger)
Reboot and check if there is any change.

If not, then press Ctrl+Alt+F1 to enter the virtual console tty1. Type: /lib/udev/findkeyboards
Get the input/event number.

Then type: sudo /lib/udev/keymap -i input/eventX
where X is the number you found in the previous step.

Press the 12 function key combinations starting with Fn+F1 all the way through Fn+F12.
Press the Escape key.
You can't use the print screen function here, so use the command:
sudo screendump 1 > screenoutput.txt

Press Ctrl+Alt+F8 to exit the tty1 console. If this fails then try Ctrl+Alt+F7.
The file "screenoutput.txt" will be found in your Home directory (/home/username). Post the result.

Finally, run these two commands in the Terminal:
cat /sys/class/dmi/id/sys_vendor
cat /sys/class/dmi/id/product_name
Last edited by roblm on Wed Oct 23, 2013 7:18 pm, edited 2 times in total.
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 15 - Samsung backlit keyboard

Postby cpreisler on Sun Jun 30, 2013 12:20 am

Did you make any changes to the /etc/default/grub file? No. I'm not sure what grub does.
Did you follow the four steps in the bottom part of my last post completely? Yes.

I ran the udevadm command and rebooted, nothing changed.

Here is the output from the commands that you asked me to run.
chad@Samsung-Laptop ~ $ sudo /lib/udev/keymap -i input/event3
Press ESC to finish, or Control-C if this device is not your primary keyboard
scan code: 0xCE key code: prog1
scan code: 0x89 key code: brightnessdown
scan code: 0x88 key code: brightnessup
scan code: 0x82 key code: switchvideomode
scan code: 0xF9 key code: f23
scan code: 0xA0 key code: mute
got scan code event 0xA0 without a key code event
scan code: 0xAE key code: volumedown
got scan code event 0xAE without a key code event
scan code: 0xB0 key code: volumeup
got scan code event 0xB0 without a key code event
scan code: 0x97 key code: kbdillumdown
scan code: 0x96 key code: kbdillumup
scan code: 0xB3 key code: prog3
scan code: 0xD5 key code: wlan
scan code: 0x01 key code: esc
chad@Samsung-Laptop ~ $ sudo screendump 1 > screenoutput.txt

chad@Samsung-Laptop ~ $ cat /sys/class/dmi/id/sys_vendor
SAMSUNG ELECTRONICS CO., LTD.
chad@Samsung-Laptop ~ $ cat /sys/class/dmi/id/product_name
700Z3C/700Z5C
chad@Samsung-Laptop ~ $

The keys seem to be registered to control the keyboard backlight. They just don't have any effect on brightness when they are pushed. I've attached a screen shot showing what appears when I use the Fn-9 or Fn-10.

Thanks for all the help.
Attachments
functionF10.png
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Sun Jun 30, 2013 8:45 am

It appears that the exact product name of your laptop is 700Z3C or 700Z5C. Whichever it is, you need to go back and replace the name 700Z with the correct product name. 700Z was used six times in making two files and two other lines in two other files.
You will need to right click each file and select "Open as Root".

The file /lib/udev/keymaps/samsung-700Z will be changed to /lib/udev/keymaps/samsung-700Z3C or
/lib/udev/keymaps/samsung-700Z5C, whichever is correct.

Then make the change to the file /lib/udev/keymaps/force-release/samsung-700Z

Then open the file “/lib/udev/rules.d/95-keymap.rules” and make the two changes in the line:
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z*", RUN+="keymap $name samsung-700Z"

Then open the file "/lib/udev/rules.d/95-keyboard-force-release.rules" and make the two changes in the line:
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z*", RUN+="keyboard-force-release.sh $devpath samsung-700Z"

Then run this command in the Terminal: udevadm control - -reload-rules
Then check the backlight. You may need to reboot.
Last edited by roblm on Sun Jun 30, 2013 8:28 pm, edited 1 time in total.
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 15 - Samsung backlit keyboard

Postby cpreisler on Sun Jun 30, 2013 12:13 pm

I followed your instructions, no change. I changed the file names and the lines from the keymap files to match my model number.

95-keymap.rules
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z5C*", RUN+="keymap $name samsung-700Z5C"

95-keyboard-force-release.rules
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z5C*", RUN+="keyboard-force-release.sh $devpath samsung-700Z5C"

I ran the command to re-load the udev rules and then rebooted.

I've seen some posts around the internet that talk about the kbdillumdown and kbdillumup not being loaded by the kernel on boot. Some suggest changing the grub file. I don't have a /etc/default/grub file.
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Sun Jun 30, 2013 1:03 pm

Adding commands to the /etc/default/grub file was going to be the next step, if working with the keymap configuration files didn't work.

Looking over everything, I caught an error in the command: udevadm control - -reload-rules (UPDATED: Use: sudo adevadm trigger)
There should not be a space between the two hyphen symbols. It should be: udevadm control --reload-rules
So try running the corrected command. If this fails, then proceed below.

EDITED: try using the name 700Z5 also.

Then try removing the asterisk in front of 700Z5C in these two lines:

95-keymap.rules
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z5C*", RUN+="keymap $name samsung-700Z5C"
and

95-keyboard-force-release.rules
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z5C*", RUN+="keyboard-force-release.sh $devpath samsung-700Z5C"

So "*700Z5C*" will become "700Z5C*". Then run the command in the Terminal: udevadm control --reload-rules
Reboot and check the backlight.

If that fails, then remove the asterisk after 700Z5C in the two lines. "700Z5C*" will be changed to "700Z5C"
Repeat the Terminal command.

To check if your system can control the keyboard backlight type this command in the Terminal, while the light is on and see if it turns off:
sudo echo 0 > /sys/devices/platform/samsung/leds/samsung\:\:kbd_backlight/brightness

If that doesn't work then try: echo 0 | sudo tee /sys/devices/platform/samsung/leds/samsung\:\:kbd_backlight/brightness

After doing more investigation on this problem, it appears that there was a bug affecting Samsung series 7 laptops in using the keyboard
function keys to control the keyboard backlight. Here is a link to one site:
https://bugs.launchpad.net/ubuntu/+sour ... bug/902332

Most of the information I used for my posts comes from testing done on the Samsung series 9 laptops. However, both the 7 and 9 series
use the same scancodes. The bug was supposedly fixed, according to this site:
http://git.kernel.org/cgit/linux/hotplu ... 861d52fd6f

The line in green is the line you listed in your second post above, which is listed below:
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*700Z*", RUN+="keymap $name 0xBA ejectcd 0x96 keyboardbrightnessup 0x97 keyboardbrightnessdown"

It's strange why the words keyboardbrightnessup and keyboardbrightnessdown are used instead of kbdillumup and kbdillumdown, which are used when generating the scancodes. This line may be causing a conflict. You could disable it by putting a # followed by a space in front of it
like this below and then run all the tests again:
# ENV{DMI_VENDOR}==.........................keyboardbrightnessdown"

I don't know if switching the words in the "/lib/udev/keymaps/samsung-700Z5C" file will make a difference.

0xCE prog1 # FN+F1 System Settings
0x89 brightnessdown # FN+F2 Brightness down
0x88 brightnessup # FN+F3 Brightness up
0x82 switchvideomode # FN+F4 Switch video mode
0xF9 f23 # FN+F5 Turn touchpad off
0xA0 mute # FN+F6 Mute
0xAE volumedown # FN+F7 Volume down
0xB0 volumeup # FN+F8 Volume up
0x97 keyboardbrightnessdown # FN+F9 Keyboard backlight down
0x96 keyboardbrightnessup # FN+F10 Keyboard backlight up
0xB3 silentmode # FN+F11 Silentmode
0xD5 wlan # FN+F12 WiFi

You may have to test this with *700Z5C*, 700Z5C*, and 700Z5C.

EDITED: 7-2-13: Here's another possible solution I ran across.

Add the following lines to /lib/udev/keymaps/samsung-other

0x96 kbdillumup # keyboard backlit up
0x97 kbdillumdown # keyboard backlit down

and the following lines to /lib/udev/keymaps/force-release/samsung-other

0x96 # keyboard backlit up
0x97 # keyboard backlit down

Then run the command in the Terminal: udevadm control --reload-rules
Reboot.
Also turn off the ambient light sensor in the BIOS to see if it has any effect.

EDITED: 7-3-13

If you've done enough internet searches for problems related to your laptop I'm sure you've come across the potentially fatal problem of making your laptop totally unusable (bricking) if you try to boot into Linux with UEFI. This affects Samsung laptop models in the 3,5,7, and 9 series, including yours. Here is a link to one of the many sites that talk about this:
http://arstechnica.com/information-tech ... g-laptops/

If your laptop has UEFI firmware and you installed Mint with UEFI mode set in the BIOS, then the samsung-laptop driver may not work correctly. This driver controls the keyboard backlight. You would have to reinstall Mint with CSM mode (legacy BIOS) selected in the BIOS, but this driver
still may not fully support your model.

If the command Iisted above works, to turn off the keyboard backlight, then it may be easier just to make several scripts for the desktop with different brightness settings such as OFF, 50% and 100%. The script would look like this:

#!/bin/sh
echo X > /sys/devices/platform/samsung/leds/samsung\:\:kbd_backlight/brightness

where X would be a value between 0 and 8, which is the range for your laptop. You can just click the desktop icon that has the setting you want and select “Run”. Here is a picture below as an example.

Keyboard backlight.png
Last edited by roblm on Wed Oct 23, 2013 7:20 pm, edited 4 times in total.
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 15 - Samsung backlit keyboard

Postby cpreisler on Sun Jul 07, 2013 10:59 am

The command does not work on my computer because I don't have /sys/devices/platform/samsung directory. It seems like Linux can control the backlight because if the room is bright enough the lights turn off. Or is that the hardware itself that does that? Anyway, I searched around a little bit to figure out what command actually is conrolling the backlight, but couldn't figure it out. It seems that quite a few things have changed in LinuxMint 15, and a lot of the old information out there does not apply any more.
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Sun Jul 07, 2013 11:46 am

See if there is a samsung folder in /sys/class/leds. If there is, then list the full pathway to a "brightness" folder.
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 15 - Samsung backlit keyboard

Postby cpreisler on Sun Jul 07, 2013 5:32 pm

I've attached a screenshot of what I was able to find under the directory with brightness in the path or file name.
Attachments
brightness.png
cpreisler
Level 1
Level 1
 
Posts: 12
Joined: Fri May 31, 2013 12:21 am

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Sun Jul 07, 2013 8:49 pm

The folders in your list are for screen brightness control, not keyboard backlight. Every topic I've read on Samsung backlight control for series 7
and 9 lists the location of files in /sys/class/leds or /sys/devices/platform. Be sure to go to these locations and look for any folders with the word samsung in them. If there's nothing there, then the only thing I can think of is that the samsung-laptop.ko module is not loading or working
correctly. I would think that the ambient light sensor is just hardware controlled, so it doesn't need the module.

You can type the command “lsmod” to see a list of all the modules that load. As I explained in a previous post, if your laptop has UEFI firmware and UEFI mode is set in the BIOS, then the module may not work properly, so nothing would be listed in those locations. But I'm no expert on this subject. You could run the command “locate samsung” to find all references to Samsung, but only the folders in /sys are important.

I still have not read any topics where anyone has been successful in controlling the keyboard backlight with the function keys for the series 7 laptops.

EDITED 7-8-13: The remaining options you have are:

1. A BIOS update.

2. Updating the kernel. You can use this link: http://kernel.ubuntu.com/~kernel-ppa/mainline/
I have tested these 3 kernels and did not experience any problems. Your experience may differ.
v3.8.13.2-raring/
v3.9-rc8-raring/
v3.10-rc5-saucy/

3. Add commands to the /etc/default/grub file.

Since you don't have a grub file, then you could check if the packages for the Grub 2 bootloader are installed. Open Synaptic and search for grub. I have these packages installed:

grub-pc-bin
grub-common
grub-pc
grub-gfxpayload-lists
grub2-common
grub2-theme-mint

If you have these installed, then you could try making one by copying the contents of another grub file. I could find very little information on this and it's uncommon to not have the file so I don't know if this will work, so you do this at your own risk. The only info I found in the Mint forums is the link below:
viewtopic.php?f=46&t=121178

Before proceeding, you should have a backup image of your Linux partition or drive in case something goes wrong. You can use Clonezilla.

Here are the important lines from my grub file:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Copy the lines above and then open Nemo and go to /etc. Right click on the folder “default”. Select “Open as Root”. Right click in the empty space and select “Create New Document” > “Empty Document”. Name this file grub. Open this file and paste the files you copied above into it.

Change the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
into the top line below:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi_osi=Linux”
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi=Linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi="
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi=noirq acpi_osi=Linux acpi_backlight=vendor”

Save the file and type this command in the Terminal: sudo update-grub

Reboot. Test your laptop. If there's no change, then try the next line. To open the grub file type the command:
sudo gksudo gedit /etc/default/grub

Sometimes making changes to the grub file can cause startup problems. If this happens then restart and select the correct operating system at the Grub Boot Menu and then press e. Go down to the line that starts with:
linux /boot/vmlinuz.......................ro quiet splash $vt_handoff
Remove the command you added between the word “splash” and “$vt”.
Press Ctrl+x or F10. This change is just temporary and allows you to start your system. Then remove the command in the /etc/default/grub file.
If you have only one operating system installed, then a Grub Boot Menu may not be displayed. Hold down the Shift key while restarting, or if this doesn't work, keep tapping the shift key while starting.
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 15 - Samsung backlit keyboard

Postby romafederico on Tue Aug 13, 2013 7:43 pm

Hi Guys,

I read the whole thread as I was experience the same issues. I'm running Linux Mint Olivia on a Samsung Series 7 700G7C, and the function keys didn't work properly, but after following all your instructions, everything is working just fine.

The only thing is not working are the screen brightness control keys. Fn + F2 and Fn + F3. They seem to be doing fine because /sys/devices/platform/samsung/backlight/samsung/actual_brightness changes everytime I punch one of those hot keys. The value changes from 1 to 8 and the icons in the screen show up indicating that screen brightness is changing, but is actually not.

I cannot modify screen brightness at all. Even xbacklight commands don't work.

Do you have any ideas how can I fix this?

Thanks for all the previous instructions, they've been really helpful, and since I'm kinda new in linux, very educational aswell.
romafederico
Level 1
Level 1
 
Posts: 2
Joined: Mon Jul 29, 2013 8:35 pm

Re: Mint 15 - Samsung backlit keyboard

Postby roblm on Wed Aug 14, 2013 2:00 pm

romafederico,

Up until now I have not read of anyone on the Mint or other Linux forums with a Samsung series 7 laptop having success with the method
in this topic, only some users of Samsung series 9 laptops.
Did you install Mint 15 with UEFI mode or CSM mode (legacy BIOS) set in the BIOS?

When you opened this file: /lib/udev/rules.d/95-keymap.rules
and changed the line:
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", TTR{[dmi/id]product_name}=="*700Z*", RUN+="keymap $name samsung-700Z"

did you change the “*700Z*” to “*700G7C*”, “700G7C*”, or “700G7C”

Could you run this command in the Terminal, to list all the models in your laptop class:
cat /sys/class/dmi/id/product_name

Did you create these files:
/lib/udev/keymaps/samsung-700G7Z
/lib/udev/keymaps/force-release/samsung-700G7Z

and add the “0x89 brightnessdown” and “0x88 brightnessup” scancodes, such as shown below?

0xCE prog1 # FN+F1 System Settings
0x89 brightnessdown # FN+F2 Brightness down
0x88 brightnessup # FN+F3 Brightness up
0x82 switchvideomode # FN+F4 Switch video mode
0xF9 f23 # FN+F5 Turn touchpad off
0xA0 mute # FN+F6 Mute
0xAE volumedown # FN+F7 Volume down
0xB0 volumeup # FN+F8 Volume up
0x97 kbdillumdown # FN+F9 Keyboard backlight down
0x96 kbdillumup # FN+F10 Keyboard backlight up
0xB3 silentmode # FN+F11 Silentmode
0xD5 wlan # FN+F12 WiFi

You can test the following commands (kernel boot parameters) in the grub boot file. The effect will only last for one session and will no longer
be in effect after restarting your system. At the grub boot menu press the “e” key. If no menu shows then hold down the shift key while starting.
Go down to the line that starts with:
linux /boot/vmlinuz.......................ro quiet splash $vt_handoff

Add the line: acpi_osi=Linux
after the word “splash”. The end of the line will look like this:
….....ro quiet splash acpi_osi=Linux $vt_handoff

Press Ctrl+x at the same time to start your system. Check if there is any brightness control. If not then repeat the steps with the lines below:
acpi_backlight=vendor
acpi_osi=Linux acpi_backlight=vendor
acpi_osi='!Windows 2012'

If one of the lines allows brightness control then make the change permanent. In the Terminal run this command:
gksudo gedit /etc/default/grub

Change the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to the line below that worked:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi_osi=Linux”
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi=Linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi='!Windows 2012'"

Save the file and then run this command in the Terminal: sudo update-grub

If this doesn't work then run these commands to see if the kernel can decrease and increase the brightness:
sudo echo 3 > /sys/devices/platform/samsung/backlight/samsung/brightness
sudo echo 8 > /sys/devices/platform/samsung/backlight/samsung/brightness

If the commands don't work then try:
echo 3 |sudo tee /sys/devices/platform/samsung/backlight/samsung/brightness
echo 8 |sudo tee /sys/devices/platform/samsung/backlight/samsung/brightness

EDITED 1-5-14: The method in this topic does not work in Mint 16. Check the topics below for a newer method using evtest:
viewtopic.php?f=49&t=153157
viewtopic.php?f=49&t=155225

If evtest does not work then check this topic using showkey:
viewtopic.php?f=49&t=155527
User avatar
roblm
Level 5
Level 5
 
Posts: 699
Joined: Sun Feb 24, 2013 2:41 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 9 guests