put wrong video card driver now screen garbled

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

put wrong video card driver now screen garbled

Postby leo5111 on Thu Jun 19, 2008 11:19 am

i put in a driver thought was right one but apprently wasnt :evil: now it boots into a completly garbled screen cant see jack how do i boot in so its not using that driver or whatever so i can remove the driver and go back to restricted one? thanx
User avatar
leo5111
Level 4
Level 4
 
Posts: 312
Joined: Tue Mar 11, 2008 2:32 am
Location: Escaped From Xp Hell

Linux Mint is funded by ads and donations.
 

Re: put wrong video card driver now screen garbled

Postby 67GTA on Thu Jun 19, 2008 12:42 pm

What video card are you using?
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: put wrong video card driver now screen garbled

Postby leo5111 on Thu Jun 19, 2008 5:11 pm

ati 1600xt
User avatar
leo5111
Level 4
Level 4
 
Posts: 312
Joined: Tue Mar 11, 2008 2:32 am
Location: Escaped From Xp Hell

Re: put wrong video card driver now screen garbled

Postby MagnusB on Thu Jun 19, 2008 5:36 pm

Use Recovery mode, then use:
Code: Select all
nano /etc/X11/xorg.conf

The scroll down to the video card section and change:
Driver "whatever"

to
Driver "vesa"

then press Ctrl+X - Y - enter, reboot with:
Code: Select all
reboot -t now
Image
You're not drunk if you can lie on the floor without holding on.
--Dean Martin
MagnusB
Level 6
Level 6
 
Posts: 1255
Joined: Sun Nov 18, 2007 12:39 pm
Location: Norway

Re: put wrong video card driver now screen garbled

Postby 67GTA on Thu Jun 19, 2008 5:42 pm

The restricted driver would be
Code: Select all
fglrx
.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: put wrong video card driver now screen garbled

Postby leo5111 on Thu Jun 19, 2008 5:58 pm

ok kewl thanx :P
User avatar
leo5111
Level 4
Level 4
 
Posts: 312
Joined: Tue Mar 11, 2008 2:32 am
Location: Escaped From Xp Hell

Re: put wrong video card driver now screen garbled

Postby Cubby on Sun Jun 22, 2008 8:24 pm

Hi all,

This is the second install that when I restart or start up the computer, the log in screen resolution is huge, and when I log in, the desktop is huge. It started doing this today.
If I go to peripherals>monitor and as administrator or user I cannot slide the selector knob to increase the resolution -it's stuck at 640x480.
The only thing that I can think of that I've changed recently is today I changed the refresh rate from the default 60 Hz to 75 Hz to try and get rid of vertical lines where one notices the fonts aren't crisp in certain areas of the monitor (vertical banding). Also, the other difference was I used Firefox for the first time today and not the usual Konqueror browser. That is when the problem started. I noticed when I use the mouse to click on something, such as Bookmark manager, when I clicked on it, it wouldn't bring it up on the first click, I had to click more than a couple of times to get Bookmarks manager up. Then I logged off of internet, closed Firefox, and when I clicked on the Daryna KDE Community Edition icon in the left of the kicker, it wouldn't bring it up until after several clicks of the mouse.

So, I finished what I was doing, and turned off the computer. Starting it up, I had the huge font size problem where the screen was locked at 640 x 480. My screen resolution should be 1280 x 1024. So, I used MagnusB's suggestion (thanks MagnusB!) to start up in safe mode using nano to edit the xorg.conf file. I changed it to "vesa" but this only garbled the screen for me. Then I restarted again and in safe mode changed driver back to "nv" and then edited anywhere I saw 640 x 480@60 to 1280 x 1024@60, according to this link:
http://linuxfud.wordpress.com/2006/08/1 ... -try-this/
When I restarted computer according to MagnusB's information, the font login was back to normal, but when I got to desktop, the fonts and icons were huge as before, so I went into system settings>peripherals>monitor, and this time I was able to use the slider bar to up the resolution to 1280 x 1024.

I should add that in the past week I reinstalled Linux Mint KDE CE (because of this very reason for this X11 problem) and used aptitude to update and install all of the new stuff. It did give me warning about installing the latest Firefox, but I ignored it and updated it anyway. I'm just wondering if this has to do with Firefox from gutsy v.2.0.0.14, or maybe it has something to do with Flash that was installed when I updated. I really don't like Flash. Or, maybe it's because I changed the refresh rate to 75? I would like to avoid this problem in the future.

Maybe I should only get safe updates next time. After doing updates, I recently changed mintUpdate and unticked "safe packages, untested, but believed to be safe" to be on the safe side. :wink:

And update: I just started up the computer from a cold start, and am back to huge fonts in both the log in menu and desktop. I'm wondering where the problem lies? A bit frustrating. I guess I'll have to reinstall again. :|

Another update: Whenever I rebooted, a new xorg.conf file would be created. So, I reinstalled the os and this time I copied the three xorg.conf files after a fresh install with no updates. I then went to system settings>peripherals>monitor and as administrator I changed the gamma and that was it, I decided to not change the refresh rate to 75hz. So, I looked at the xorg.conf file again, and this time it had several modules listed and one thing I notice is that it doesn't have as an option, "1280x1024@75" , but there are many other options with different screen resolutions and refresh rates, but not this particular combination. So, I'm guessing that this is where the problem started. Since it's not listed in my config file, it isn't an option to select the 75mz refresh rate. So, remembered how I got rid of the slight vertical banding problem I had before in another Linux os, and so I in fonts I enabled anti-aliasing as well as sub-pixel rendering. Now my fonts are crisp and I didn't mess up the xorg.conf settings. Hoping this will all keep steady as she goes. I may do some updates after a week goes by. For now, I have these commented out to stay on the safe side:
Code: Select all
 Gutsy (Ubuntu 7.10)
#deb http://archive.ubuntu.com/ubuntu gutsy main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu gutsy-updates main restricted universe multiverse
#deb http://security.ubuntu.com/ubuntu gutsy-security main restricted universe multiverse

Regards, Lisa
Athlon 64 FX-57, Asus A8N-E, nForce4 chipset, video card NX8500GT GeForce, sound card bGears b-Enspirer w/ audio contlr: CMI8788 [Oxygen], 4G RAM, Sata WD hd 160G + 320G. Boot XP Pro nLite and a few other Linux distros.
Cubby
Level 2
Level 2
 
Posts: 72
Joined: Mon Apr 07, 2008 11:05 am
Location: Arkansas

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 11 guests