problem using all of SD card

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

problem using all of SD card

Postby WaltH on Mon Jun 30, 2008 11:28 pm

I recently installed Linux Mint 5.0r1, and I'm liking it so far, except for one quirk (at least I think it's a quirk). We recently bought a camera that uses SD cards, and we bought a 2.0GB card to go with it. I have a SanDisk reader which Mint recognizes just fine, but when I try to put files onto the card, it allows me to put 1.0 GB on it and then says the card it full even though the File Browser says there is 876 MB still available. Any idea how I can utilize that space? Thanks.

Walt
WaltH
Level 1
Level 1
 
Posts: 7
Joined: Wed Jun 18, 2008 8:15 pm

Linux Mint is funded by ads and donations.
 

Re: problem using all of SD card

Postby 67GTA on Tue Jul 01, 2008 2:28 pm

It's hard to say without actually playing with the card. Some of them have hidden folders on them from the factory, like trash folders. I have seen some that have more than one partition(2 1GB's). Make sure the hidden folders are set to be shown in nautilus while viewing the card, and see if there is something hidden on the card. If not, I would use the partition manager to reformat the whole card and see if you can make one big partition. It could be vfat, fat16, fat32. Just see what format it is in before you erase it, so you will know what filetype to reformat it in.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: problem using all of SD card

Postby WaltH on Wed Jul 02, 2008 12:35 am

I ran into the same problem with the card on my Windows machine at work. After some more searching on the net, I figured out it was the way the card was formatted. It was formatted as FAT. I reformatted it as FAT32. and I was able to use the entire card (at least at work). I think the problem is solved, but I'll need to check it on my home machines to be sure. Thanks.

Walt
WaltH
Level 1
Level 1
 
Posts: 7
Joined: Wed Jun 18, 2008 8:15 pm

Re: problem using all of SD card

Postby T J Tulley on Wed Jul 16, 2008 6:49 am

I've just bought a Fujifilm DCR2-161 card reader and two 2.1GB Olympus xD cards - the instructions say, format the card in your camera.

If cards are formatted in the card reader to suit the PC, perhaps there could be incompatibility with the camera?

I have difficulties which I'm describing in another post.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 15 guests