Touchpad Tapping - Stops working after suspend resume

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Touchpad Tapping - Stops working after suspend resume

Postby anandrkris on Sat Sep 14, 2013 1:38 am

Hi - I am using Mint Cinnamon (daily PPA) and after hibernate or suspend & resume and my laptop touchpad tapping stops working. Currently, have to enable it using synpatiks.
Any idea what could be the issue? Let me know if any more info is required. dmesg?

P.S. I use KDE as well but donot face this issue.
P.P.S For my USB Mouse, had an issue of USB disconnecting automatically. The below fixed the issue.
http://www.hecticgeek.com/2012/06/fix-usb-mouse-not-working-laptop-mode-tools-ubuntu/
Last edited by anandrkris on Mon Sep 23, 2013 9:48 am, edited 2 times in total.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 848
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Linux Mint is funded by ads and donations.
 

Re: Touchpad Tapping - Stops working after suspend resume

Postby gatb27 on Sat Sep 14, 2013 3:39 pm

I have the same issue: if i suspend my macbook air and then i open it, the touchpad and the keyboard don't work , i can only move the cursor but i can't tapping anywhere!
gatb27
Level 1
Level 1
 
Posts: 3
Joined: Sat Sep 14, 2013 1:31 pm

Re: Touchpad Tapping - Stops working after suspend resume

Postby anandrkris on Wed Sep 18, 2013 8:19 am

gatb27 wrote:I have the same issue: if i suspend my macbook air and then i open it, the touchpad and the keyboard don't work , i can only move the cursor but i can't tapping anywhere!
:(

Any pointers to solve this issue, please.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 848
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Touchpad Tapping - Stops working after suspend resume

Postby roblm on Fri Sep 20, 2013 7:42 pm

anandrkris,

I don't know the exact reason the touchpad tapping is disabled after resuming from suspend or hibernation but from what I've read,
it can be caused by a conflict with the mouse daemon.

What command are you using to restore the touchpad tapping action. Is it one of these?
synclient TouchpadOff=0
synclient TapButton1=1 TapButton2=2 TapButton3=3
User avatar
roblm
Level 5
Level 5
 
Posts: 601
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad Tapping - Stops working after suspend resume

Postby anandrkris on Mon Sep 23, 2013 9:40 am

Thanks for the command, was doing it through UI earlier with few annoying steps.
Any idea, how to auto-execute it after resume from hibernate / suspend? Novice here, need to add to some bash script?
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 848
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Touchpad Tapping - Stops working after suspend resume

Postby roblm on Mon Sep 23, 2013 4:48 pm

I assume you were using the command "synclient TouchpadOff =0". First copy the lines below:

#!/bin/sh
synclient TouchpadOff=0

Then create a script in your "/home/user-name" directory named ".touchpad-settings” or whatever. The dot in front of the file name makes it
hidden. Replace "user-name" with your real user name.

To do this type this command in the Terminal: gedit /home/user-name/.touchpad-settings
Paste the copied lines into this opened file. Save the file. Then right click on it and select > Properties > Permissions. Check the box next
to “Allow executing file as program”.

In the Terminal type this command, again substituting your real user name for “user-name”:

gsettings set org.gnome.settings-daemon.peripherals.input-devices hotplug-command "/home/user-name/.touchpad-settings"

Reboot and test your touchpad.
User avatar
roblm
Level 5
Level 5
 
Posts: 601
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad Tapping - Stops working after suspend resume

Postby anandrkris on Mon Sep 23, 2013 11:47 pm

Thanks a bunch, robim. :) Really grateful for your help. It worked after minor tweaking
Code: Select all
gsettings set org.cinnamon.settings-daemon.peripherals.input-devices hotplug-command "/home/anand/.touchpad-settings.sh"

I remembered that since am nightly PPA gnome-settings changed to Cinnamon settings.
Code: Select all
gsettings list-schemas
helped me get the exact name.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 848
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Touchpad Tapping - Stops working after suspend resume

Postby roblm on Tue Sep 24, 2013 8:53 am

anandrkris,

If you happen to look at this topic again, I noticed that you added the "sh" file extension to the end of the "touchpad-settings" file name. I left
it off this time because I didn't think it was needed to execute the command but did you find that it was required?
User avatar
roblm
Level 5
Level 5
 
Posts: 601
Joined: Sun Feb 24, 2013 2:41 pm

Re: Touchpad Tapping - Stops working after suspend resume

Postby anandrkris on Tue Sep 24, 2013 11:57 am

No...It is not required. Initially it was not working becuase i didnt not replace user-name with my name :( and I did not notice it. So while searching for schema solution, some tutorials had .sh so added it and did not bother to change later.
Cheers,
If there is a drive, there will be a path
User avatar
anandrkris
Level 5
Level 5
 
Posts: 848
Joined: Fri Nov 16, 2012 1:13 am
Location: Chennai

Re: Touchpad Tapping - Stops working after suspend resume

Postby wmichaelb on Sun Dec 22, 2013 4:26 pm

Thanks to both you gentlemen, I had a similar problem after an update.
wmichaelb
Level 1
Level 1
 
Posts: 41
Joined: Thu May 17, 2012 9:50 pm
Location: Cincinnati, Ohio

Re: Touchpad Tapping - Stops working after suspend resume

Postby jose44 on Tue Dec 24, 2013 1:40 pm

I added Petra backports to linux Mint 13, and lost some of the touchpad functions, until I found the solution given by robin at:
viewtopic.php?f=49&t=145054&p=799328&hilit=touchpad&sid=5db7e082d4590a906e14f3e121455ab4#p799328
I used the command "gsettings set" twice, because I had those two lines:
org.gnome.settings-daemon.peripherals.input-devices
org.cinnamon.settings-daemon.peripherals.input-devices
when I sent the command gsettings list-schemas.
Also anadrkris helped with his additional comments.
Thanks to both of them.
jose44
Level 1
Level 1
 
Posts: 1
Joined: Tue Dec 24, 2013 1:26 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot] and 14 guests