Touchkit touch and eGalaxy on Samsung Q1 Ultra - HELP!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Touchkit touch and eGalaxy on Samsung Q1 Ultra - HELP!

Postby yanosiq on Wed Sep 25, 2013 4:34 pm

Hello!


Does anyone know how to set up touchpanel monitor mounted in Samsung Q1 Ultra?

I have read much about evdrv.so and ev_touch.so drivers and tried everything.
Another non-working example:
https://ssl.webpack.de/www.conan.de/tou ... touch.html

Even original driver does not work. In this netbook everything is installed correctly with new Mint 15 but touchpanel.

Here is my xorg.conf after lifting:
Code: Select all
Section "Device"
   Identifier   "Configured Video Device"
   Driver      "vesa"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

### Touch Configuration Beginning ###
Section "ServerLayout"
        Identifier "Default Layout"
   Screen   "Default Screen"
#        InputDevice "EETI" "SendCoreEvents"
InputDevice "Touchkit touch" "CorePointer"
#InputDevice "dummy"
EndSection

# Section "InputDevice"
#    Identifier "dummy"
#    Driver "void"
#    Option "Device" "/dev/input/mice"
#EndSection

Section "InputDevice"
    Identifier "Touchkit touch"
    Driver "evtouch"
    Option "Device" "/dev/input/event2"
    Option "DeviceName" "Touchkit touch"
    Option "MinX" "98"
    Option "MinY" "43"
    Option "MaxX" "940"
    Option "MaxY" "925"
    Option "ReportingMode" "Raw"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    Option "SendCoreEvents" "On"
EndSection

#Section "InputDevice"
#        Identifier "EETI"
#        Driver "egalax"
#        Option "Device" "/dev/serio_raw0"
#        Option "Parameters" "/var/lib/eeti.param"
#        Option "ScreenNo" "0"
#        Option "SkipClick" "0"
#EndSection
### Touch Configuration End ###


As you see I've tried many ways to make it work.

Additional info, that everything is working fine with Windows XP. In linux the touch device is recognized as "Touchkit touch" and is visible in Start +> Settings => Mouse and touchpanel. But clicking x tick in configuration do nothing. Other mouses and keyboards work fine.

I tried to install evdrv and older version - evtouch, but nothing happens, I tried to assign touchpanel device to other input device in /usr/lib/... but still nothing.

Note that in Linux Crouchbang that I opened in live version from pendrive everything works fine. But it has other file structure than LM so I don't know where to find proper settings to copy it to Mint version.


Anyone can help me with this problem, please??? This is the only problem with Linux Mint I have on this netbook.
yanosiq
Level 1
Level 1
 
Posts: 3
Joined: Sun Sep 15, 2013 9:17 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot] and 11 guests