Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!

Postby T J Tulley on Wed Jul 16, 2008 7:24 am

My Fujifilm DCR2-161 card reader mounted when I first plugged it in, and showed as the media it contained - either 16 MB Fujifilm xD Picture Card or 2.1 GB (Olympus xD Picture Card (formatted in my Fujifilm 900 camera). At that time I added a folder and 2 sub-folders to it ready for adding pictures from my archives.

After a reboot, it will not mount - it shows (as the contained media) in "Computer" on the Desktop but if I R-click and select Mount volume, it reports: "Unable to mount the volume. Details: Mount_point cannot contain the following characters: newline, G_DIR_SEPARATOR (usually /)."

Properties says the permissions could not be determined, and in "Open with" I have added File browser and Image Viewer but it fails to open. Obviously it must first be mounted - which it did when first connected before re-booting (which was difficult, as reported elsewhere).

The specification of the card reader says it is compatible with Mac OS X without an added driver so it ought to work with Unix & Linux, I presume?

Edit- addition, 4.55 PM
I have had an idea - when the card reader was mounted, I went to Properties/Notes and amended Settings to give a Mount Point as /media/CardReader - in similar style to the already specified mount point. [Can't remember what that was].
Of course, there is a notice saying that new settings will not come into effect until next boot.
Now there appears to be no way to edit that specification. The Notes tab of Properties is blank.
Last edited by T J Tulley on Thu Jul 17, 2008 4:28 pm, edited 1 time in total.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Linux Mint is funded by ads and donations.
 

Re: Card reader won't mount in Elyssa [edited 4.55 pm]

Postby Mr. Blue on Thu Jul 17, 2008 4:38 am

I've heard of the G_DIR_SEPARATOR (usually /) error before.

If I'm remembering this right, setting the mount point in the gui's Properties tab must not contain /media/. It's already in there, just invisible :) . Only use the name of the mount point, i.e. CardReader.

Having the field blanked out is a bit of a problem though. Not sure how to fix that. I'll see if I can dig something up.

EDIT:

Found it. Thread on UbuntuForums: http://ubuntuforums.org/showthread.php?t=376404

StaticSage has this to say:

I had this same problem, only it was for my external hard drive. In the mount point, I entered /media/usbdisk because it was mounting as /media/disk.

I got the same error message, mount_point cannot contain the following characters: newline, G_DIR_SEPARATOR (usually /)

I found the setting by going Places | Computer. From there, was able to see my drive but it gave me that error when trying to mount. Right click | Properties | Volume Tab | Removed the mount point setting.

I found that if you want to change the mount point, you only have to put what it should be named. For instance, to have my disk mounted as /media/usbdisk, I put usbdisk into the box (an not the entire path).

Hope this helps someone!


Sounds like that should do it.
...and that should work...theoretically.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Re: Card reader won't mount in Elyssa [edited 4.55 pm]

Postby T J Tulley on Thu Jul 17, 2008 6:14 am

Thanks a lot Mr Blue.
Unfortunately, when I R-click on it in Computer, the Properties field doesn't include a Volume tab - the tabs are Basic, Emblems, Permissions, Open with and Notes. The last is where Mount point and Options appear for many objects, but for this it is now blank. Under Basic, the list is: Name: 2.1 GB Media; Type: unknown type' Size: unknown; Location: Computer:///; Volume: unknown; Mime type: application/octet-stream; Modified: unknown; Accessed: unknown
If I remove the xD Picture card, the entry in Computer disappears.
If I insert a smaller xD Picture card, it reappears, with Name: 16.4 MB Media.

So I can't see where I can edit my previous erroneous entry, which appears to be the reason for failure to mount now. Evidently it still exists - I need to access a table of devices. Where might that be?

I've just carefully examined the contents of /dev - one or two items might correspond, but no entries in Properties/Notes which might be edited.

Any more ideas?
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: Card reader won't mount in Elyssa [edited 4.55 pm]

Postby Mr. Blue on Thu Jul 17, 2008 7:33 am

Got it. I did the same to break my SD card and this brought it back.

http://howtoxyz.blogspot.com/2008/07/how-to-mountpoint-cannot-contain.html

From the post:

And this is what I did:

Open gconf-editor in terminal:
$ gconf-editor
In the left panel:
Goto:
system -> Storage -> volumes

Here you will see the mount point you specified for the device.
Change it to just a single word (OR just remove it :) )
Thats it. Replug your device.


Good Luck!
...and that should work...theoretically.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Re: Card reader won't mount in Elyssa [edited 4.55 pm]

Postby T J Tulley on Thu Jul 17, 2008 8:55 am

Thanks again Mr Blue:
$ gconf-editor -> System/storage/ shows no Volume, only default_options or drives.

Default_options are: hfs, iso9660, ntfs, ntfs3g, ntfs-fuse, udf, vfat
None of these look hopeful - they all show different responses on the RHS.

'Drives' opens to show:
/system/storage/drives/_org_freedesktop_Hal_devices_storage_serial_Generic_STORAGE_DEVICE_000000009144_0_1
and when selected this shows on the RHS:
/fstype_override [Value: ext3]
/mount_point [Value: which I edited to: CardReader].
Underneath were various entries, including a warning sign: This key has no Schema, and:
Key name: /system/storage/drives/_org_freedesktop_Hal_devices_storage_serial_Generic_STORAGE_DEVICE_000000009144_0_1/mount_point

Subsequently it still failed to mount, giving a long message including: In some cases useful info id found in syslog - try dmesg | tail or so

I found syslog in /var/log and sure enough there is an entry near the end:
Jul 17 10:41:25 TJT4Elyssa NetworkManager: <debug> [1216287685.228393] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/volume_part1_size_16363008').
The size obviously matches the smaller card then added - the larger one had previously been reported removed from the same address. Later in syslog I see:
Jul 17 12:50:57 TJT4Elyssa kernel: [ 8754.671098] VFS: Can't find ext3 filesystem on dev sdf1.

This suggests to me that I should edit the filesystem specified in gconf-editor - it needs to be something compatible with jpeg files. (But surely sdf1 is the floppy drive - no floppy in it).

More ideas?
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: Card reader won't mount in Elyssa [edited 4.55 pm]

Postby Mr. Blue on Thu Jul 17, 2008 9:15 am

This seems to work on this side.

You'll have to manually mount it from the command line. Then you'll have those volume options when right clicking in Computer. So here we go.

Make a mount point (just temporarily):

Code: Select all
sudo mkdir /media/a


Mount the card where x is the letter you probably saw in the dmesg output:

Code: Select all
sudo mount -t vfat /dev/sdx1 /media/a


I'm assuming there's just one partition.

Now you can go to Computer in nautilus, right click on the drive icon for the card, go to the Volume tab and remove the "ext3" entry.

Unmount the card:

Code: Select all
sudo umount /media/a


Things should be back to normal now. You can double click the icon to mount it through nautilus and you know how to set where you want the card mounted (NO /media/ :lol: ).

That should work. In theory, anyway.
...and that should work...theoretically.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Re: Card reader won't mount in Elyssa [edited 4.55 pm] -Solved!!

Postby T J Tulley on Thu Jul 17, 2008 4:26 pm

Thanks yet again, Mr Blue. We seem to have succeeded.

I studied the output of $ dmesg carefully - whole file, I removed the | tail from the command. I could see where the cardreader was recognised and identified as sdf then sdf1.

So I created the mount point as you suggested, and mounted it there. Its properties were then clearer - Basic gave a circular disk diagram showing more than half used - this is a small xD card with 8 large jpeg files on it. That page also showed the filetype as msdos. Permissions are still unknown (jn properties, but they show in /- filebrowser) and in the Open-with tab I added filebrowser.

Now I can open it fully and see the jpeg files; if I double-click on those they open with Gnome's Image Viewer, so all is well.

I tried to rename the new directory with the command $ mv /media/a /media/CardReader but the response was cannot move - Device or resource busy. I did think of using 'CardReader' where you had suggested 'a' - now I wish I had done so.

Next - I exchanged the card in the reader - change not shown. So I unmounted it, then changed the name of the mount point, and re-mounted it. Now it appears in /- filebrowser as /media/CardReader and its contents are as I originally created them - but it also contains an empty directory 'a' -without the quotes. So I entered a command to remove it, with response as follows:
theo@TJT4Elyssa / $ sudo rm /media/CardReader/a
rm: cannot remove `/media/CardReader/a': Is a directory

This doesn't matter much, but is annoying. I'm just being fussy. Thanks a lot.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!

Postby Mr. Blue on Thu Jul 17, 2008 8:56 pm

Glad it worked out.

It's probably giving the resource busy error either because there are files in use or you're in the directory in the terminal. Closing the files and/or changing out of the directory in the terminal should clear that up.

To get rid of the 'a' directory you can use the "rmdir" command instead of just "rm". This will remove an empty directory.

"rmdir" is fussy and won't delete a directory that contains files. For that you can use "rm -r", the -r being 'recursive', so it'll wipe out everything in the directory, including the directory itself. Just be sure you really, really want to use it before hitting enter.

So you told the file manager to mount the card on /media/CardReader when it auto-mounts, having it create the folder when mounted and remove it when unmounted. That means you probably still have /media/a persisting from what we did before. You can use the commands I mentioned above, just remember that /media belongs to root, so you'll have to use "sudo" before any commands you use. Be careful.

I also like to have my computer just the way I like it. Having things out of place annoys me too. :)

Enjoy the pictures!
...and that should work...theoretically.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Re: Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!

Postby T J Tulley on Fri Jul 18, 2008 8:55 am

Thanks again Mr Blue: Mystery deepens.

Continuing to be fussy, I am surprised this morning to find mounted 2 devices - CardReader, shown on desktop and in / -filebrowser as 2.1 GB, empty, modified 17/7/08, and CardReader_, shown likewise with contents as I originally installed them - this shows modifed 18/7/08, but the contents are dated 13/7/08 - so this is the 'real' one.
(The original contents are a directory dcim containing 2 empty directories family and friends - ready to receive photos).
It also contained the empty directory 'a' which I have successfully removed with $ sudo rmdir /media/CardReader_/a.

Now I can't remove the empty directory /CardReader - says it is busy, although I have closed filebrowser; it is represented by an icon on the desk top. I was first in /media, but then went to / but it is still busy. It is empty.

Is there a command which will show what a file or directory is busy with?

BTW, this is after resuming from hibernate, not after a full boot. When did the superfluous mount occur?

Well - after writing to there, I have unmounted CardReader (by command) - icon disappeared from Desktop - but trying to rename CardReader_ as CardReader finds it busy. AFIK its only 'activity' is being represented by an icon on Desktop. Here's the command & response:
theo@TJT4Elyssa / $ sudo mv /media/CardReader_ /media/CardReader
mv: cannot move `/media/CardReader_' to `/media/CardReader/CardReader_': Device or resource busy.

That looks as though it was trying to insert CardReader_ into CardReader whose icon has gone from Desktop, but in /-filebrowser it still appears, now with a white X over it - Properties now show it as total capacity 4.8 GB, 2.7 GB used (contents unreadable), 2.1 GB free - filesystem ext3.
Those 'Properties look as though CardReader_ has in fact been inserted into CardReader - though it still shows separately in the list.
I've just spotted that both CardReader versions are listed in .hal-mtab - but that record was probably written when the system opened, and is not updated. I've also been looking through syslog but it's difficult to make sense of that.

Sorry if I'm trying your patience.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!

Postby Mr. Blue on Fri Jul 18, 2008 12:28 pm

No need to apologise. This is why the forum's here.

The command "lsof" will 'list open files'. This will give way too much information by itself, so run it with the mount point, like this:

Code: Select all
lsof /media/CardReader


Note there must be no trailing / in the mount point name. /media/CardReader/ won't output anything.

From the sound of things /media/CardReader already existed, so Mint had to create /media/CardReader_ when it mounted the xDPictureCard. That's why CardReader_ is the real one with the files you expect to be there. Given that, I don't expect you'll get anything from using "lsof" on /media/CardReader.

I think since we don't care about CardReader we can just delete it. I understand it's empty and unused, correct? First remove your xDPictureCard from the reader so that nothing bad can happen to it.

Now I expect there is no /media/CardReader_ anymore. I also expect /media/CardReader will be there and still won't cooperate with the umount command. So we'll force it to unmount:

Code: Select all
sudo umount -lf /media/CardReader


That should unmount it. Now you'll be able to delete it leaving a clean /media folder (in terms of the card reader mount points).

Run the mount command and see if there are any references to the xD card lurking there. If so, unmount them (using force if they don't respond).

Now inserting the card will result in it being mounted in /media/CardReader with the folder /media/CardReader having been created on-the-fly, as well as a nifty desktop icon full of your pictures.

In theory, anyway. Best of luck!
...and that should work...theoretically.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Re: Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!

Postby T J Tulley on Fri Jul 18, 2008 4:01 pm

Thanks again Mr Blue: it's been cured in a different way.

A few days ago I was advised to avoid BusyBox by editing Menu-lst in Grub and a bit doubtfully I did so. As I said, I regularly use Hibernate, but today I decided it was time to try whether that worked, and whether other edits I have done to fstab would work. One does, but the editing of Menu.lst has failed to prevent resort to BusyBox: I had to use Supergrub several times before I got it to boot. I shall undo that edit, and continue to avoid re-booting by hibernating.

I had unplugged the card reader, so I re-connected it, and soon the icon appeared on the Desktop. Only one!
A double-click opens it to show CardReader - File Browser, containing the folder dcim - which opens to show family and friends. Family opens to show another folder which I created in it this morning.

Evidently the previous CardReader (second one created, empty) has disappeared and the original can take its name without the '_' - whoopee! I'm now having problems copying photos into those folders, but that will be another topic - probably in Software & Applications - and not immediately - there are other things I must work at.
Rapid edit: I couldn't resist looking at permissions.
$ cd /media; $ ls -l response included:
drw-r----- 3 root root 8192 1970-01-01 01:00 CardReader
It has refused to sudo chgrp or sudo chown; apparently sudo chmod 666 was accepted but it doesn't look like it here!

Warmest thanks for your help on this.
Last edited by T J Tulley on Fri Jul 18, 2008 4:19 pm, edited 1 time in total.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: Card reader won't mount in Elyssa [edited 4.55 pm] Solved!!

Postby Mr. Blue on Fri Jul 18, 2008 4:12 pm

My pleasure. Now go take some photos! :D
...and that should work...theoretically.
User avatar
Mr. Blue
Level 2
Level 2
 
Posts: 69
Joined: Sun Jul 13, 2008 9:25 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: Google Adsense [Bot], mlangston31 and 21 guests