VMWare Workstation Mouse Driver Problem *SOLVED*

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

VMWare Workstation Mouse Driver Problem *SOLVED*

Postby lger on Sat Jul 19, 2008 11:44 am

Are any of you running Mint as a workstation guest? Mouse works fine but the scroll wheel is not functioning. Here is the mouse section of my xorg.conf file:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
Option "CorePointer"
Option "Emulate3Buttons" "true"
Option "Device" "/dev/input/mice"
EndSection

I am using a Microsoft "Wheel Mouse Optical 1.1A USB and PS2 Compatible" Mouse. This mouse has left, right, and clickable middle scroll wheel buttons. Any help would be much appreciated. BTW.. I am running Elyssa with r1 downloaded and installed yesterday.

Thanx... Leon
Last edited by lger on Sat Jul 19, 2008 9:42 pm, edited 1 time in total.
lger
Level 1
Level 1
 
Posts: 8
Joined: Wed Jun 27, 2007 9:51 am

Linux Mint is funded by ads and donations.
 

Re: VMWare Workstation Mouse Driver Problem *SOLVED*

Postby lger on Sat Jul 19, 2008 9:41 pm

Just wanted to let everyone know that I did find a fix for this.... anyway it seems to be working on my machine so far. This fix was for Ubuntu Hardy on VMware Fusion but thought I'd give it a try anyway. Here's the link - http://peterc.org/2008/64-how-to-enable ... usion.html. Basically what it says - link may break - is to delete the mouse section in xorg.conf and replace it with this:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
EndSection

Hope that this helps someone else down the road. Seems like there are quite a few people having this problem but responses to their questions were hard to find.

Leon
lger
Level 1
Level 1
 
Posts: 8
Joined: Wed Jun 27, 2007 9:51 am

Re: VMWare Workstation Mouse Driver Problem *SOLVED*

Postby peter.cmai on Fri Aug 08, 2008 2:23 am

Many thanks. Worked for me too. Peter :D
peter.cmai
Level 1
Level 1
 
Posts: 12
Joined: Mon Mar 12, 2007 11:14 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 16 guests