Sound issue resurfaced in xfce

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Sound issue resurfaced in xfce

Postby anthony2010 on Mon Jul 21, 2008 2:06 pm

Hi all.

The sound has vanished again. Heres the output. Does anyone know what I can do to restore sound? I miss my music!!
I have the outpiut of lspci here:

00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6100 nForce 405 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Multimedia audio controller: C-Media Electronics Inc CM8338A (rev 10)

I have no idea what that all means! Will it be hard to keep sound with Linux? I remember it was fine with ubuntu 7.10, then 8.04 killed it. Mint 5 was fine but an upgrade killed it there too. It was ok with this xcfe yesterday but something has happenned to stop it again. maybe an upgrade?

If you can help I would be most grateful..
Anthony.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Linux Mint is funded by ads and donations.
 

Re: Sound issue resurfaced in xfce

Postby Husse on Wed Jul 23, 2008 7:12 am

This one
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
is in reality a rebranded Intel HDA
Solutions for intel HDA should apply and you find some in
viewtopic.php?f=49&t=14021&hilit=sound+hda#p87773
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sound issue resurfaced in xfce

Postby anthony2010 on Thu Jul 24, 2008 5:59 am

Thanks for that.

When I open modprobe and paste the text, it says 'cannot open file to write' so for some reason I cannot save the changes.

There seems to be no facility to put in a password or anything like that.

ant.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm

Re: Sound issue resurfaced in xfce

Postby Husse on Sat Jul 26, 2008 6:22 am

Did you forget to sudo?
Code: Select all
gksu mousepad /etc/modprobe.d/alsa-base

gksu for any GUI application
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Sound issue resurfaced in xfce

Postby anthony2010 on Sat Jul 26, 2008 7:48 am

Hi Husse.

Well I now have sound but after a few moments the screen freezes into a pattern of diagonal lines! Could this be my cpu on its way out or a glitch with multimedia software? When I try to play a dvd its the same.

I do have 2 sound cards, perhaps I should remove one? I'm afraid I'm very much a beginner here Husse and really do appreciate your help.

Regards.

Anthony.
anthony2010
Level 3
Level 3
 
Posts: 159
Joined: Tue Jul 01, 2008 7:31 pm


Return to Hardware Support

Who is online

Users browsing this forum: NissanNut and 9 guests