[Solved] USB Flash drives not mounting automatically.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

[Solved] USB Flash drives not mounting automatically.

Postby ikrshnan on Mon Dec 09, 2013 3:30 pm

I have updated LM 15 KDE to 16 using apt-get dist-upgrade.
Now it is not mounting USB Flash drives on connecting. It is getting mounted manually using 'mount' command but with read-only access.

Please help me to make it mountable on connecting the drive itself.
It was mounting all USB Flash drives perfectly before.

Also Dolphin is no longer showing external drives.
And bluetooth on my Lenovo G570 is also not working. Saying, no bluetooth adapter found.
Last edited by ikrshnan on Tue Dec 17, 2013 5:29 am, edited 1 time in total.
ikrshnan
Level 1
Level 1
 
Posts: 3
Joined: Sun Dec 08, 2013 4:35 am

Linux Mint is funded by ads and donations.
 

Re: USB Flash drives not mounting automatically.

Postby gold_finger on Wed Dec 11, 2013 12:06 am

Hello ikrshnan,
Since you haven't gotten an answer yet, I'll give it a shot. Not a KDE user but have KDE15 in VirtualBox and am guessing 16 works similarly.

Have you gone to Menu -> Computer -> System Settings -> Hardware -> Removable Devices? You can set how you want the system to handle mounting USBs and external drives there.

Under same "Hardware" heading, open "Driver Manager" and see if something shows up for your Bluetooth.

Not sure about the Dolphin problem.
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 7
Level 7
 
Posts: 1772
Joined: Mon Mar 11, 2013 11:39 pm

Re: USB Flash drives not mounting automatically.

Postby ikrshnan on Thu Dec 12, 2013 9:39 am

Thanks gold_finger for the reply,
In the path you have mentioned have found an option "Enable automatic mounting of removable media" which was disabled. Enabled it and also enabled other two options to "mount all removable media at login" and "automatically mount removable media when attached" and another one kept disabled to automatically mount only those removable medias which were mounted manually before. Also checked all "disconnected devices" to "Automount on attach".

Unfortunately still my flash drives are not mounting automatically.

For bluetooth I think I should go to hardware service centre. May be some hardware switch has been turned off inside. But still any other way to check for it will be helpful.

I have checked for all setting option of Dolphin. Can't understand why external drives are not showing up?

:( :(

gold_finger wrote:Hello ikrshnan,
Since you haven't gotten an answer yet, I'll give it a shot. Not a KDE user but have KDE15 in VirtualBox and am guessing 16 works similarly.

Have you gone to Menu -> Computer -> System Settings -> Hardware -> Removable Devices? You can set how you want the system to handle mounting USBs and external drives there.

Under same "Hardware" heading, open "Driver Manager" and see if something shows up for your Bluetooth.

Not sure about the Dolphin problem.
ikrshnan
Level 1
Level 1
 
Posts: 3
Joined: Sun Dec 08, 2013 4:35 am

Re: USB Flash drives not mounting automatically.

Postby gold_finger on Thu Dec 12, 2013 12:36 pm

ikrshnan wrote:In the path you have mentioned have found an option "Enable automatic mounting of removable media" which was disabled. Enabled it and also enabled other two options to "mount all removable media at login" and "automatically mount removable media when attached"


If these were disabled before, go ahead and enable them. If no immediate effect, reboot system and see if attaching a USB now works and if Dolphin now shows external drive(s).
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 7
Level 7
 
Posts: 1772
Joined: Mon Mar 11, 2013 11:39 pm

Re: USB Flash drives not mounting automatically.

Postby ikrshnan on Tue Dec 17, 2013 5:28 am

First of all apologies for the delay.

I did enable it even before you told me to do. At first it did not worked though I restarted my computer.
Now it is working fine. All USB Flash drives are getting mounted automatically. And Dolphin showing up all external drives now.
I have no idea how did it happened. A small system update was there. I think that may have solved the issue.

Thanks for the help gold_finger.

gold_finger wrote:
ikrshnan wrote:In the path you have mentioned have found an option "Enable automatic mounting of removable media" which was disabled. Enabled it and also enabled other two options to "mount all removable media at login" and "automatically mount removable media when attached"


If these were disabled before, go ahead and enable them. If no immediate effect, reboot system and see if attaching a USB now works and if Dolphin now shows external drive(s).
ikrshnan
Level 1
Level 1
 
Posts: 3
Joined: Sun Dec 08, 2013 4:35 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 16 guests