Keyboard and Touchpad unresponsive at boot - SOMETIMES

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Keyboard and Touchpad unresponsive at boot - SOMETIMES

Postby pizzadragon on Wed Dec 11, 2013 9:43 pm

I'll second that bump. I've got a similar laptop to the OP, and I've got the exact same problem you all are having.

I've got a Toshiba l775d-s7340 with an AMD A6-3400M. I'm running LM 16 Petra with Cinnamon v2.0.14 and Linux Kernel 3.11.0-12-generic, and I've got seemingly random intermittent detection of the keyboard/trackpad, but without rhyme or reason to it.

I installed 16 as a release candidate a week before release and followed the upgrade insructions which seemed to go well. Advice from IRC recommended I do a fresh install of the official release, so I tried but when I booted into the Live USB Installer the keyboard and trackpad were not detected at all!

I have little knowledge of how to troubleshoot a problem like this but if/when I figure any of this out I'll post back as you're the first lot I've found online with this issue.

Also, I dual booting with crunchbang which has been my go-to distro for the past year and it's been almost 100% on this same laptop, but about 2% pf the time I get the same kayboard/trackpad issue that I have more frequently on Mint.

Now it's time to learn how these drivers are implemented and where to hunt for log errors.

Wish me luck!
pizzadragon
Level 1
Level 1
 
Posts: 2
Joined: Mon Mar 19, 2012 9:57 pm

Linux Mint is funded by ads and donations.
 

Re: Keyboard and Touchpad unresponsive at boot - SOMETIMES

Postby roblm on Fri Dec 13, 2013 4:20 pm

Try adding this kernel parameter to the GRUB boot file: i8042.nomux=1
Type this command in the Terminal to open the file: gksudo gedit /etc/default/grub

Change the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux=1"
Save the file. Open the Terminal and type: sudo update-grub
Reboot.

Sometimes making changes to the GRUB file can cause startup problems. If this happens then restart and select the correct line
at he GRUB boot menu but don't press Enter. Press the “e” key to edit. If no menu is displayed then hold down the Shift key
while restarting.

Go down to the line that starts with: linux /boot/vmlinuz.......................ro quiet splash $vt_handoff
Remove the parameter you added between the words “splash” and “$vt_handoff”
Press Ctrl+X. This change is just temporary and allows you to start your system. Then remove the parameter in the
“/etc/default/grub” file and run this command in the Terminal: sudo update-grub
User avatar
roblm
Level 4
Level 4
 
Posts: 434
Joined: Sun Feb 24, 2013 2:41 pm


Return to Hardware Support

Who is online

Users browsing this forum: Google Adsense [Bot], Yahoo [Bot] and 16 guests