Crazy keyboard on terminal

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Crazy keyboard on terminal

Postby vendramini on Fri Dec 20, 2013 8:03 pm

Hi, guys!

A strange thing is happening here. After I tried to change my keyboard layout (System Settings -> Hardware -> Keyboard) my keyboard was completely disorganized. For example:
The letter "q" turned in "/"
"w" in ";"
"s" in "o"
"/" in "z", and so on...

Was impossible to login and type password, so I booted from live usb to edit some files with sudo su and try to solve it.
After editing some files, I "solved" the problem. "Solved", because when Mint starts and shows me the login page, the first time I type my password the keyboard layout is wrong. After first time, it works.

Also, if I do ctrl+alt+f1 to tty1, it's completely wrong too.

But as I said, it's normal now (I'm typing, lol).

I tried to change a lot of file, but nothing works. Some idea?

Thanks.

Forgot: I'm using Mint 16, installed 2 days ago. It's a clean system yet.
vendramini
Level 1
Level 1
 
Posts: 2
Joined: Fri Dec 20, 2013 7:53 pm

Linux Mint is funded by ads and donations.
 

Re: Crazy keyboard on terminal

Postby renatov on Sat Dec 21, 2013 1:21 am

Which files have you edited and what have you done exactly? What is your hardware (keyboard brand and model, PC/notebook configuration etc)? I hope this isn't another case of demonic possession we've been seeing lately :D
User avatar
renatov
Level 2
Level 2
 
Posts: 62
Joined: Mon Mar 25, 2013 8:45 am

Re: Crazy keyboard on terminal

Postby vendramini on Sat Dec 21, 2013 12:00 pm

Thanks for reply!

I edited /etc/default/keyboard, here it's:

Code: Select all
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

#XKBMODEL="pc105" //I commented this line
#XKBLAYOUT="us" //and this
#XKBVARIANT="qwerty" //this
#XKBOPTIONS="terminate:ctrl_alt_bksp" //this

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz
KMAP=/usr/share/keymaps/i386/qwerty/us.kmap.gz //added this line


Also /etc/X11/xorg.conf:

Code: Select all
Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbRules" "xorg" //added
    Option         "XkbModel" "pc105" //added
    Option         "XkbLayout" "us" //added
    Option         "XkbVariant" "qwerty" //added
EndSection


It's a notebook; the keyboard is this one: http://avell.com.br/media/catalog/produ ... 5g_1_1.jpg

Thanks!
vendramini
Level 1
Level 1
 
Posts: 2
Joined: Fri Dec 20, 2013 7:53 pm

Re: Crazy keyboard on terminal

Postby mytux on Fri May 02, 2014 3:51 pm

I have the same problem with my my laptop Asus X301A, with all releases of Linuxmint and Manjaro.
Maybe the problem come when your laptop support the UEFI firmware, I try to install the intel-microcode and make a safe-upgrade with aptitude.

It's a bug ? I hope the problem will solved in Qiana.
User avatar
mytux
Level 1
Level 1
 
Posts: 3
Joined: Wed Jun 26, 2013 3:37 pm
Location: France


Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot], HarrisCreekCentral and 10 guests