ATI Rage Pro: Different drivers for 'Live' and installation?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

ATI Rage Pro: Different drivers for 'Live' and installation?

Postby derlinzer on Mon Aug 18, 2008 11:10 pm

I started Elyssa in 'Live' mode on an older PC with an integrated ATI Rage Pro graphics card. My monitor has a resolution of 1680x1050 and Elyssa used the correct resolution and looked fine.

After installation however, i'm stuck with a flickering max of 1440x1050 and find no way to change that to my monitors native resolution.

Now i wonder, if Elyssa uses different drivers in 'Live' mode and after installation and how i can setup my monitor/graphics card correctly.
See, i told you they'd listen to Reason* - Fisheye
*Gatling-type 3-mm hypervelocity railgun system
User avatar
derlinzer
Level 1
Level 1
 
Posts: 12
Joined: Tue Aug 05, 2008 9:05 am
Location: Linz, Austria

Linux Mint is funded by ads and donations.
 

Re: ATI Rage Pro: Different drivers for 'Live' and installation?

Postby Husse on Tue Aug 19, 2008 6:05 am

This is interesting - I did not think so - but the live CD could use the "radeon" driver
As this is an old card you'd need a legacy driver and I'm not sure if ATI even has drivers for that vintage
Check in /etc/X11/xorg.conf under Section Device which driver is in use - if it says "vesa" that's the explanation
If so change it to "radeon" and hopefully you are ok.
Restart X for the change to take effect - ctrl+Alt+backspace
If it says "radeon" already post back and we'll have to look at it a bit more
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: ATI Rage Pro: Different drivers for 'Live' and installation?

Postby derlinzer on Wed Aug 20, 2008 8:47 am

I did a new clean install and now for whatever reason the right resolution is now used. The mentioned section reads

Code: Select all
Section "Device"
   Identifier   "Configured Video Device"
EndSection
User avatar
derlinzer
Level 1
Level 1
 
Posts: 12
Joined: Tue Aug 05, 2008 9:05 am
Location: Linz, Austria

Re: ATI Rage Pro: Different drivers for 'Live' and installation?

Postby Husse on Wed Aug 20, 2008 11:46 am

Ok - remember my signature
x has been completely remade with Elyssa and works much better now,
Perhaps if the standard open driver is used it is not mentioned in xorg.conf
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: Reorx and 17 guests