My Micromax 377G dongle isn't working on Linux Mint 16

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

My Micromax 377G dongle isn't working on Linux Mint 16

Postby Petrauser on Sun Apr 27, 2014 3:17 pm

I am a new user of Linux. Currently, I am using Linux Mint 16 xfce on USB drive. However, my micromax 377G dongle isn't being detected on Linux.
I read a few articles, and learnt about usb_modeswitch. I installed it, but my dongle is still undetected.
So, guys, please tell me what I can do.
Petrauser
Level 1
Level 1
 
Posts: 5
Joined: Sun Apr 27, 2014 2:57 pm

Linux Mint is funded by ads and donations.
 

Re: My Micromax 377G dongle isn't working on Linux Mint 16

Postby xenopeek on Sun Apr 27, 2014 4:51 pm

Linux Mint is compatible with Ubuntu, and Ubuntu has a much larger user base. Please search for hardware issues first with adding the keyword "Ubuntu", to get relevant hits (I searched "Ubuntu Micromax 377G" and got immediate seemingly helpful hits). If that doesn't get you anywhere, search with keyword "Linux" instead of "Ubuntu".

This seems to be what you need: http://code-cocktail.in/micromax-3g-dat ... on-ubuntu/

The modem comes with drivers embedded on the device. That post seems to be the steps for accessing and installing the drivers from the device itself.

You may have to undo what you have done yourself so far.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14557
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: My Micromax 377G dongle isn't working on Linux Mint 16

Postby Petrauser on Mon Apr 28, 2014 7:55 am

Thank you for replying. I visited the link u put in ur reply. The codes provided there are for Ubuntu , I guess. I tried to run them on terminal emulator and got weird responses, like fine not found, no such command, etc. What should I do?
Petrauser
Level 1
Level 1
 
Posts: 5
Joined: Sun Apr 27, 2014 2:57 pm

Re: My Micromax 377G dongle isn't working on Linux Mint 16

Postby xenopeek on Mon Apr 28, 2014 7:59 am

You typed the > character in front of the commands, didn't you? That is commonly used to indicate the terminal prompt. Don't type it...
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14557
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: My Micromax 377G dongle isn't working on Linux Mint 16

Postby Petrauser on Mon Apr 28, 2014 11:08 am

xenopeek wrote:You typed the > character in front of the commands, didn't you? That is commonly used to indicate the terminal prompt. Don't type it...


Well, it worked and I connected te the internet.However, when I installed mint, it deleted all the files frm D and F drive. To connect, I tried to all the procedure again, but the second and the third code is not working, now, after intallation.Yes, the second and third code given in the ling u mentioned in ur 1st comment.It deleted winxp frm drive E also.So, I can't even connect to the internet, now.m on phone.I donno what to do.Please help
Petrauser
Level 1
Level 1
 
Posts: 5
Joined: Sun Apr 27, 2014 2:57 pm

Re: My Micromax 377G dongle isn't working on Linux Mint 16

Postby austin.texas on Mon Apr 28, 2014 6:42 pm

Boot your usb drive with Mint 16 xfce on it.
Open the file manager and see if you can read the hard drive partitions.
Mint 17 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 9
Level 9
 
Posts: 2629
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: My Micromax 377G dongle isn't working on Linux Mint 16

Postby Petrauser on Wed Apr 30, 2014 4:50 am

Well, now everything is fine and working. Thanks every1.
However, when I type this code -" ls /dev/tty* " to check the com ports , the last four lines don't appear until I unplug and plug my dongle again. When I was using xp, I never unplugged my dongle. Now, I have to unplug it and plug again every time I boot. Is there anyway I can resolve this.
Petrauser
Level 1
Level 1
 
Posts: 5
Joined: Sun Apr 27, 2014 2:57 pm

Re: My Micromax 377G dongle isn't working on Linux Mint 16

Postby Petrauser on Wed Apr 30, 2014 5:08 am

or is there anyway i can get connected automatically every time i log in?
Petrauser
Level 1
Level 1
 
Posts: 5
Joined: Sun Apr 27, 2014 2:57 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 19 guests