Completed but not printing. (FIX - Laserjet P1005)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Completed but not printing. (FIX - Laserjet P1005)

Postby dashyr on Wed Apr 30, 2014 5:57 pm

I found a lot of discussion about it but never really found a clear answer. It ended up being quite simple in the end. I guess I'll just post it here so it might be useful for someone who had the same problem as me. The problem being Mint 16 saying the print is completed but the printer actually did nothing. Looks like the included hplip is faulty and/or incompatible with this printer.

Download the latest HPLIP drivers from here.
Current version is 3.14.4

Once downloaded, open a terminal inside your download folder. (Right-Click + Open in terminal)
Then type this command. sh (Change version number to current version)

Make sure you overwrite and/or update every file as asked. When they ask you what to do with the old hplip installed, type i. (Remove and Re-install)

This fixed it for me. I hope this will help someone. :)
Level 1
Level 1
Posts: 1
Joined: Wed Apr 30, 2014 5:43 pm

Linux Mint is funded by ads and donations.

Re: Completed but not printing. (FIX - Laserjet P1005)

Postby enero on Mon Jun 02, 2014 6:31 pm

hei !
thanx a lot for your HELP !
It worked for me just perfect !
although i had a different symptoms. But the printers name&number are just the same so it seems that you found a perfect solution.
Thanks again for sharing it ! :D :D :D :D
Level 1
Level 1
Posts: 8
Joined: Wed Mar 19, 2014 5:27 am

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 12 guests