[SOLVED]Mouse centralbutton dragging nt working(auto-scroll)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

[SOLVED]Mouse centralbutton dragging nt working(auto-scroll)

Postby ElStellino on Wed Apr 30, 2014 8:08 pm

One thing I never made work in Linux is the fast scrolling dragging the mouse, keeping pressed the scroll wheel. It's actually something that I would use quite a lot, and I feel a bit of an amputee.

What I get with xinput is that the button 2 gets pressed and released, and now also types the useless command I just found in a ubuntu site:
Code: Select all
button pressed 2
gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true
button released 2


Pressing it on links it opens the link in a new tab, but I can't drag up and down a whole webpage just keeping it pressed.

Any help would be really appreciated. Thanks!

Oh, the mouse is a standard Logitech Mouseman USB, laser. (M-BT83)
Last edited by ElStellino on Sun Dec 20, 2015 7:47 am, edited 2 times in total.
Anagram:
ImageImage
That’s Rafaela, Santa Fe, Argentina.
Turn your monitor for the solution: uoɯɐuuıɔ 9 ɐlǝɐɟɐɹ ʇuıɯ xnuıႨ

Hardware: Core i3 530 2.93Ghz ‑ 4Gb Ram Dual Channel.
User avatar
ElStellino
Level 2
Level 2
 
Posts: 65
Joined: Thu Nov 08, 2012 9:54 am
Location: Tenerife

Linux Mint is funded by ads and donations.
 

Re: Mouse central button dragging not working

Postby ElStellino on Fri May 02, 2014 11:38 am

Okay, I then researched better, and first of all the function I want is called auto‑scrolling.
Already knowing what the name of what you want is helps you by a long shot, so I just duckduckwent it.

For future reference, and for the odd person like me who may want the same feature in the future, it's something within the programs one is using, not the OS.
Apparently, in Windows all the programs have the auto‑scrolling enabled by default, but it is not so in Linux, where one has to set it manually for each program.

In Firefox, Preferences, Advanced, General tab, enable Use autoscrolling
In Opera, it's not possible to chose an option, but there is an extension for it (https://addons.opera.com/en/extensions/details/autoscroll/?display=en).
In LibreOffice Tools, Options, LibreOffice, View, and under Mouse change Mouse middle button from "Paste Clipboard" to "Automatic scrolling"
In Chrome this isn’t possible within the browser. Searching on the net there are just frustrated people who want to disable it, so you won’t find much help there. I found however this extension that will help, designed especially for Linux and Mac, that apparently has the same problem: https://chrome.google.com/webstore/detail/autoscroll/occjjkgifpmdgodlplnacmkejpdionan?utm_source=chrome-app-launcher-info-dialog

I don't use any other program where I may want to use it, so I'll just leave this one here.

Marked as [SOLVED]
20151220 Edit: added Chrome as I now use also this browser.
Anagram:
ImageImage
That’s Rafaela, Santa Fe, Argentina.
Turn your monitor for the solution: uoɯɐuuıɔ 9 ɐlǝɐɟɐɹ ʇuıɯ xnuıႨ

Hardware: Core i3 530 2.93Ghz ‑ 4Gb Ram Dual Channel.
User avatar
ElStellino
Level 2
Level 2
 
Posts: 65
Joined: Thu Nov 08, 2012 9:54 am
Location: Tenerife


Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot] and 16 guests