Second graphic card not detected

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Second graphic card not detected

Postby jibe on Wed Sep 10, 2008 10:20 am

Hi,

I need 2 screens, and installed a second graphic card on my computer. But when I installed Elyssa, only the onboard graphic interface was detected. I can get my second graphic card working if I modify xorg.conf, but I can't find a way to have the 2 screens working properly...

Here is my config :
- P5GC-MX/I333 motherboard with onboard G945 Graphic controller,
- SiS 6326 PCI Graphic card.
- Asus VW192S LCD 1440x900 monitor connected on the onboard controller,
- IBM E74 CRT monitor connected on the SiS PCI card

What I tried :
- xinerama with i810 driver : I can get the 2 screens working, but cannot have the resolutions I want. I can have 1440x900 on the LCD, but the quality is bad (when it was perfect after the first install, and I can get the same quality using only one screen and the intel driver instead of i810).
- xinerama with intel driver : Impossible to have it working... I get an error with DRI, even if I disable it in the "module" section...
- xrandr sees only one screen. Seems that version 1.2 is not able to work with 2 video cards ?

Any suggestion ?
User avatar
jibe
Level 2
Level 2
 
Posts: 68
Joined: Thu Dec 28, 2006 4:31 pm

Linux Mint is funded by ads and donations.
 

Re: Second graphic card not detected

Postby jibe on Wed Sep 10, 2008 3:24 pm

Finally, I found a good solution, with totally independant screens :D

Here is my xorg.conf (I did nothing more than adjusting it) :
Code: Select all
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "fr"
#   Option      "XkbVariant"   "oss"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "Device"
   Identifier   "Onboard Video Device"
   Boardname   "Intel 945"
   Vendorname   "Intel"
   Busid      "PCI:0:2:0"
   Driver      "intel"
   Screen      0
   Option      "MetaModes" "1440x900-1280x1024 1024x640-800x600"
EndSection

Section "Device"
   Identifier   "SiS 6326"
   Boardname   "SIS"
   Busid      "PCI:1:1:0"
   Driver      "sis"
EndSection

Section "Monitor"
   Identifier   "Asus VW195S"
   Vendorname   "Asus"
   Modelname   "VW195S"
EndSection

Section "Monitor"
   Identifier   "IBM E74"
   Vendorname   "IBM"
   Modelname   "IBM 6332 E74"
   Horizsync   30.0-69.0
   Vertrefresh   50.0-130.0
  modeline  "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
  modeline  "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
  modeline  "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Asus VW195S"
   Device      "Onboard Video Device"
   Defaultdepth   24
   SubSection   "Display"
      Depth   24
      Modes   "1440x900" "1280x800" "1024x640"
   EndSubSection
EndSection

Section "Screen"
   Identifier   "Second Screen"
   Device      "SiS 6326"
   Monitor      "IBM E74"
   Defaultdepth   16
   SubSection "Display"
      Depth   16
      Modes   "1280x1024@60" "1152x864@75" "1024x768@85" "800x600@85" "640x480@85"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen" 0 0
   Screen      "Second Screen" LeftOf "Default Screen"
#   Screen      "Second Screen"
EndSection

Section "Module"
   Load      "glx"
   Load      "GLcore"
   Load      "v4l"
EndSection

Section "ServerFlags"
EndSection
User avatar
jibe
Level 2
Level 2
 
Posts: 68
Joined: Thu Dec 28, 2006 4:31 pm


Return to Hardware Support

Who is online

Users browsing this forum: deathwiz and 8 guests