Broadcom wireless support on Mint 17

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Broadcom wireless support on Mint 17

Postby 170pte on Thu Jun 05, 2014 11:21 am

I have a Dell 1501 and was using Mint 15 without problems. I want to install Mint 17 because of LTS. I did dual install on another partition to try and the wireless card ins not listed in the network interfaces. I searched the web and tried many solutions, mostly from Ubuntu forums. I tried Ubuntu 14 live CD and got the same problem. I think it is related to the change of kernel between Mint 15 and 17. The last thing I tried was ndiswrapper instructions from a Ubuntu forum :http://ubuntuforums.org/showthread.php?t=760568

the result of mintWifi is:

* I. scanning WIFI PCI devices...
-- Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
==> PCI ID = 14e4:4311 (rev 01)
-------------------------
* II. querying ndiswrapper...
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)
-------------------------
* III. querying iwconfig...[/color]
wlan0 IEEE 802.11bg ESSID:"bingo"
Mode:Managed Frequency:2.437 GHz Access Point: C8:D3:A3:57:B6:CD
Bit Rate=48 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=54/70 Signal level=-56 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:161 Missed beacon:0

lo no wireless extensions.

-------------------------
* IV. querying ifconfig...
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:666 errors:0 dropped:0 overruns:0 frame:0
TX packets:666 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:62900 (62.9 KB) TX bytes:62900 (62.9 KB)

wlan0 Link encap:Ethernet HWaddr 00:c0:ca:27:b4:33
inet addr:192.168.51.104 Bcast:192.168.51.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:caff:fe27:b433/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4583 errors:0 dropped:0 overruns:0 frame:0
TX packets:1534 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1677510 (1.6 MB) TX bytes:272715 (272.7 KB)

I am using a USB Wifi adapter because the ndiswrapper installation disabled my ethernet connection too.

Anyone knows how to enable this Broadcom Wifi card in Mint 17 (Cinnamon 32) ?
170pte
Level 1
Level 1
 
Posts: 3
Joined: Sat Sep 14, 2013 3:09 pm

Linux Mint is funded by ads and donations.
 

Re: Broadcom wireless support on Mint 17

Postby 170pte on Thu Jun 05, 2014 12:02 pm

Solution:

I found a solution here:
http://askubuntu.com/questions/55868/in ... ss-drivers

I followed these steps from the post above:

make sure that the firmware-b43-installer and the b43-fwcutter packages are installed (of course you will need internet by others means):

sudo apt-get install firmware-b43-installer b43-fwcutter

type into terminal:

cat /etc/modprobe.d/* | egrep 'bcm'

(you may want to copy this) and see if the term 'blacklist bcm43xx' is there

if it is, type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf

put a # in front of the line: blacklist bcm43xx

then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly).

reboot
170pte
Level 1
Level 1
 
Posts: 3
Joined: Sat Sep 14, 2013 3:09 pm

Re: Re: Broadcom wireless support on Mint 17

Postby JeremyB on Thu Jun 05, 2014 3:09 pm

170pte wrote:Solution:

I found a solution here:
http://askubuntu.com/questions/55868/in ... ss-drivers

I followed these steps from the post above:

make sure that the firmware-b43-installer and the b43-fwcutter packages are installed (of course you will need internet by others means):

sudo apt-get install firmware-b43-installer b43-fwcutter

type into terminal:

cat /etc/modprobe.d/* | egrep 'bcm'

(you may want to copy this) and see if the term 'blacklist bcm43xx' is there

if it is, type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf

put a # in front of the line: blacklist bcm43xx

then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly).

reboot

The terminal errors were likely caused by using sudo gedit instead of gksudo edit

Good job of figuring the broadcom out. I believe obuntuforums has a sticky on what package you need for a lot of broadcom in networking
JeremyB
Level 5
Level 5
 
Posts: 934
Joined: Fri Feb 21, 2014 8:17 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 11 guests