constant HD scratching (and a short story) solved

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

constant HD scratching (and a short story) solved

Postby Azraiyl on Sat Sep 20, 2008 3:17 am

Hello,

I've solved a problem myself and only like to share it with others.

I've a 4 year old laptop at home with a Mobility FireGL 7800 graphic card with 2 GHZ CPU and 500 MB ram. Till recently there was a Gentoo on it and I had no problem with it. Because of the constantly increasing compile time I thought that know it's time to switch to a binary package distribution and finally came to Mint. The install process went very fine, not counting the fact that Grub was not able to setup on a XFS partition (kill Grub in the background aborted the whole installation). I were using XFS together with Grub as boot manager on Gentoo and never had the slightest problem (Thats the reason why I was choosing this option although there was a warning). After installing Grub myself there is no problem since then. The only thing I do not understand here why Mint has a problem with it.
Next step, I tried to enable direct rendering (because it was working with Gentoo). But I'm still not able to activate it (EnvyNG and modifying xorg.conf manually a lot).

This was the short story, nothing is worth more than a note, but then there was my real problem. My hd were constantly scratching, about every 5 seconds. After searching the web, I saw the Ubuntu forums e.g. are full of such threads. If anyone else has your problem it may be easy to solve, I thought. Here is everything I tried to do.

- Increase "hdparm -B" parameter
- assure that "Search and Indexing" is disabled
- Monitoring "Load_Cycle_Count" with the smartctl from the smartmontools.
- Disabled acpi services.
- Installed iotop to see if there is a process constantly reading or writing (but there was none!).
- Stopped klogd and sysklod.
- Monitoring "free -m".
- Disabled swap.

Then I tried to manually stop all possible services. After all, the bad service was /etc/init.d/aiteventsd from the xorg-driver-fglrx package. After removing this package my laptop is as quiet as before. Maybe any of this above written steps helps anyone.

Azraiyl
Azraiyl
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 20, 2008 2:48 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: SJLPHI and 23 guests