how do I blacklist USB 2.0 driver? solved

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

how do I blacklist USB 2.0 driver? solved

Postby fudda on Sun Sep 21, 2008 7:35 am

Hi,

I have the following problem:

When USB 2.0 is enabled on my mainboard Elyssa wont boot. Hangs up on BusyBox. Though I have figured out that when I uninstall USB host controllers from Windows, (I have a dual boot) Elyssa boots just perfectly right until I load Windows XP for the next time and install (automatically) all the USB host controllers again. After that Elyssa wont boot again. So here's my thought/question:

Cant I just blacklist the USB 2.0 driver from Elyssa so it wont load at boot but after the OS is fully loaded? Kind of like I had to do with the Broadcom WLAN driverson my notebook? If this is possible then please help me findout how.

But if you know a better work around or yet even a solution for this problem, please let me know.

Thank you all in advance for any type of help.

fudda
fudda
Level 1
Level 1
 
Posts: 22
Joined: Thu Jun 12, 2008 10:21 am

Linux Mint is funded by ads and donations.
 

Re: how do I blacklist USB 2.0 driver?

Postby Husse on Mon Sep 22, 2008 6:18 am

This is far from ideal
To blacklist USB - and this is all USB!
Code: Select all
echo "blacklist usbcore" | sudo tee -a /etc/modprobe.d/blacklist

Then when you have booted restore USB
Code: Select all
sudo modprobe usbcore

Hopefully this loads ohci_hcd and ehci_hcd as well
If you experience problems modprobe these too
No guarantees given...
This is perhaps possible to script and make automatic, but first we must know if it works at all
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: how do I blacklist USB 2.0 driver?

Postby fudda on Mon Sep 29, 2008 5:20 am

Hi, thanks for the reply.

No it actually didnt work. After digging deeper for the error I found out that it was the:

IRQ 19 : nobody cared issue

Obviously USB 2.0 and my Harddrive were assigned same IRQ because it did either boot with USB onboard disabled from HDD or with my harddrive unplugged from Live CD.

Tried irqpoll like it told me too. That did only work after I disabled the "assign IRQ to USB" option in my BIOS. -.-

Now it boots and everything seems to be working fine. Although I have read on several forums that irqpoll would slow down the machine and network performance.

Is there another way to fix this besides booting with irqpoll option?
fudda
Level 1
Level 1
 
Posts: 22
Joined: Thu Jun 12, 2008 10:21 am

Re: how do I blacklist USB 2.0 driver?

Postby Husse on Mon Sep 29, 2008 5:46 am

after I disabled the "assign IRQ to USB" option in my BIOS.

Maybe you don't need irqpoll now?
But it's no big problem to use irqpoll
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: how do I blacklist USB 2.0 driver? solved

Postby fudda on Mon Sep 29, 2008 9:16 am

I had that thought too that maybe I wouldnt need irqpoll then, but I need it although I turned that option off. Weird... :/

But if you say that booting with irqpoll isnt a problem you have taken my worries ;)

Thank you for your help.
fudda
Level 1
Level 1
 
Posts: 22
Joined: Thu Jun 12, 2008 10:21 am


Return to Hardware Support

Who is online

Users browsing this forum: all41, DaComboMan and 15 guests