AAO (Acer Aspire One) wifi and sound not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

AAO (Acer Aspire One) wifi and sound not working

Postby eztuxer on Tue Sep 23, 2008 9:33 am

Daryna (4) installed fine, but no sound or wifi.
Downloaded Alyssa (5), but install stalls.
Is there a way I can upgrade from that iso ? (ie: without web acces).
[user@localhost ~]$ lspci
00:00.0 Host bridge: Intel 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel 82801G (ICH7 Family) HD Audio Controller: Realtek ALC662G/268 (rev 02)
00:1c.0 PCI bridge: Intel 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Ethernet controller: Realtek RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Ethernet controller: Atheros AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
[user@localhost ~]$
eztuxer
Level 1
Level 1
 
Posts: 6
Joined: Tue Sep 23, 2008 9:20 am

Linux Mint is funded by ads and donations.
 

Re: AAO (Acer Aspire One) wifi and sound not working

Postby eztuxer on Tue Sep 23, 2008 6:19 pm

I' ve read this tread:
viewtopic.php?f=53&t=10470&hilit=Atheros+AR5006EG
But I cant use apt get to try it, since the wifi only works with Linpus (fedora 7) and use RPM.
Any other way around it ?
eztuxer
Level 1
Level 1
 
Posts: 6
Joined: Tue Sep 23, 2008 9:20 am

Re: AAO (Acer Aspire One) wifi and sound not working

Postby wuying_ren on Thu Sep 25, 2008 6:26 am

Hi eztuxer!

You will not be able to install Elyssa Main, because it's based on Ubuntu 8.04, and it won't boot. But you can install one of the CE Editions (I've tested KDE CE and XFCE CE and both work, XFCE is especially fast), they're based on Ubuntu 8.04.1, which is able to boot without problems.

Once you have installed Elyssa, you can use this https://help.ubuntu.com/community/AspireOne to make everything work.

Enjoy your AAO! :D
"Try not. Do, or do not, there is no try." - Master Yoda

[Howto] Encrypt your system!
[Howto] Fbcondecor on Mint
User avatar
wuying_ren
Level 2
Level 2
 
Posts: 61
Joined: Thu Jun 05, 2008 9:59 am
Location: Catalunya

Re: AAO (Acer Aspire One) wifi and sound not working

Postby eztuxer on Sat Sep 27, 2008 8:50 am

Ola ! Catalunya !

Tnx for advice, I'm downloading Mint XFCE 5 CE and will install it on a 4 GB partition on my 8 GB usb stick, I can't wait to have a dependable working OS for this nice AAO, (Limpus is not quite up to the hardware perfs of this Netbook), see:

http://www.aspireoneuser.com/forum/view ... 419#p28419

http://www.aspireoneuser.com/forum/view ... &start=230

NB: The Windblow$ users are not better off it seems... :mrgreen:
eztuxer
Level 1
Level 1
 
Posts: 6
Joined: Tue Sep 23, 2008 9:20 am

Re: AAO (Acer Aspire One) wifi and sound not working

Postby eztuxer on Sun Sep 28, 2008 7:40 am

Installed Mint 5 XFCE Community Edition.

It looks good, and is pretty fast, but screen resolution is only 800x600 or 640x480, no 1024x600 option in the XFCE menu. Mint 4 was OK on this issue...

The solutions to fix wifi and sound exposed here: https://help.ubuntu.com/community/AspireOne use apt get, and I only have wifi web access ;) no lan, only wlan... :mrgreen:
eztuxer
Level 1
Level 1
 
Posts: 6
Joined: Tue Sep 23, 2008 9:20 am

Re: AAO (Acer Aspire One) wifi and sound not working

Postby eztuxer on Tue Sep 30, 2008 4:56 am

After deeper investigation, it appears that 1024x600 mode is working after all, but is display as default mode, without pixel map size.
eztuxer
Level 1
Level 1
 
Posts: 6
Joined: Tue Sep 23, 2008 9:20 am

Re: AAO (Acer Aspire One) wifi and sound not working

Postby eztuxer on Mon Oct 06, 2008 4:17 am

eztuxer wrote:After deeper investigation, it appears that 1024x600 mode is working after all, but is display as default mode, without pixel map size.


Although the size of the displayed image fits the screen it actually looks like 800x600 (with the pixels stretched horizontally). :(

Now the good news: Sound is working straight out of the box. :mrgreen:
eztuxer
Level 1
Level 1
 
Posts: 6
Joined: Tue Sep 23, 2008 9:20 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot], JayVii and 17 guests