Mic not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Mic not working

Postby zami on Fri Sep 26, 2008 10:29 am

For the last 2 weeks I've been enjoying Mint Elyssa. Almost everything worked nicely, but my integrated mic stayed silenced no matter what (using Skype and the Sound Recorder). I've searched everywhere for answers, installed, removed and reinstalled many packages, played with alsamixer as much as I could, but nothing helped. I've only been able to make a huge mess out of my OS. Yesterday I've reinstalled Mint (the 64 bit version), and was thinking that it's a good time to start asking for help. So please help me.

I have the Dell Vostro 1510 laptop, and this is what I get about my hardware:

Code: Select all
 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Code: Select all
lspci -v
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
   Subsystem: Dell Unknown device 0273
   Flags: bus master, fast devsel, latency 0, IRQ 22
   Memory at f8500000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>


Code: Select all
lshw
 *-multimedia
             description: Audio device
             product: 82801H (ICH8 Family) HD Audio Controller
             vendor: Intel Corporation
             physical id: 1b
             bus info: pci@0000:00:1b.0
             version: 03
             width: 64 bits
             clock: 33MHz
             capabilities: bus_master cap_list
             configuration: driver=HDA Intel latency=0 module=snd_hda_intel


Thanks.
zami
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 20, 2008 5:55 am

Linux Mint is funded by ads and donations.
 

Re: Mic not working

Postby Husse on Sat Sep 27, 2008 11:04 am

This is ICH8 and Realtek
Search the forum for sound and ich8
Look at this
viewtopic.php?f=49&t=10607&hilit=toshiba+intel+sound#p65088
you could probably apply it for your needs like this
Code: Select all
options snd-hda-intel index=0 model=dell
or possibly
Code: Select all
options snd-hda-realtek index=0 model=dell

You add that to /etc/modprobe.d/alsa-base at the end
I'm not saying this will help you - only that it might help you
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Mic not working

Postby zami on Sun Sep 28, 2008 4:02 am

Nope, it didn't help :(
zami
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 20, 2008 5:55 am

Re: Mic not working

Postby zami on Tue Oct 07, 2008 4:20 pm

Not sure if this helps but I've installed openSuse and my mic is working. Any chance to get anything (settings/drivers) from there and get the mic to work in Mint? I'd love to keep Mint.
zami
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 20, 2008 5:55 am

Re: Mic not working

Postby Husse on Wed Oct 08, 2008 6:48 am

I know it's a newer kernel in Opensuse latest version.....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Mic not working

Postby beranger on Wed Oct 08, 2008 10:11 am

Are you sure you selected as the input source the "Front Mic", and NOT the default "Mic"?
This is the usual trap with many laptops!
User avatar
beranger
Level 1
Level 1
 
Posts: 11
Joined: Tue Sep 23, 2008 2:28 pm

Re: Mic not working

Postby zami on Wed Oct 08, 2008 11:45 am

beranger wrote:Are you sure you selected as the input source the "Front Mic", and NOT the default "Mic"?
This is the usual trap with many laptops!


Yes, I've tried both Front Mic and Mic.

update: I've got an external mic and it works :D (though in openSuse both the internal and the external work).
zami
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 20, 2008 5:55 am

Re: Mic not working

Postby psych1610 on Sat Oct 11, 2008 12:52 am

I've got the same problem but in a Vostro 1500. Anyone mind if I hijack this thread? Or does anyone have any more solutions? :)
psych1610
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 03, 2008 5:12 pm

Re: Mic not working

Postby Husse on Sat Oct 11, 2008 4:45 pm

psych1610 wrote:I've got the same problem but in a Vostro 1500. Anyone mind if I hijack this thread? Or does anyone have any more solutions? :)

You'd be better off starting a new topic
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Mic not working [Solved]

Postby psych1610 on Sat Oct 11, 2008 5:28 pm

And start a new topic I shall, thanks Husse.

SUCCESS!

Alright minor successes on my end.

The following is copied from Ubuntu Bugs. None of it is my own work but it did solve my problem.

Code: Select all

Dear ubuntu team, I've managed to fix my issue.
Because I hope this can be useful to others here are the instructions to make it work.

snd-hda-intel takes some parameters, one of the parameter is the model of the card used. To read more about models, check /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz file and search snd-hda-intel. To see what model is used one can issue:
'aplay - L' or better 'cat /proc/asound/oss/sndstat'

in my case it is

SigmaTel STAC9228

So I checked back the ALSA-Configuration file and see there is dell-3stack driver that looks familiar to what I have. Then I added
'options snd-hda-intel model=dell-3stack'
to /etc/modprobe.conf/alsa-base and rebooted (actually I guess just reload of drivers should be fine).
Sound was ok, but still no microphone worked in Sound Recorder (I tried Capture1, Capture2, Capture3, Digital) but when I opened gnome-volume-control, Selected Options (just make sure you have all ticked in Edit->Preferences) tab and changed Digital Input Source to Digital Mic 1 recording is fine using the integrated microphone in the laptop.

My external mic does not work, but I do not care as the one integrated is doing fine and I guess I can make it work by plaing with some source of Capture combination. Anyway it would be nice if someone eplained what is difference between :

Input source (gnome-volume-control): Mic, Front Mic, Line
Digital Input source (volume control): Digital Mic1 , Digital Mic2 and Analog
Record input from (sound recorder): Capture(1,2), Digital, Mux

Issue is solved for me now.


After following those steps and rebooting it worked. Gnome Alsa Mixer and the Pulse Audio Device Chooser and Volume Control needed a bit of tweeking just to make sure nothing was muted and all the volumes were up. According to the person on the other end its a little bit garbled sometimes, and my voice is really low but its 100% better than it was (it works!).

One edit to the above: Where it says /etc/modprobe.conf you'll actually be looking for /etc/modprobe.d/alsa-base as Mint apparently does not have the modprobe.conf folder.

*Edit* After she switched to Windows and tried skype there the volume is better. I suspect some of the problems are caused by her volume control using PCLinuxOS.

In tinkering with this I may have inadvertently messed up my video but a simple (no idea how since I didn't touch those settings)

Code: Select all
sudo modprobe -r uvcvideo
sudo modprobe uvcvideo


fixed it.

If those steps don't work for you the following links looked promising, though I haven't tried them.

https://bugs.launchpad.net/ubuntu/+sour ... bug/149423 About halfway down there's a post.
http://tp0x45.blogspot.com/2008/05/hard ... sound.html


Good luck!
psych1610
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 03, 2008 5:12 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 19 guests