USB drive problem (SanDisk Sansa Clip)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

USB drive problem (SanDisk Sansa Clip)

Postby Foo on Sun Sep 28, 2008 2:52 pm

Hi,

I have a problem with my SanDisk Sansa Clip (mp3 player).
In Mint 4 KDE, it works nicely (as usb mass storage device).
In Mint 5 KDE RC1 (fully updated), it does not work at all.
Here are the relevant dmesg lines:
Code: Select all
[24195.290115] usb 7-3: new high speed USB device using ehci_hcd and address 6
[24197.730319] ehci_hcd 0000:00:1d.7: port 3 reset error -110
[24197.730334] hub 7-0:1.0: hub_port_status failed (err = -32)

(The device usually charges its battery via USB. Even that does not work in Mint 5 KDE).
Does anybody have a clue about what could be the problem? Or even better: a solution?
Foo
 

Linux Mint is funded by ads and donations.
 

Re: USB drive problem (SanDisk Sansa Clip)

Postby Husse on Mon Sep 29, 2008 5:22 am

For starters - does USB work in general?
You could test to change the USB setting in the BIOS (there are only two options USB 1.1 and USB 2 There may be a legacy option for USB 2 - begin by turning that off)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB drive problem (SanDisk Sansa Clip)

Postby Foo on Mon Sep 29, 2008 11:06 am

In general USB works nicely. Keyboard, mouse, sticks, harddrives. Transfer is fast (> 16 MB/s), so USB 2 also works.
I'll have a look at the BIOS tonight.
Foo
 

Re: USB drive problem (SanDisk Sansa Clip)

Postby Foo on Fri Oct 03, 2008 1:31 pm

BIOS settings: found "USB emulation" and an option to turn off USB completely. Tried turning it emulation off. Didn't help.

I also tried booting from a Linux Mint 5 Beta 032 livecd. Works.
(I really like the KDE version, so I probably won't install the Gnome version.)

I'll also try a Linux Mint 5 KDE Beta livedvd (the one I installed) to check if my system got messed up since the installation. I'll report in a few days (DVD not here).
Foo
 

Re: USB drive problem (SanDisk Sansa Clip)

Postby Foo on Sat Oct 11, 2008 4:48 am

Summary and update:
- USB works just fine and fast (including mass storage devices)
- The Sansa Clip, however, does *not* work correctly on Linux Mint 5 KDE RC1, installed system with kernel 2.6.24-19-generic and all updates (including levels 4 and 5), as well as live dvd.
- It *does* work on Linux Mint 5 Beta 032 livecd.

So there seems to be an important difference between beta 032 and kde rc1. Maybe different kernel versions? Didn't check. Behaviour on an up to date Mint 5 main edition might be interesting. If you think it's worth the effort (for diagnostic purposes), I can try that in one or two weeks.

Any further ideas?
Foo
 

Re: USB drive problem (SanDisk Sansa Clip)

Postby Husse on Sat Oct 11, 2008 4:50 pm

Maybe beta32 used the 2.6.24-16 kernel, I don't think so but....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: Google Adsense [Bot], nunu and 15 guests