Vostro 1500 Microphone success

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Vostro 1500 Microphone success

Postby psych1610 on Sat Oct 11, 2008 7:30 pm

The problem: No matter what I did the Microphone on my Dell Vostro 1500 would not work with Sound Recorder or with Skype.

Result: Found a post in Ubuntu Bugs that, after I reinstalled package gnome-media, allowed me to get the microphone working.

This post was also posted here viewtopic.php?f=49&t=17251#p106631 but I wanted to start a new thread in the hopes more people would see it and solve their problems.

Sorry to every one if this is a problem, please delete me :)

Alright minor successes on my end.

The following is copied from Ubuntu Bugs. None of it is my own work but it did solve my problem.

Code: Select all

Dear ubuntu team, I've managed to fix my issue.
Because I hope this can be useful to others here are the instructions to make it work.

snd-hda-intel takes some parameters, one of the parameter is the model of the card used. To read more about models, check /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz file and search snd-hda-intel. To see what model is used one can issue:
'aplay - L' or better 'cat /proc/asound/oss/sndstat'

in my case it is

SigmaTel STAC9228

So I checked back the ALSA-Configuration file and see there is dell-3stack driver that looks familiar to what I have. Then I added
'options snd-hda-intel model=dell-3stack'
to /etc/modprobe.conf/alsa-base and rebooted (actually I guess just reload of drivers should be fine).
Sound was ok, but still no microphone worked in Sound Recorder (I tried Capture1, Capture2, Capture3, Digital) but when I opened gnome-volume-control, Selected Options (just make sure you have all ticked in Edit->Preferences) tab and changed Digital Input Source to Digital Mic 1 recording is fine using the integrated microphone in the laptop.

My external mic does not work, but I do not care as the one integrated is doing fine and I guess I can make it work by plaing with some source of Capture combination. Anyway it would be nice if someone eplained what is difference between :

Input source (gnome-volume-control): Mic, Front Mic, Line
Digital Input source (volume control): Digital Mic1 , Digital Mic2 and Analog
Record input from (sound recorder): Capture(1,2), Digital, Mux

Issue is solved for me now.


After following those steps and rebooting it worked. Gnome Alsa Mixer and the Pulse Audio Device Chooser and Volume Control needed a bit of tweeking just to make sure nothing was muted and all the volumes were up. According to the person on the other end its a little bit garbled sometimes, and my voice is really low but its 100% better than it was (it works!).

One edit to the above: Where it says /etc/modprobe.conf you'll actually be looking for /etc/modprobe.d/alsa-base as Mint apparently does not have the modprobe.conf folder.

*Edit* After she switched to Windows and tried skype there the volume is better. I suspect some of the problems are caused by her volume control using PCLinuxOS.

In tinkering with this I may have inadvertently messed up my video but a simple (no idea how since I didn't touch those settings)

Code: Select all
sudo modprobe -r uvcvideo
sudo modprobe uvcvideo


fixed it.

If those steps don't work for you the following links looked promising, though I haven't tried them.

https://bugs.launchpad.net/ubuntu/+sour ... bug/149423 About halfway down there's a post.
http://tp0x45.blogspot.com/2008/05/hard ... sound.html


Good luck!
psych1610
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 03, 2008 5:12 pm

Linux Mint is funded by ads and donations.
 

Re: Vostro 1500 Microphone success

Postby Husse on Sun Oct 12, 2008 10:47 am

Glad you solved it
I thought I'd seen something like this
If you have not already, please add solved to the subject line of your other post (click edit :))
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Vostro 1500 Microphone success

Postby psych1610 on Mon Oct 13, 2008 1:26 am

Done! Thanks Husse
psych1610
Level 3
Level 3
 
Posts: 152
Joined: Mon Mar 03, 2008 5:12 pm


Return to Hardware Support

Who is online

Users browsing this forum: Google Adsense [Bot], Riko, Sam Sung, santi2007 and 11 guests