atheros wireless network SOLUTION *UPDATED*

Questions about WIFI networks and devices
Forum rules
Before you post please read this

atheros wireless network SOLUTION *UPDATED*

Postby xnostradamusx on Thu Nov 06, 2008 1:42 pm

ok well i got some spare time so i want to contribute with the community so this is how i was able to make my atheros wireless AR5007* (AR2425 chips) work with ubuntu 8.04/interpid and mint 5 and mint 6 rc1 so i think this can be applied also with other atheros cards if your lucky

so here we go:

Preparing

first open up a terminal and copy paste this
Code: Select all
apt-get install build-essential
this will download the build

essentials packages for compiling after it finish close the terminal

Download The Driver

then we need to download the needed files so http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6/madwifi-hal-0.10.5.6-r3875-20081105.tar.gz

Remove Old Modules

now to be sure you encounter no errors remove the old modules

First, set all your MadWifi devices down: type this in terminal
Code: Select all
sudo ifconfig ath0 down
sudo ifconfig wifi0 down

#Repeat these 2 ifconfig lines for every MadWifi device you have (ath1,
etc)

next we need to extract the file, right click on the file and click extract here, now a folder of your downloaded file will appear right click to that then choose

run in terminal now your inside the folder time to copy paste this

Code: Select all
sudo cd scripts
./madwifi-unload
./find-madwifi-modules.sh $(uname -r)
cd ..

You should then be asked if you are sure that you want to remove the old modules.

now everything is ready we can build and install the madwifi drivers

Building And Installing

assuming your still in the madwifi folder just type this

Code: Select all
sudo make
sudo make install


it will install your needed files to enable your wireless.

Loading The Driver

To Load The Driver just type This in Terminal

Code: Select all
sudo modprobe ath_pci


after this you should restart your computer.

then when your logged in again right click on nm applet and there should be two options which is checked by default now

enabled networking and enabled wireless.

and by left clicking nm applet again you should see the available wireless connection now and connecting to it is as simple as using windows

if you dont see this just type this again in the terminal

Code: Select all
sudo modprobe ath_pci


then that should appear now

now enjoy your wireless connection :D

*Reminders*

make sure there is no ndiswrapper driver loaded cause it will cause conflict with madwifi.
check on Hardware Drivers and Disable support for Atheros wireless because you dont need it.
Last edited by xnostradamusx on Tue Nov 18, 2008 3:48 am, edited 6 times in total.
~cheers~

xnostradamusx
User avatar
xnostradamusx
Level 3
Level 3
 
Posts: 169
Joined: Thu Jul 24, 2008 1:04 am
Location: qatar

Linux Mint is funded by ads and donations.
 

Re: atheros wireless network SOLUTION

Postby arm1e on Mon Nov 17, 2008 6:52 pm

I have this chip and in mint 5 I was able to get it working simply by deactivation HAL usig the GUI and installing the windows inf using ndiswrapper.

This i personnally found much easier than the mad wifi method which I used to ALWAYS have to use.

NOTE: This was a while ago but i am sure it is how i got it working.
arm1e
Level 1
Level 1
 
Posts: 32
Joined: Tue May 27, 2008 5:35 am

Re: atheros wireless network SOLUTION

Postby RSimpson on Mon Nov 17, 2008 6:54 pm

In Mint 6.0 RC1 on my emachines E520, this compiled and loaded a driver, but wireless still wouldn't come up even after rebooting and doing modprobe again. It seems to be working perfectly with this solution:

http://www.linuxmint.com/forum/viewtopic.php?f=53&t=18883&p=112868#p112868

...but I'd like to get this madwifi open source driver to work.

I haven't tried using the madwifi method with Mint 5 on this new machine because the graphics card didn't work with Mint 5.
User avatar
RSimpson
Level 1
Level 1
 
Posts: 29
Joined: Thu Sep 13, 2007 7:24 pm

Re: atheros wireless network SOLUTION

Postby badmotor on Mon Nov 17, 2008 8:11 pm

Anyone know if this works with Intrepid/Felicia?
badmotor
Level 4
Level 4
 
Posts: 371
Joined: Fri May 02, 2008 7:40 pm
Location: New Zealand.

Re: atheros wireless network SOLUTION

Postby xnostradamusx on Tue Nov 18, 2008 2:16 am

badmotor wrote:Anyone know if this works with Intrepid/Felicia?



it works im using felicia now and i just used my method as always
~cheers~

xnostradamusx
User avatar
xnostradamusx
Level 3
Level 3
 
Posts: 169
Joined: Thu Jul 24, 2008 1:04 am
Location: qatar

Re: atheros wireless network SOLUTION *UPDATED*

Postby zerokpa on Mon Dec 01, 2008 1:47 pm

awesome! wireless now working on my AAO!
zerokpa
 

Re: atheros wireless network SOLUTION *UPDATED*

Postby Ulyss on Sat Dec 27, 2008 1:13 am

Same here, my Aspire One is now happy, so am I! Thank you!
Ulyss
 

Re: atheros wireless network SOLUTION *UPDATED*

Postby feddds on Mon Jan 12, 2009 5:04 pm

Hi, I followed this:
viewtopic.php?f=49&t=13980

But could not make it work :-(
I got this:
capacitacion@capacitacion-laptop ~ $ sudo ndiswrapper -l
WARNING: /etc/modprobe.d/blacklist line 50: ignoring bad line starting with '“blacklist'
net5211 : driver installed
device (168C:001C) present (alternate driver: ath_pci)
capacitacion@capacitacion-laptop ~ $

02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
Subsystem: Device 1a3b:1026
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at d0000000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ndiswrapper
Kernel modules: ath_pci

It seems theres is a difference between 168C:001C and 1a3b:1026 from ndiswrapper

Before proceeding with this solucion how I disable ndiswrapper and go back all steps?
Thanks feddds.
feddds
Level 1
Level 1
 
Posts: 11
Joined: Mon Jan 12, 2009 4:47 pm

Re: atheros wireless network SOLUTION *UPDATED*

Postby Guest on Wed Feb 04, 2009 3:29 am

zerokpa wrote:awesome! wireless now working on my AAO!


+1. Very clear instructions, worked first time. Thanks a million. 8)
Guest
 

Re: atheros wireless network SOLUTION *UPDATED*

Postby HelloJayo on Wed Feb 04, 2009 10:49 am

you are a HERO!!!

this is the only solution of dozens i went thru that actually works in mint 6!!!

thanks a million

***STICKY THIS***
HelloJayo
 

Re: atheros wireless network SOLUTION *UPDATED*

Postby merlwiz79 on Wed Feb 04, 2009 9:35 pm

feddds wrote:Hi, I followed this:
viewtopic.php?f=49&t=13980

But could not make it work :-(
I got this:
capacitacion@capacitacion-laptop ~ $ sudo ndiswrapper -l
WARNING: /etc/modprobe.d/blacklist line 50: ignoring bad line starting with '“blacklist'
net5211 : driver installed
device (168C:001C) present (alternate driver: ath_pci)
capacitacion@capacitacion-laptop ~ $

02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
Subsystem: Device 1a3b:1026
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at d0000000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ndiswrapper
Kernel modules: ath_pci

It seems theres is a difference between 168C:001C and 1a3b:1026 from ndiswrapper

Before proceeding with this solucion how I disable ndiswrapper and go back all steps?
Thanks feddds.

I think you just need to edit the last line in /etc/modprobe.d/blacklis
You most likely have 2 line as 1 line.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: atheros wireless network SOLUTION *UPDATED*

Postby Milutin on Fri Feb 06, 2009 11:45 am

Dear whoever
I have installed the Mint6 for the first time, I have succeeded to establish the wireless connection with my provider an the indication in the toolbar is OK.

Now since I connect to internet with username and password I don't have a slightest idea how to do it?

Please please help
Milutin
Level 1
Level 1
 
Posts: 27
Joined: Thu Feb 05, 2009 5:22 pm

Re: atheros wireless network SOLUTION *UPDATED*

Postby Aljado on Fri Feb 13, 2009 10:17 am

Guest wrote:
zerokpa wrote:awesome! wireless now working on my AAO!


+1. Very clear instructions, worked first time. Thanks a million. 8)


That was me posting before I signed up. I'm afraid my wireless doesn't work now, and repeating this tutorial doesn't bring it back. I've tried a few of the offshoot threads too, but no dice.

I (stupidly) unchecked the 'enable wireless' box in NM, and couldn't get on again. In my attempts to reinstate, I've uninstalled NM, put Wicd on, followed this tutorial through again, no joy. I even tried older versions of the madwifi package in case there was an issue with the 5th Feb edition.

I checked the Wicd community to see what they reckon (wired connections work 100%) and iwlist scan shows no scan results for wlan0.

The thread over there (link) suggests a driver problem, which brought me back here. I'm wondering if somehow I am not clearing off the older drivers and my subsequent attempts to fix, though at this stage I'm at something of a loss. As you can tell, I'm an ubernoob with Linux.

Any thoughts very much welcome. Thanks in advance.

AAO running LM6 Felicia
Aljado
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 04, 2009 3:27 am

Re: atheros wireless network SOLUTION *UPDATED*

Postby dringof1 on Thu Mar 05, 2009 12:54 pm

Ok this is what worked for me:

Go to Menu > Administration > Hardware Drivers - Ensure all wifi drivers are deactivated.
Restart
Go to Menu > Administration > Windows Wireless Drivers (You will need to type your root password in)
Click Install new driver.
Navigate to Filesystem: Usr > Lib > Linuxmint > mintwifi > drivers > (i386 if your running a 32bit machine / amd64 if your not) > Atheros_5007eg > net5211.inf
This should suddenly make your wifi spring in to life!

Let me know if it works for you.
dringof1
Level 1
Level 1
 
Posts: 1
Joined: Thu Mar 05, 2009 12:43 pm

Re: atheros wireless network SOLUTION *UPDATED*

Postby merlwiz79 on Thu Mar 05, 2009 8:17 pm

Why make it so hard?
This seems to work just fine.
viewtopic.php?p=124897#p124897
viewtopic.php?p=124574#p124574
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: atheros wireless network SOLUTION *UPDATED*

Postby badmotor on Sat Mar 07, 2009 1:58 am

dringof1 wrote:Ok this is what worked for me:

Go to Menu > Administration > Hardware Drivers - Ensure all wifi drivers are deactivated.
Restart
Go to Menu > Administration > Windows Wireless Drivers (You will need to type your root password in)
Click Install new driver.
Navigate to Filesystem: Usr > Lib > Linuxmint > mintwifi > drivers > (i386 if your running a 32bit machine / amd64 if your not) > Atheros_5007eg > net5211.inf
This should suddenly make your wifi spring in to life!

Let me know if it works for you.


Why hasn't someone posted this one before? So easy, and no outdated links to drivers on the net. Well done. Getting wireless working seems to be such a criptic thing when it doesn't have to be.
badmotor
Level 4
Level 4
 
Posts: 371
Joined: Fri May 02, 2008 7:40 pm
Location: New Zealand.

Re: atheros wireless network SOLUTION *UPDATED*

Postby Infected2Me on Thu Mar 12, 2009 4:35 pm

Woot! Thanks so much,I've been looking for a solution for my wifi problem everywhere! This literally took only 5 minutes even with the restart. Thanks again! ^.^
Infected2Me
Level 1
Level 1
 
Posts: 4
Joined: Thu Mar 12, 2009 2:59 pm

Re: atheros wireless network SOLUTION *UPDATED*

Postby gonzalobriceno on Sat Mar 14, 2009 6:15 pm

I recently purchased an HP Pavilion dv5z-1200 laptop. After installing Mint 6(32-bit) I followed the instructions in this posting to get my wireless working. Two things worth noting:

1. I deactivated the 'Support for Atheros 802.11 wireless LAN cards' option under the Hardware Drivers app.
2. Before following the instructions on this posting I tried those in http://forums.linuxmint.com/viewtopic.php?p=124897#p124897 but they did not work. I made sure to revert the changes from those instructions.

So far so good...
gonzalobriceno
Level 1
Level 1
 
Posts: 1
Joined: Sun Dec 07, 2008 12:58 pm

Re: atheros wireless network SOLUTION *UPDATED*

Postby arm1e on Fri Apr 03, 2009 3:39 pm

Post 2 on this topic!
I wrote about this method and said i used it on mint 5 and that it should work on mint 6!

Glad i wasted my time!
arm1e
Level 1
Level 1
 
Posts: 32
Joined: Tue May 27, 2008 5:35 am

Re: atheros wireless network SOLUTION *UPDATED*

Postby vcrazy on Wed Apr 08, 2009 6:00 am

dringof1 wrote:Ok this is what worked for me:

Go to Menu > Administration > Hardware Drivers - Ensure all wifi drivers are deactivated.
Restart
Go to Menu > Administration > Windows Wireless Drivers (You will need to type your root password in)
Click Install new driver.
Navigate to Filesystem: Usr > Lib > Linuxmint > mintwifi > drivers > (i386 if your running a 32bit machine / amd64 if your not) > Atheros_5007eg > net5211.inf
This should suddenly make your wifi spring in to life!

Let me know if it works for you.


OMG Thank you SO Much! After hours of fiddling and searching the forums, this method worked for me. I'm new to Linux Mint (and Linux for that matter), I had a fresh install on a partition on my HP laptop dv6700. Wireless worked like a charm and i'm now running mintUpdate. Thanks again! =)
vcrazy
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 08, 2009 5:57 am

Linux Mint is funded by ads and donations.
 
Next

Return to Wireless

Who is online

Users browsing this forum: Señor Normal and 10 guests