USB HDD with NTFS read only

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

USB HDD with NTFS read only

Postby NiksaVel on Sun Apr 01, 2007 3:44 pm

Hey guys... a friend just came here with a USB 2.5" HDD formatted with NTFS

Mint recognised it with no prob and mounted in /media/Canyon

but it's READ ONLY

what can I do to get it to RW?
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Linux Mint is funded by ads and donations.
 

Postby Husse on Sun Apr 01, 2007 6:25 pm

NiksaVel you know that mintDisk mounts r/w so the disk is not mounted by mintDisk.
I've helped solve and solved some mysterious behavior of this kind, and unless something is seriously broken my bet is that you have an UUID in fstab that for some mysterious reason is the same as that of the disk that just said hello to your computer.
It should not happen but...(take a look at user pashabears plight)
You could try to remove every trace (including commented entries) of ntfs disks in fstab (copy it first) reboot and see what happens
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby NiksaVel on Sun Apr 01, 2007 6:40 pm

this is my fstab

tell me if I need to change something...

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda2
UUID=637e8996-9402-4152-8b0f-2f6b206ca2ec / ext3 defaults,errors=remount-ro 0 1
# /dev/hda5
UUID=01fc5c30-7b5a-4bd5-b666-aa39fbdd2ab5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0
192.168.2.3:/home/niksavel/shared/music /home/niksavel/Music/shared nfs _netdev,auto,user 0 0
192.168.2.3:/home/niksavel/shared /home/niksavel/z nfs _netdev,auto,user 0 0



I would really like to get this to work as this is one of those "Pro-Windows" friends that likes to criticise linux and I hate that :D
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby Husse on Sun Apr 01, 2007 7:02 pm

There are no ntfs partitions there, but some of theese ugly UUIDs. I think you should paste your mintDisk log
(/usr/lib/linuxmint/mintDisk/mintDisk.log)
and maybe we have to ask Clem for help :)
It seems that it is mintDisk that mounts after all.
Are there some special properties for the disk that are different from normal ntfs?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby NiksaVel on Mon Apr 02, 2007 4:25 am

I don't know....

:shock:

normal NTFS disks are mounted through mintDisk and work r/w fine...


------------------------
* checking the presence of os-prober and remastersys...
-- os-prober is present
-- remastersys is present
-------------------------
* checking system environment...
-- user = niksavel
-- home = /home/niksavel
-- locale = en_US.UTF-8
-------------------------
* configuring options...
-- mount point: /media/<<DEVICE>>
-- show links: Yes
-- links location: /home/niksavel/Desktop/
-------------------------
* loading support for FAT32...
-- partition type = b
-- mount type = vfat
-- mount options = iocharset=utf8,umask=000
* loading support for FAT32 (LBA)...
-- partition type = c
-- mount type = vfat
-- mount options = iocharset=utf8,umask=000
* loading support for NTFS...
-- partition type = 7
-- mount type = ntfs-3g
-- mount options = defaults,locale=en_US.utf8
-------------------------
* removing existing links (if any)...
-------------------------
* scanning partitions...
-- detected device /dev/sda1 of type 7 and size 36GB
=> no alias defined
=> mounting partition...
=> WARNING: Deficient FUSE kernel module detected. Some driver features are
not available (swap file on NTFS, boot from NTFS by LILO), and
unmount is not safe unless it's made sure the ntfs-3g process
naturally terminates after calling 'umount'. The safe FUSE kernel
driver is included in the official Linux kernels since version
2.6.20-rc1, or in the FUSE 2.6.0 or later software packages,
except the faulty FUSE version 2.6.2. For more help, please
have a look at /usr/share/doc/ntfs-3g/README.Debian. Thanks

=> creating a link to /media/sda1
-- detected device /dev/hda1 of type 7 and size 204GB
=> no alias defined
=> mounting partition...
=> WARNING: Deficient FUSE kernel module detected. Some driver features are
not available (swap file on NTFS, boot from NTFS by LILO), and
unmount is not safe unless it's made sure the ntfs-3g process
naturally terminates after calling 'umount'. The safe FUSE kernel
driver is included in the official Linux kernels since version
2.6.20-rc1, or in the FUSE 2.6.0 or later software packages,
except the faulty FUSE version 2.6.2. For more help, please
have a look at /usr/share/doc/ntfs-3g/README.Debian. Thanks

=> creating a link to /media/hda1
-- detected device /dev/hda2 of type 83 and size 39GB
=> partition type not supported
-- detected device /dev/hda3 of type 5 and size 1GB
=> partition type not supported
-- detected device /dev/hda5 of type 82 and size 1GB
=> partition type not supported
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby Husse on Mon Apr 02, 2007 5:07 am

This is odd...
There are two partitions mounted by mintDisk
/dev/sda1
/dev/hda1
and /dev/sda1 is the USB disk I presume. Read only, but the mount type = ntfs-3g and no warnings (except the FUSE thing that is irrelevant here)
What about /dev/hda1 also mounted by mintDisk? It is ntfs as well, can you write to it?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby NiksaVel on Mon Apr 02, 2007 10:26 am

no... these are my phisical hdds


sda1 is a sata disk
and hda1 is the ntfs partition of my ide hdd...


I don't have that little usb disk here anymore, it was my friends' who came to visit and copy some movies and stuff...

I'll make a log when he gets here again...

I can r/w on both
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby Lolo Uila on Thu May 17, 2007 9:07 pm

I believe Mintdisk only mounts NTFS read/write (NTFS-3g) at boot time.

If you plug in a USB NTFS drive after you have booted, it will mount, but in read-only mode. If you want read/write access you need to boot (or reboot) with the drive connected. You will probably end up with 2 icons for the drive after rebooting (I do anyway). At least one of them will be read/write.

VFAT (FAT16/32), on the other hand, can be mounted read/write when hot plugged.

That's the way it works based on my limited experience. There is a similar problem when you install Mint on a system that has internal NTFS formatted drives. They will mount in read-only mode. In the case of an internal drive that was already in there at the time Mint was installed the answer is to edit the fstab file and remove the entries for the NTFS drives (note that you have to delete the entries; commenting them out is not enough). After a reboot Mintdisk will mount them read/write.

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby NiksaVel on Fri May 18, 2007 1:56 am

I believe Mintdisk only mounts NTFS read/write (NTFS-3g) at boot time.

If you plug in a USB NTFS drive after you have booted, it will mount, but in read-only mode. If you want read/write access you need to boot (or reboot) with the drive connected. You will probably end up with 2 icons for the drive after rebooting (I do anyway). At least one of them will be read/write.

VFAT (FAT16/32), on the other hand, can be mounted read/write when hot plugged.

That's the way it works based on my limited experience. There is a similar problem when you install Mint on a system that has internal NTFS formatted drives. They will mount in read-only mode. In the case of an internal drive that was already in there at the time Mint was installed the answer is to edit the fstab file and remove the entries for the NTFS drives (note that you have to delete the entries; commenting them out is not enough). After a reboot Mintdisk will mount them read/write.



Clem can you confirm this? (especially the part about the USB NTFS drives and mintDisk...??)

If this is really the case, than maybe we could improve mintDisk with this tiny but also BIG problem... USB HDDs are becoming quite popular these days...
Windows is extremely fast after a fresh install. If you want to make it stay that way: - don't use it.
-Clem
User avatar
NiksaVel
Level 5
Level 5
 
Posts: 806
Joined: Wed Feb 28, 2007 4:06 am
Location: Croatia

Postby Lolo Uila on Fri May 18, 2007 7:18 am

Just tried it again, and that's how it's working for me.

I plug in my 200GB NTFS USB drive and it mounts as WD200 (the drive's label) with "access files" permission (read only). I plug in my 40GB NTFS USB portable drive and it mounts as NTFS40GB (the label again) with access files (read only) permissions.

I plug in my 40GB FAT32 portable drive and it mounts as USB 40GB with "create and delete files" permissions.

I leave the 200G connected and powered on while I restart and I get the WD200 icon that is listed as Owner: root, and I get a 2nd icon labeled; 195GB NTFS Volume (sdc1) and it shows me as the owner with read and write permissions. Curiously, although the WD200 icon is owned by root, I can open it and read/write files just like the other icon.

Anyway... it will be interesting to hear what Clem has to say about this. I don't know if this is how it's supposed to work, but this is how it has always worked for me.

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby Lolo Uila on Fri May 18, 2007 7:39 am

And in case you are wondering if I have anything screwy in my fstab file that may be causing this behavior, I don't. I edited my fstab file to clean it up for better Mintdisk operation. I removed all the UUID references and left entries only for my 2 internal Linux formatted hard drives (hda/sdb) and my optical drive.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
#
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/sdb1 /media/sdb1 ext3 defaults 0 2
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Postby telic on Fri May 18, 2007 12:08 pm

This USB HDD read-only problem also exists for native Linux file-systems (e.g. ReiserFS) under Mint.

Your glitch might be resolved by following the instructions in my post [HERE] from a month ago.

-----
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Postby Lolo Uila on Fri May 18, 2007 3:47 pm

Didn't work for my NTFS USB drive. :(

trp@Linux-Mint:/media$ sudo chmod g+w WD200
chmod: changing permissions of `WD200': Read-only file system

It mounts with me as the group and user owner, but it still won't let me change anything. Keeps insisting it is a read-only drive and will not make changes.

Thanks for trying though.

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 22 guests