Headset doesn't mute speaker audio solved

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Headset doesn't mute speaker audio solved

Postby rjohn on Sat Dec 20, 2008 9:44 pm

Just installed Mint 6.0 (upgrade from 4.0) and it is awesome. Haven't found ALL of the neat things it can do yet, but have found a weird issue with sound. If I use a headset, the audio is ported out to headset but is also present on the laptop speakers. I am using a Sony laptop (VGN-NR160E) if that makes a difference. I have tried all different options with sound devices and with pulse audio to no avail.
Output of lspci:
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8039 PCI-E Fast Ethernet Controller (rev 14)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
08:03.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
08:03.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
08:03.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
I appreciate any help-this is the best distro I have used by far.
rjohn
rjohn
Level 1
Level 1
 
Posts: 17
Joined: Wed Apr 23, 2008 12:41 am

Linux Mint is funded by ads and donations.
 

Re: Headset doesn't mute speaker audio

Postby Husse on Sun Dec 21, 2008 2:36 pm

I have seen reports on that all the time I think
You have the ICH8 chipset and sound - standard solutions for it helps I think. Not absolutely sure this will fix it but I think so
viewtopic.php?f=48&t=17801&p=107982&hilit=ich8+alsa#p107982
Of course you use model=sony
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Headset doesn't mute speaker audio

Postby rjohn on Sun Dec 21, 2008 4:57 pm

Thanks Husse for the reply-
Unfortunately, no joy. I tried substituting moel =sony, model =laptop, model=vaio with reboot each time and no change. The sound works, just no speaker mute with headset, so I am a bit hesitant to to change drivers as suggested in the other post (which also seems to revolve around an earlier kernel). However, <Control Center> <Sound Preferences> <Sound Playback> returns the following if I choose" HDA Intel ALC262 Analog (ALSA)"-audiotestsrc wave=sinefreq=512 ! audioconvert ! audioresample ! gconfaudiosink: could not open audio device for playback". ALL other options return normal result, i.e. play 512hz tone, although the tone is heard through headset and speakers.
This "bug" is more of a distraction than a problem, but there are times when it is desirable to have the privacy of speaker mute using headset. Any further suggestions? Anyone?
Thanks
rjohn
Level 1
Level 1
 
Posts: 17
Joined: Wed Apr 23, 2008 12:41 am

Re: Headset doesn't mute speaker audio

Postby rjohn on Sun Dec 21, 2008 6:13 pm

Mark this one solved :D !
I enclose the following from alsa-base : options snd-hda-intel index=0 model=vaio
Open mixer applet and add the following controls- Master, PCM , Front, Microphone.
Mute "Front" and adjust the volume controls for appropriate level in the headset. The speakers remain muted and the master control in the bottom control panel has no effect-but the volume control for the media player app does work.
This could be considered a "feature" :lol: .
All in all Mint 6.0 is awesome, I couldn't be more pleased.
Rjohn
rjohn
Level 1
Level 1
 
Posts: 17
Joined: Wed Apr 23, 2008 12:41 am


Return to Hardware Support

Who is online

Users browsing this forum: da_caat, Google [Bot], Google Adsense [Bot], spottraining and 10 guests