sound card driver

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

sound card driver

Postby blior32017 on Sat Jan 17, 2009 1:03 pm

my speakers is don't work so i need to driver
my computer is HP: Compaq dx6120
the name of the sound card company is: soundmax
tanks


im sorry if my eng no so good because i from Israel
blior32017
Level 1
Level 1
 
Posts: 3
Joined: Sat Jan 17, 2009 12:53 pm

Linux Mint is funded by ads and donations.
 

Re: sound card driver

Postby hotweiss on Sat Jan 17, 2009 5:47 pm

Hmmm, the problem could be one of many, but try this:

A) First we’ll have to edit the ALSA configuration file via terminal:
Code: Select all
sudo nano /etc/modprobe.d/alsa-base


B) Scroll down to the bottom and add this line:
Code: Select all
options snd-hda-intel model=laptop


C) Hit Ctrl-O to save and then Ctrl-X to exit.

D) Reboot

If the above doesn't work, delete the previously tried line and try this:

Code: Select all
options snd-hda-intel position_fix=1 model=3stack
hotweiss
Level 4
Level 4
 
Posts: 204
Joined: Mon Jan 21, 2008 3:12 am
Location: Warsaw, Poland

Re: sound card driver

Postby khelben1979 on Sun Jan 18, 2009 1:06 pm

Run the alsaconf command with root priviliges. ( http://man-wiki.net/index.php/8:alsaconf )

Can you find your soundchip in the list?
/Bear Spirit
User avatar
khelben1979
Level 1
Level 1
 
Posts: 9
Joined: Wed Jan 07, 2009 3:01 pm
Location: Sweden

Re: sound card driver

Postby hotweiss on Sun Jan 18, 2009 6:45 pm

The best thing to do is to identify your sound card and then search for a solution.

Using

Code: Select all
lspci -v | less


what sound card is identified?
hotweiss
Level 4
Level 4
 
Posts: 204
Joined: Mon Jan 21, 2008 3:12 am
Location: Warsaw, Poland

Re: sound card driver

Postby Guest on Thu Jan 22, 2009 2:47 pm

Far be it for me to introduce a potential red herring, but my experiences with Elyssa (KDE) and Felicia (Gnome) suggest making sure you don't have any Pulse Audio modules installed. I installed Amarok (amongst other KDE apps) onto Felicia with Gnome and they dragged along PA - couldn't get sound to work with them there. Removed the PA, life and sound was good.
Guest
 


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 25 guests