Audio not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Audio not working

Postby faweb on Thu Jan 22, 2009 7:51 am

Hello.

I have just installed linux mint on my grand childs PC. But I cant get the audio to work. It is a IBM Thinkpad 600X I have been in the Terminal and the following is the output on the audio.


sudo alsa force-reload
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/simone/.gvfs
Output information may be incomplete.

Terminating processes: 4788lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/simone/.gvfs
Output information may be incomplete.

lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/simone/.gvfs
Output information may be incomplete.
.
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/simone/.gvfs
Output information may be incomplete.

Unloading ALSA sound driver modules: snd-cs46xx snd-ac97-codec snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
Loading ALSA sound driver modules: snd-cs46xx snd-ac97-codec snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.

Can anyone help please.

Many regards

Flemming Andersen
Denmark
faweb
Level 1
Level 1
 
Posts: 2
Joined: Thu Jan 22, 2009 7:43 am

Linux Mint is funded by ads and donations.
 

Re: Howto Audiodriver?

Postby Husse on Fri Jan 23, 2009 7:05 am

The fuse daemon error is nothing to worry about (in this connection)
You have to tell us more facts.
The minimum is exactly which Mint you have (Edition, version)
We also need to know a bit about all your hardware.
Run " lspci " in a terminal and post here (To copy from a terminal right click)
Some wifi and possibly built in sound can be connected to USB even if they are internal - if you suspect you have one of these run " lsusb " in a terminal.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Audio not working

Postby faweb on Fri Jan 23, 2009 7:34 am

Hi

Thanks for reply

Here is the output you ask for:::

simone@simone-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP
bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Communication controller: Agere Systems WinModem 56k (rev 01)
00:06.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev
01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev
01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: Neomagic Corporation NM2360
[MagicMedia 256ZX]
06:00.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X
+ Wireless Network Adapter (rev 01)
simone@simone-laptop:~$

Many regards

Flemming
Denmark
faweb
Level 1
Level 1
 
Posts: 2
Joined: Thu Jan 22, 2009 7:43 am

Re: Audio not working

Postby Husse on Fri Jan 23, 2009 8:30 am

It's an old computer and this
Cirrus Logic CS 4614/22/24/30

makes it hard
You could search for that and Linux to try to find a solution
I have to dig a bit more to solve this
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Audio not working

Postby Husse on Sat Jan 31, 2009 12:21 pm

I found that this probably happens because the driver is missing
Unfortunately to fix it you have to compile the module
The alsa driver in the link is a bit old, but newer ones don't seem to have the module included
It's not as tricky as it sounds
First
sudo su
This is to make you root in the terminal for a while (simplifying - less sudo this way)
Code: Select all
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.17.tar.bz2

Code: Select all
tar xf alsa-driver-1.0.17.tar.bz2

Code: Select all
rm alsa-driver-1.0.17.tar.bz2

Code: Select all
cd alsa-driver-1.0.17/

Code: Select all
./configure --with-cards=cs46xx --with-sequencer=yes --with-isapnp=no --disable-verbose-printk

Code: Select all
make

Code: Select all
make install

Code: Select all
modprobe snd-cs46xx

Close the terminal
Code: Select all
sudo alsamixer

and press m to unmute the master channel which will be muted by default.
If this works for you just add snd-cs46xx to /etc/modules
Code: Select all
echo "snd-cs46xx" | sudo tee -a /etc/modules

I don't know if an update of alsa will destroy this or not
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: Bing [Bot], HPTesla and 15 guests