added an X-fi scard - how do i get it working in Mint 6 SOLV

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

added an X-fi scard - how do i get it working in Mint 6 SOLV

Postby madevan on Mon Jan 26, 2009 2:55 pm

I was using my motherboard built in sound when I installed Felicia - I have since added an X-fi sound card and now no sound - obviously I have to get the system to recognise it is there.

How do I achieve that?

here is an lspci listing - hope it helps:
$ lspci
00:00.0 Host bridge: Intel Corporation 82946GZ/PL/GL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82946GZ/PL/GL PCI Express Root Port (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1)
02:01.0 Multimedia audio controller: Creative Labs SB X-Fi
02:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
02:02.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
02:02.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
02:02.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
02:03.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 14)
Last edited by madevan on Fri Jan 30, 2009 9:57 pm, edited 1 time in total.
User avatar
madevan
Level 1
Level 1
 
Posts: 29
Joined: Tue Sep 18, 2007 11:42 am

Linux Mint is funded by ads and donations.
 

Re: added an X-fi sound card - how do i get it working in Mint 6

Postby garda on Wed Jan 28, 2009 1:54 pm

Your X-Fi doesn't work under Felicia because it's not yet compatible with PulseAudio, which is the default audio framework used in Ubuntu and its derivatives. In order to get audio with Sound Blaster X-Fi in Felicia, you must replace PulseAudio and Alsa with OSS. You can follow this guide to do just that:
Ubuntu Community Documentation - OpenSound

Edit:
You should follow the guide for Intrepid, where applicable, in Felicia. Read the guide completely and carefully before you start with any of the steps.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: added an X-fi sound card - how do i get it working in Mint 6

Postby madevan on Fri Jan 30, 2009 8:13 am

Thanks Garda - I'll try it this weekend! :)

Early Sat morning - it worked fine! GREAT

Thanks Garda
:D :D :D
User avatar
madevan
Level 1
Level 1
 
Posts: 29
Joined: Tue Sep 18, 2007 11:42 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 20 guests