(EE) failed to load module "glx" (module does not exist, 0)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

(EE) failed to load module "glx" (module does not exist, 0)

Postby kloispetie on Wed Mar 04, 2009 12:27 pm

I just installed a new geforce 7200 GS graphic card from Point of View. This card supports the linux drivers from nvidia.

So i tried to install these drivers
A) direclty from the website (since i am a beginner, this was difficult for shutting down X)
I got a lot of errors.
B) Using Envy G.
When restarting, I get the following error:

(EE) failed to load module "glx" (module does not exist, 0)
(EE) failed to load module nvidia (module does not exist, 0)
(EE) no drivers


I googled, searched for answers (because several persons seem to have it after upgrading to ubuntu 8.10), but don't manage to solve it.

I tried sudo apt-get install nvidia-glx-new linux-restricted-modules-$(uname -r) --reinstall (from this topic: http://ubuntuforums.org/showthread.php?t=699693)
but get a new error (I tried to translate the most imported part, the original dutch text is copied under it).

nvidia-glx-new is not available, but there is pointed to it. This possibly means that the file is missing or old. It is replaced by nvidia-glx-96 nvidia-glx-180 nvidia-glx-177 nvidia-glx-173 nvidia-glx-71
E: File nvidia-glx-new has no candidate that can be installed.


Thanks a lot


Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
De status informatie wordt gelezen... Klaar
Pakket nvidia-glx-new is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
Echter, de volgende pakketten vervangen dit:
nvidia-glx-96 nvidia-glx-180 nvidia-glx-177 nvidia-glx-173 nvidia-glx-71
E: Pakket nvidia-glx-new heeft geen installeerbare kandidaat
kloispetie
Level 1
Level 1
 
Posts: 14
Joined: Mon Nov 03, 2008 1:13 pm

Linux Mint is funded by ads and donations.
 

Re: (EE) failed to load module "glx" (module does not exist, 0)

Postby Husse on Sat Mar 07, 2009 4:13 pm

Which version exactly of Mint do you use?
Try to uninstall the nvidia driver with Envy - it may still be possible
Then install again
You must have made a mistake along the road - glx should (more or less could) not be missing
I think the errors caused by your attempt to install the run file from nvidia's site is the cause, but what to do about is not so easy to say
You could try to remove all packages you find in synaptic with nvidia except those containing
envy, kcmnvview, sysinfo, jockey, gimp, trigger, dmraid, cpufreqd and sensors-applet and all the mod-aliases
as a last resort and after that use envy or jockey to reinstall
Be very careful - check if other apps are removed - this could be the case
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: rogerdv and 22 guests