EMPIA em2860 driver install problem with "make"

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

EMPIA em2860 driver install problem with "make"

Postby JohnH on Sat Mar 07, 2009 4:07 am

Hi there,

I posted on the newbie forum something that probably belongs here. My apologies.

I'm having a problem installing a driver. I'm following the instructions from the Ubuntu site and strike a problem.

Here is the error message from the "make"

Code: Select all
 make

running ./build.sh build

make[1]: Entering directory `/home/john/v4l-dvb-kernel'
rm -rf Module.symvers;
make -C /lib/modules/`if [ -d /lib/modules/2.6.21.4-eeepc ]; then echo 2.6.21.4-eeepc; else uname -r; fi`/build SUBDIRS=`pwd` modules
make[2]: Entering directory `/lib/modules/2.6.27-7-generic/build'
make[2]: *** No rule to make target `modules'.  Stop.
make[2]: Leaving directory `/lib/modules/2.6.27-7-generic/build'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/john/v4l-dvb-kernel'


Here is the code from the build.sh file which might have a clue to the problem:

Code: Select all
#!/bin/bash
if [ "$1" = "" ]; then
   echo "available commands:"
   echo "./build.sh build ... building the modules"
   echo "./build.sh load ... for loading the modules"
   echo "./build.sh install ... for installing the modules"
   echo "./build.sh tvtime-ubuntu ... for installing tvtime (for ubuntu hardy)"
   exit 0
fi

if [ "$1" = "ubuntu" ]; then
if [ ! -d /usr/src/ubuntu-hardy-lum/ubuntu/media/empia/ ]; then
  mkdir -p /usr/src/ubuntu-hardy-lum/ubuntu/media/empia/
fi

cp * -rf /usr/src/ubuntu-hardy-lum/ubuntu/media/empia/
cd ubuntu
cp * -rf /usr/src/ubuntu-hardy-lum/ubuntu/media/empia/
fi

if [ "$1" = "build" ]; then
make default

if [ $? != 0 ]; then
   # Stop if there was any error
   exit $?
fi

if [ -d /lib/modules/2.6.21.4-eeepc ]; then
for i in sharp/s921.ko drx3973d/drx3973d.ko tvp5150/tvp5150.ko lgdt3304/lgdt3304.ko  mt352/mt352.ko zl10353/zl10353.ko  cx25843/em28xx-cx25843.ko  xc3028/tuner-xc3028.ko xc5000/tuner-xc5000.ko em28xx.ko em28xx-audio.ko em28xx-aad.ko em28xx-audioep.ko em28xx-dvb.ko precompiled/dvb-core.ko qt1010/qt1010.ko mt2060/mt2060.ko; do
   cp $i modules/;
done
exit 0
else
for i in sharp/s921.ko drx3973d/drx3973d.ko tvp5150/tvp5150.ko lgdt3304/lgdt3304.ko  mt352/mt352.ko zl10353/zl10353.ko  cx25843/em28xx-cx25843.ko  xc3028/tuner-xc3028.ko xc5000/tuner-xc5000.ko em28xx.ko em28xx-audio.ko em28xx-aad.ko em28xx-audioep.ko em28xx-dvb.ko qt1010/qt1010.ko mt2060/mt2060.ko; do
   cp $i modules/;
done
fi
fi

KVER=`uname -r`

if [ "$1" = "install" ]; then
   if [ -d /lib/modules/2.6.21.4-eeepc ]; then
      for i in sharp/s921.ko  drx3973d/drx3973d.ko tvp5150/tvp5150.ko lgdt3304/lgdt3304.ko  mt352/mt352.ko zl10353/zl10353.ko  cx25843/em28xx-cx25843.ko  xc3028/tuner-xc3028.ko xc5000/tuner-xc5000.ko em28xx.ko em28xx-audioep.ko em28xx-aad.ko em28xx-audio.ko em28xx-dvb.ko precompiled/dvb-core.ko qt1010/qt1010.ko mt2060/mt2060.ko; do
         cp $i modules/;
      done
      exit 0
   else
      for i in sharp/s921.ko  drx3973d/drx3973d.ko tvp5150/tvp5150.ko lgdt3304/lgdt3304.ko  mt352/mt352.ko zl10353/zl10353.ko  cx25843/em28xx-cx25843.ko  xc3028/tuner-xc3028.ko xc5000/tuner-xc5000.ko em28xx.ko em28xx-audioep.ko em28xx-aad.ko em28xx-audio.ko em28xx-dvb.ko qt1010/qt1010.ko mt2060/mt2060.ko; do
         cp $i modules/;
      done
   fi
   #FIXME Why not just do make install here?
   find /lib/modules/${KVER}/ | grep tvp5150.ko | xargs rm -rf
   find /lib/modules/${KVER} | grep em28xx | xargs rm -rf
   find /lib/modules/${KVER} | grep zl10353 | xargs rm -rf
   find /lib/modules/${KVER} | grep mt352.ko | xargs rm -rf
   rm -rf /lib/modules/${KVER}/empia
   mkdir -p  /lib/modules/${KVER}/empia
   cp modules/* /lib/modules/${KVER}/empia
   depmod -a
fi

if [ "$1" = "load" ]; then
for i in sharp/s921.ko em28xx-audioep.ko em28xx-aad.ko em28xx-dvb.ko em28xx-audio.ko em28xx.ko drx3973d/drx3973d.ko lgdt3304.ko  mt352.ko zl10353.ko  em28xx-cx25843  tuner-xc3028 tuner-xc5000  tvp5150 qt1010 mt2060; do
   rmmod $i;
done

for i in  mt2060/mt2060.ko qt1010/qt1010.ko drx3973d/drx3973d.ko tvp5150/tvp5150.ko lgdt3304/lgdt3304.ko  mt352/mt352.ko zl10353/zl10353.ko  cx25843/em28xx-cx25843.ko  xc3028/tuner-xc3028.ko xc5000/tuner-xc5000.ko em28xx.ko em28xx-audio.ko em28xx-aad.ko em28xx-dvb.ko em28xx-audioep.ko; do
   insmod $i;
done
fi

if [ "$1" = "tvtime-ubuntu" ]; then
   apt-get install mercurial
   hg clone http://mcentral.de/hg/~mrec/tvtime
   apt-get install libswscale-dev libasound2-dev libc6-dev make automake1.9 autoconf libtool g++ gcc libxml2-dev libzvbi-dev
   cd tvtime
   ./autogen.sh
   ./configure --prefix=/usr
   make
   make install
fi


I would be grateful for some wisened soul who could see what I need to do to fix this problem.

thank you

John
If you get too big for your britches, you will be exposed in the end.
User avatar
JohnH
Level 4
Level 4
 
Posts: 215
Joined: Wed Nov 22, 2006 4:15 am
Location: Caboolture, Oz

Linux Mint is funded by ads and donations.
 

Re: EMPIA em2860 driver install problem with "make"

Postby Husse on Sun Mar 08, 2009 8:48 am

Have you installed build-essential?
Code: Select all
apt install build-essential
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: EMPIA em2860 driver install problem with "make"

Postby JohnH on Sun Mar 08, 2009 7:12 pm

Husse,

Build-essential 11.4 is installed

John
If you get too big for your britches, you will be exposed in the end.
User avatar
JohnH
Level 4
Level 4
 
Posts: 215
Joined: Wed Nov 22, 2006 4:15 am
Location: Caboolture, Oz

Re: EMPIA em2860 driver install problem with "make"

Postby garda on Fri Mar 13, 2009 7:29 am

Make sure the proper kernel headers are already installed, in your case they are linux-headers-2.6.27-7 and linux-headers-2.6.27-7-generic. Some modules also require the corresponding kernel source be installed for successful module compile. Therefore, you might also want to install linux-source-2.6.27.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 8 guests