No Sound - Linux Mint 6 on Asus F6A

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

No Sound - Linux Mint 6 on Asus F6A

Postby hardwear31 on Sun Mar 08, 2009 6:06 am

Hey everyone, I'm a total linux newb. I just installed Linux Mint 6 on my new Asus F6A. I noticed that sound wasn't working and I'm not sure where to even begin trying to fix it. Any help appreciated. Thanks!
hardwear31
Level 1
Level 1
 
Posts: 5
Joined: Mon Feb 09, 2009 7:31 pm

Linux Mint is funded by ads and donations.
 

Re: No Sound - Linux Mint 6 on Asus F6A

Postby Husse on Sun Mar 08, 2009 10:29 am

You have to tell us more facts.
The minimum is exactly which Mint you have - which version and which edition (main or any of the CEs)
We also need to know a bit about all your hardware.
Run " lspci " in a terminal and post here (To copy from a terminal right click)
Some wifi and possibly built in sound can be connected to USB even if they are internal - if you suspect you have one of these run " lsusb " in a terminal.
It's good to know it's an ASUS but not enough
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: No Sound - Linux Mint 6 on Asus F6A

Postby hardwear31 on Sun Mar 08, 2009 3:51 pm

Thanks Husse. I rather expected an RTFM sort of reply but this is great! :D

I am running Linux Mint 6 Main Edition. I'm curious if there is a "system information panel" or something of that nature that lists information like this - I haven't found one yet on Mint.

Here is my lspci output:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

This is my lsusb output:
Bus 008 Device 003: ID 04f2:b029 Chicony Electronics Co., Ltd
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 004: ID 0461:4d15 Primax Electronics, Ltd
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
hardwear31
Level 1
Level 1
 
Posts: 5
Joined: Mon Feb 09, 2009 7:31 pm

Re: No Sound - Linux Mint 6 on Asus F6A

Postby Husse on Sun Mar 08, 2009 4:30 pm

No - why should you get RTFM?
"system information panel"

We used to have "Hardware information" but it disappeared
However as you see lspci gives very good information
you can add -v to see even more (and several v)
In your case it's because you have ICH sound - pulse audio does not like it
First off though - check any setting for sound you can find - double click the volume applet next to the clock
Then check this out
http://www.linuxmint.com/forum/viewtopi ... sa#p107982
Of course you change to model=asus
Sometimes another index number helps but that's only a last resort
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: No Sound - Linux Mint 6 on Asus F6A

Postby hardwear31 on Sun Mar 08, 2009 5:12 pm

I had a friend helping me troubleshoot a couple of days ago and he was modifying that alsa-base file. There may have been many changes made to it already and I am not sure if what we did actually made things worse. Here's what it looks like right now. Is there anything here that jumps out at you as problematic?

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
# Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
# non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
options snd-hda-intel index=0 model=asus
#options snd-hda-intel index=0 model=ref
#options snd-hda-intel model=3stack-dig
options snd-hda-intel enable_msi=1
options snd-hda-intel single_cmd=1
hardwear31
Level 1
Level 1
 
Posts: 5
Joined: Mon Feb 09, 2009 7:31 pm

Re: No Sound - Linux Mint 6 on Asus F6A

Postby Husse on Sun Mar 08, 2009 5:33 pm

Comment out the last two lines
options snd-hda-intel enable_msi=1
options snd-hda-intel single_cmd=1
I can't say if that's good or bad
Maybe also put the line I adviced you to add first of the options snd lines
options snd-hda-intel index=0 model=asus
Generally this trick gets the sound going
Also check every setting for sound you can find - don't forget to double click the volume applet next to the clock
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: No Sound - Linux Mint 6 on Asus F6A

Postby qx48 on Sun Mar 08, 2009 8:58 pm

Should this work for 64-bit Mint 6 as well?
I also have an Asus F6A but it is running the 64 bit version.
Is there anything different i should do to get it working this version?
qx48
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 08, 2009 8:52 pm

Re: No Sound - Linux Mint 6 on Asus F6A

Postby Husse on Mon Mar 09, 2009 6:46 am

There's basically only one difference between the 32 and 64 bit versions - 32 bits :)
I'll have to think about this and come back to you
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: No Sound - Linux Mint 6 on Asus F6A

Postby Husse on Sat Mar 14, 2009 1:43 pm

@ qx48
I did not realise that you are not the original poster
Check every setting for sound - don't forget to double click the volume applet next to the clock and explore the settings
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 17 guests