Enabling restricted video driver

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Enabling restricted video driver

Postby xjohn on Sun Mar 15, 2009 8:33 am

Hi,
I just installed the latest version of Mint but I have some problems with the video card (it is a Radeon 9600pro). First off, I had to install it from the Live CD in recovery mode because the the screen turned off after booting in normal mode. This way, I could only get 1024x768 resolution after installing (my 17" display is 1280x1024). Then, I tried to enable the proprietary video drivers from Hardware Drivers in Control Center. It installed all right so I rebooted the computer. After the splash screen, the screen started blinking and the I got an error message "Ubuntu is running in low-graphics mode ... (EE) fglrx(0) Unknown EDID version 0...failed to allocate CMM buffer...etc". So I ran the system in recovery mode and "tried to fix x-server". Now the screen resolution is correct (1280x1024) but the Hardware Drivers menu says that "A different version of this drivers is in use" and I still can't use the visual effects because the drivers are not activated.
Can anyone suggest how to enable these drivers without getting the error message after reboot? I am grateful for any help.
xjohn
Level 1
Level 1
 
Posts: 1
Joined: Sun Mar 15, 2009 8:09 am

Linux Mint is funded by ads and donations.
 

Re: Enabling restricted video driver

Postby Husse on Tue Mar 17, 2009 7:55 am

I think the 9600 is an old card, so old that you may even need to use a legacy driver
Not yet - I found that the 9600 is still there
http://support.amd.com/us/gpudownload/Pages/index.aspx
Here's some (Not so funny) info
http://www.phoronix.com/scan.php?page=n ... &px=NzExOQ
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 18 guests