THINKPAD R61 MIC PROBLEM

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

THINKPAD R61 MIC PROBLEM

Postby la_monda on Sat Mar 21, 2009 9:28 am

Hallo everybody, i have a r61 8919-cto thinkpad. I installed mint and everything worked like a charm except.....the mic. Since i use skype a lot its a damn shame i cant use the mic. Anyone got any clue of how to make this work??? Bellow i post my souncard info. Thanks in advance guys!

p.s felicia kicks ass, best tuned ubuntu ever!

dinos@dinos-laptop ~ $ sudo lshw -class sound
[sudo] password for dinos:
*-multimedia
description: Audio device
product: 82801H (ICH8 Family) HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=HDA Intel latency=0 module=snd_hda_intel
la_monda
Level 2
Level 2
 
Posts: 57
Joined: Wed Apr 02, 2008 6:54 pm

Linux Mint is funded by ads and donations.
 

Re: THINKPAD R61 MIC PROBLEM

Postby merlwiz79 on Sat Mar 21, 2009 10:05 am

Try
Code: Select all
gksu gedit /etc/modprobe.d/alsa-base

Code: Select all
options snd-hda-intel model=thinkpad

Make sure to backup the file
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: THINKPAD R61 MIC PROBLEM

Postby la_monda on Sun Mar 22, 2009 5:16 pm

My alsa file now looks like this but still no mic....any clues?

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
# Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
# non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
options snd-hda-intel model=thinkpad
la_monda
Level 2
Level 2
 
Posts: 57
Joined: Wed Apr 02, 2008 6:54 pm

Re: THINKPAD R61 MIC PROBLEM

Postby proxima_centauri on Sun Mar 22, 2009 7:08 pm

I have a Thinkpad T61p and have my mic working.
Go into volume control, should be under preferences or adminstration, or even maybe under Sound and Video in the mintMenu.
Make sure you have a microphone slider under playback, 2 capture sliders on playback. You can enable them from the preferences box if they are not present. Make sure they are at adequate levels and are not muted.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3968
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 14 guests