No 6 channel sound

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

No 6 channel sound

Postby Shadowriser on Sat Mar 21, 2009 5:40 pm

I am having two very odd sound problems that my second computer never had with Linux. First the sound channel in mixer in both KDE and Gnome distro's show up as 6 channel in the mixer panel but the center channel and rear have no sound at all. I have already made sure those channels are not muted. I then did a google search and played with alsa in terminal which got me no where.

My old computer had Realtek ALC 883 on an Asus Core 2 Board. My newer system using HDA ATI SB ALC 888. I checked the ALC 888 in windows and all channels work fine. On my old board I could also change from 2 channel to 6 or even 8 channel sound. This mixer is only letting me choose 6 or 8. Six was on by default but no sound from center or rear. My front sound jacks on my Antec 900 case also work fine in windows.

Hoping it is just something simple I am missing :P
AMD Athlon II X4 620 Propus 2.6GHz
ASRock M3A785GMH
OCZ Vertex 32 GB boot drive
ATI 5770 (WTB better drivers)
G.SKILL Ripjaws Series 4GB DDR3
Shadowriser
Level 1
Level 1
 
Posts: 32
Joined: Tue Jan 27, 2009 7:50 pm

Linux Mint is funded by ads and donations.
 

Re: No 6 channel sound

Postby Husse on Sun Mar 22, 2009 11:22 am

Well the HDA ATI SB ALC 888 is probably an Intel HDA so the standard solution for it would apply
viewtopic.php?f=48&t=17801&p=107982&hilit=ich8+alsa#p107982
You would have to change model= to what you have or auto
The HDA can't handle pulse audio ...
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: No 6 channel sound

Postby Shadowriser on Sun Mar 22, 2009 1:50 pm

Its an AM2 chipset not Intel though. I will try that solution and hope it works.
AMD Athlon II X4 620 Propus 2.6GHz
ASRock M3A785GMH
OCZ Vertex 32 GB boot drive
ATI 5770 (WTB better drivers)
G.SKILL Ripjaws Series 4GB DDR3
Shadowriser
Level 1
Level 1
 
Posts: 32
Joined: Tue Jan 27, 2009 7:50 pm


Return to Hardware Support

Who is online

Users browsing this forum: DoTheEvolution, Google [Bot], IMH and 12 guests