Atheros AR242x

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Atheros AR242x

Postby esplosion on Tue Mar 24, 2009 12:07 pm

Okay, so running the newest release of Mint on my laptop, Lenovo t500. The wireless card in it is an Atheros AR242x. It basically wasn't recognized correctly on install, so going through wired NIC, I ran through this http://madberry.org/2008/08/how-to-get-atheros-ar242x-wireless-to-work-2/ and got the wireless "working."

For those who don't want to go through the whole link, basically did the following:

wget -c http://snapshots.madwifi-project.org/ma ... ent.tar.gz

tar xvf madwifi*.tar.gz

cd madwifi*r*

sudo apt-get update && sudo aptitude install build-essential

make

sudo make install

sudo modprobe ath_pci

sudo modprobe wlan_scan_sta

Afterwards, I had to also blacklist ath_hal (on /etc/modprobe.d/blacklist).

Reboot and it worked, mostly. It takes FOREVER to connect. The howto above also noted that updates to the kernel will break it again and I will have to perform the same steps over, at least from the update and build-essential. Just testing, I reboot my machine to make sure it would continue to work. No good.

Basically every time I boot, I have to run make clean, make, sudo make install, and then the two modprobe commands. Then half the time it works (no reboot) and half the time it doesn't and I have to reboot and try again.

On a slight side note, I also wasn't running DHCP on my wireless router, so I had to assign a static to the Atheros. Yea, that didn't work. It would never connect no matter what I did. I eventually had to turn DHCP back on, which I would rather have off, given the option. Like I said, though, this is more of a side note than the main point of the post.

Anyone have any ideas?
esplosion
Level 1
Level 1
 
Posts: 3
Joined: Tue Mar 24, 2009 11:56 am

Linux Mint is funded by ads and donations.
 

Re: Atheros AR242x

Postby miket on Fri Mar 27, 2009 7:26 am

Hi !

esplosion wrote:Okay, so running the newest release of Mint on my laptop, Lenovo t500. The wireless card in it is an Atheros AR242x. It basically wasn't recognized correctly on install, so going through wired NIC, I ran through this http://madberry.org/2008/08/how-to-get-atheros-ar242x-wireless-to-work-2/ and got the wireless "working."

For those who don't want to go through the whole link, basically did the following:

wget -c http://snapshots.madwifi-project.org/ma ... ent.tar.gz
tar xvf madwifi*.tar.gz
cd madwifi*r*
sudo apt-get update && sudo aptitude install build-essential
make
sudo make install
sudo modprobe ath_pci
sudo modprobe wlan_scan_sta

Afterwards, I had to also blacklist ath_hal (on /etc/modprobe.d/blacklist).

Reboot and it worked, mostly. It takes FOREVER to connect. The howto above also noted that updates to the kernel will break it again and I will have to perform the same steps over, at least from the update and build-essential. Just testing, I reboot my machine to make sure it would continue to work. No good.

Basically every time I boot, I have to run make clean, make, sudo make install, and then the two modprobe commands. Then half the time it works (no reboot) and half the time it doesn't and I have to reboot and try again.

On a slight side note, I also wasn't running DHCP on my wireless router, so I had to assign a static to the Atheros. Yea, that didn't work. It would never connect no matter what I did. I eventually had to turn DHCP back on, which I would rather have off, given the option. Like I said, though, this is more of a side note than the main point of the post.

Anyone have any ideas?


Ok, the Atheros devices are a constant source of problems unfortunately.
You can get the system to run those commands for you at boot time automagically so that at least you won't have to do it.

If you open the /etc/rc.local file using gedit or your favorite editor with root priv's and then add the commands to the bottom of the rc.local file,
however remember you *MUST* have the "exit" command as the LAST entry in the file otherwise the system will not boot properly!

Also remember that you will need to add the appropriate cd commands to get into the right directories to do the make etc ...

Once you've done this reboot and see if it works OK.

Also you can lock your IP Address using DHCP, go to the DHCP server (router?) and then select to lock the IP Address to a MAC address and then enter the mac address of your PC,
this will ensure your PC gets the same IP Address each time you boot.

Let us know how you get on.

Mike.
User avatar
miket
Level 5
Level 5
 
Posts: 524
Joined: Tue Mar 04, 2008 5:50 am
Location: UK & France


Return to Hardware Support

Who is online

Users browsing this forum: niowluka and 7 guests