HPT302/302N IDE controller not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

HPT302/302N IDE controller not working

Postby andyh on Sat Mar 28, 2009 12:18 am

Hi all,

I have a HighPoint HPT302/302N Rocket IDE controller card with 4 IDE drives on my system which currently does not work with Mint 6. I moved over from Debian a couple of days ago, where the card was functioning perfectly.

I've tried compiling the v1.2 OpenSource HPT302 driver against sources for the kernel versions below without success.

My current kernel version is 2.6.27-14-generic having tried 27-7 and 27-11 without any luck. The working Debian kernel was 2.6.26-6.

System Log Boot Message: wrote:Mar 28 05:28:07 mediamachine kernel: [ 3.786845] ACPI: PCI Interrupt Link [APC1] enabled at IRQ 16
Mar 28 05:28:07 mediamachine kernel: [ 3.786852] pata_hpt37x 0000:01:06.0: PCI INT A -> Link[APC1] -> GSI 16 (level, low) -> IRQ 16
Mar 28 05:28:07 mediamachine kernel: [ 3.787499] pata_hpt37x 0000:01:06.0: PCI INT A disabled


Any ideas/suggestions would be appreciated.
andyh
Level 1
Level 1
 
Posts: 3
Joined: Sat Mar 28, 2009 12:07 am

Linux Mint is funded by ads and donations.
 

Re: HPT302/302N IDE controller not working

Postby Fred on Sat Mar 28, 2009 5:21 am

andyh,

I have always had pretty good luck with the High Point hardware RAID controllers. Since the kernel version has changed, are you sure you have the correct driver module? There are a lot of them out there. I would try Googling for a loadable module for the Ubuntu kernel and see where that takes you.

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: HPT302/302N IDE controller not working

Postby andyh on Sat Mar 28, 2009 4:00 pm

This is the first time I've had trouble with the HighPoint cards in Linux, Fred. They've been well supported up until now.

I've Googled further on the subject. It appears that the pata_hpt37x module is supposed to support the HTP302/302N card, but from what I've read a number of Ubuntu users who upgraded from Hardy to Intrepid have experienced the same problem. The pata_hpt37x driver modules in kernel 2.6.27 don't work for their boards and the pata_hpt366 (supports 302 in previous kernels) module isn't properly enabled in the kernel according the support responses.

That said, I've been trying to force the htp366 driver to load instead of the 37x version to see if there's any change. I've added the 37x driver to /etc/modprobe.d/blacklist and the 366 version to /etc/modules and the 37x driver is still loading. Any ideas as to what I'm missing?

If this doesn't work, it looks like I might have to compile a 2.6.28 kernel, as reports are the driver is working in that version! :roll:
andyh
Level 1
Level 1
 
Posts: 3
Joined: Sat Mar 28, 2009 12:07 am

Re: HPT302/302N IDE controller not working

Postby andyh on Sun Mar 29, 2009 9:00 pm

Success! ....well sort of....

There is a precompiled 2.6.29 kernel floating around on the Ubuntu forums with a limited driver set which I downloaded and install. The graphics drivers weren't cutting it and wifi was off, but the HighPoint HPT302 support is back! Now I know that building my own kernel will be the only way out of this mess.... unless the Mint people are reading this and get a new one out.
andyh
Level 1
Level 1
 
Posts: 3
Joined: Sat Mar 28, 2009 12:07 am


Return to Hardware Support

Who is online

Users browsing this forum: Google Adsense [Bot] and 14 guests