I've lost my Cube - driver problem Perhaps?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

I've lost my Cube - driver problem Perhaps?

Postby terry1951 on Sat Mar 28, 2009 12:54 pm

Hello all ...

I have a slight niggle that I can't seem to find an issue for. When I installed Mint 6 [felicia] it all worked perfectly right out of the Mag and was fine - All except for a frazzle across the window screens as they opened? - It did this in all Windows!

BTW - The Cube worked as did all the other features? - It was this frazzle that bothered me so in "Appearance Preference" I switched all the features "OFF" under the "Visual Effects" Tab by selecting "NONE" - To see it the frazzle was a feature? - It wasn't! As the Frazzle was still there : So I re-clicked the Lower option "Custom" to turn back "ON" all the screen toys : Only to be told that the System couldn't load the drivers and !!! [wait for it!] -> I got a Dialogue Box saying.

"Desktop effects could not be enabled" - Now I've done some searching on this message and its quite infamous. But it was a dialogue that was talked about quite a lot in 2008 and it seemed to have fallen out of favour recently? [GRIN]

Anyway using the system command "compiz" in a Terminal produces the output below
[It crashes my system BIG TIME? and a power reset must be performed]
Checking for Xgl: not present.
Detected PCI ID for VGA:
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

I have no idea what all this means - Can any one read it?

using the "lspci" command outputs the information below - It seems I have and Intel Graphics chip installed!

00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation 82915G Integrated Graphics Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
40:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)

Any pointers to what's going on greatly appreciated ...

RGDS - Terry - SWINDON - UK
-- --- --
[".{o\ ^ /o}."].....tusk.pigsoft(c)2009 in Swindon
...(_}=||={_)........................http://www.b92.co.uk
.......]_=_[.....Mr Terry McBride.-.working to rule
User avatar
terry1951
Level 1
Level 1
 
Posts: 5
Joined: Tue Mar 24, 2009 6:57 pm
Location: swindon - UK

Linux Mint is funded by ads and donations.
 

Re: I've lost my Cube - driver problem Perhaps?

Postby Husse on Mon Mar 30, 2009 1:04 pm

Run
Code: Select all
lspci -v | grep integrated

This should also show you the drivers used for graphics
This is an older Intel chipset but it should use the intel driver (module)
From the result of the compiz command I see something is wrong, no display detected
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: I've lost my Cube - driver problem Perhaps?

Postby terry1951 on Tue Mar 31, 2009 3:04 pm

Husse wrote:Run
Code: Select all
lspci -v | grep integrated

This should also show you the drivers used for graphics
This is an older Intel chipset but it should use the intel driver (module)
From the result of the compiz command I see something is wrong, no display detected


Hello and thank you for a response.

OK the "|" pipe and grep might have done something, but I couldn't find it?
But the output with just the -v switch in a terminal window produced this? - Its a lot isn't it!

busseey@busseey-desktop ~/Desktop $ lspci -v
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>
Kernel driver in use: agpgart-intel
Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at cfe00000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 1800 [size=8]
Memory at e0000000 (32-bit, prefetchable) [size=256M]
Memory at cff00000 (32-bit, non-prefetchable) [size=256K]
Capabilities: <access denied>
Kernel modules: intelfb

00:02.1 Display controller: Intel Corporation 82915G Integrated Graphics Controller (rev 04)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, fast devsel, latency 0
Memory at cfe80000 (32-bit, non-prefetchable) [disabled] [size=512K]
Capabilities: <access denied>

00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=20, subordinate=20, sec-latency=0
Capabilities: <access denied>
Kernel driver in use: pcieport-driver
Kernel modules: shpchp

00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=40, subordinate=40, sec-latency=0
Memory behind bridge: f0200000-f04fffff
Capabilities: <access denied>
Kernel driver in use: pcieport-driver
Kernel modules: shpchp

00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, medium devsel, latency 0, IRQ 20
I/O ports at 1440 [size=32]
Kernel driver in use: uhci_hcd
Kernel modules: uhci-hcd

00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at 1460 [size=32]
Kernel driver in use: uhci_hcd
Kernel modules: uhci-hcd

00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, medium devsel, latency 0, IRQ 21
I/O ports at 1480 [size=32]
Kernel driver in use: uhci_hcd
Kernel modules: uhci-hcd

00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, medium devsel, latency 0, IRQ 22
I/O ports at 14a0 [size=32]
Kernel driver in use: uhci_hcd
Kernel modules: uhci-hcd

00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03) (prog-if 20)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, medium devsel, latency 0, IRQ 20
Memory at cff40000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd
Kernel modules: ehci-hcd

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3) (prog-if 01)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=05, subordinate=05, sec-latency=32
Capabilities: <access denied>

00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, medium devsel, latency 0, IRQ 21
I/O ports at 1000 [size=256]
I/O ports at 1400 [size=64]
Memory at cff40400 (32-bit, non-prefetchable) [size=512]
Memory at cff40600 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: Intel ICH
Kernel modules: snd-intel8x0

00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
Flags: bus master, medium devsel, latency 0
Kernel modules: intel-rng, iTCO_wdt

00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03) (prog-if 8a [Master SecP PriP])
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, medium devsel, latency 0, IRQ 17
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at 14e0 [size=16]
Kernel driver in use: ata_piix
Kernel modules: ata_piix

00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03) (prog-if 8f [Master SecP SecO PriP PriO])
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 19
I/O ports at 1818 [size=8]
I/O ports at 1830 [size=4]
I/O ports at 1820 [size=8]
I/O ports at 1834 [size=4]
I/O ports at 14f0 [size=16]
Capabilities: <access denied>
Kernel driver in use: ata_piix
Kernel modules: ata_piix

40:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
Subsystem: Hewlett-Packard Company Device 3006
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at f0400000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: tg3
Kernel modules: tg3


END of out put ... Only the strongest will be here: {Huge GRIN]

Now don't get me wrong on this I've got a very usable Linux system with four desktops accessible from the task Bar and I'm am very grateful as its the FIRST time I've EVER been able to Install something usable without a lot of Grief. Linux has in my humble opinion finally come of age, but I really want that cool toy back?

Can you assist? - Rgds
-- --- --
[".{o\ ^ /o}."].....tusk.pigsoft(c)2009 in Swindon
...(_}=||={_)........................http://www.b92.co.uk
.......]_=_[.....Mr Terry McBride.-.working to rule
User avatar
terry1951
Level 1
Level 1
 
Posts: 5
Joined: Tue Mar 24, 2009 6:57 pm
Location: swindon - UK

Re: I've lost my Cube - driver problem Perhaps?

Postby Husse on Tue Mar 31, 2009 6:03 pm

Just taking a quick look late in the evening
My fault - I should have used grep -i so it ignored case - it says Integrated :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: I've lost my Cube - driver problem Perhaps?

Postby terry1951 on Sat Apr 04, 2009 3:29 pm

Husse wrote:Just taking a quick look late in the evening
My fault - I should have used grep -i so it ignored case - it says Integrated :)


Got it: finally! - Using the command

lspci -v | grep -i Integrated

produced the output below ....

00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation 82915G Integrated Graphics Controller (rev 04)

Still makes no sense to me?

RGDS
-- --- --
[".{o\ ^ /o}."].....tusk.pigsoft(c)2009 in Swindon
...(_}=||={_)........................http://www.b92.co.uk
.......]_=_[.....Mr Terry McBride.-.working to rule
User avatar
terry1951
Level 1
Level 1
 
Posts: 5
Joined: Tue Mar 24, 2009 6:57 pm
Location: swindon - UK

Re: I've lost my Cube - driver problem Perhaps?

Postby Husse on Sat Apr 04, 2009 7:10 pm

Just these two lines?
There should have been a mention of kernel modules or drivers
Can you explain the problem a bit better - I'm not quite sure I get it right
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: Bing [Bot] and 13 guests