HD is not recognized by linux

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

HD is not recognized by linux

Postby bobv on Sat Apr 04, 2009 8:14 am

I have an new sata western digital caviar 640 gig HD which I just installed. But gparted can not see it, in fact i can't get it recognized by any of the linux distro live cds I have on hand or the live gparted cd. I wondered if I had a dead hd. So I slipped in the windows 7 iso and this time everything was fine, windows 7 installed and I knew the hd was good. So I put back in the every linux live cd (ubuntu, mint, opensuse, gparted) and none of them can see the HD. I've searched on western digital and have not seen where they have a problem. Do you think I should be search for a driver or controler? I really wanted to use this HD for a multi boot system, those I mentioned above and maybe more. Where should I go from here?

Thanks in advance
BobV
bobv
Level 1
Level 1
 
Posts: 9
Joined: Thu Apr 02, 2009 3:18 pm

Linux Mint is funded by ads and donations.
 

Re: HD is not recognized by linux

Postby emorrp1 on Sat Apr 04, 2009 9:59 am

You'll probably find it is detected, but doesn't appear in your filemanager because it isn't "mounted".

In a terminal, without the external drive plugged in, run
Code: Select all
ls /dev/

Then, with the drive plugged in, run the command again. If linux detects your drive it'll appear as the difference (likely to be /dev/sdb1)

Now to mount it (to have it show up in the filemanager) you could use something like:
Code: Select all
sudo mount /dev/sdb1 /media/data
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: HD is not recognized by linux

Postby bobv on Sat Apr 04, 2009 12:05 pm

wow that sounded like a good try emorrp1 but the device never gets listed. btw it's an internal hd so I was looking for something like hda_ in the list of devices. I booted to win7 just to make sure the hd was still functioning correctly. I've also tried moving the sata hd around to different sata ports and turning off s.m.a.r.t in the bios. There are jumpers on the hd too so Ive tried every position. I'm a little confused because I'm sure the drive is good and I've never read anything about Western digital caviar not being compatable with linux. I've installed many hd in the past so I'm not new to the process however this is my first linux install to a virgin hd so I could be missing something.

one major reason for me going to a linux os was to get a more hands on os, I just did'nt think it would be at this level, I thought the grub would be my first chalange in a multi boot system.

thanks again
bobv
bobv
Level 1
Level 1
 
Posts: 9
Joined: Thu Apr 02, 2009 3:18 pm

Re: HD is not recognized by linux

Postby bobv on Sun Apr 05, 2009 4:54 pm

After getting nowhere yesterday with my problem where my sata hd could not be recognized by linux, today I removed the sata drive and installed a pata drive. Everything was going great, partitioned the drive, installed grub, and created a grub menu.lst file. But thats where it ended. I can't install to the hd. Mint can see all my partitions with gparted for the live cd, but not during the install of Mint. Maybe this is due to the fact my hard drive appears as /dev/sda and not /dev/hda. And that may be due to not being able to make the hd appear as master in the bios (yes I tried Everything). And that may be due to my mobo, a xfx geforce 8200. I did see one post yesterday that said my mobo will absolutely not work with linux. I've got a pc where I can mount these two drives out before I go further.
bobv
Level 1
Level 1
 
Posts: 9
Joined: Thu Apr 02, 2009 3:18 pm

Re: HD is not recognized by linux

Postby slider on Wed Apr 08, 2009 4:44 am

Try following this link: http://www.hp2133guide.com/forums/viewtopic.php?t=1093&sid=a2e79b904f96c69a736b0012383ffab9

Keep reading down that page. I know this is for HP but it may help you in some way I hope.............

tgc
slider
Level 5
Level 5
 
Posts: 580
Joined: Wed May 07, 2008 2:08 pm
Location: Sliding around somewhere!

Re: HD is not recognized by linux

Postby bobv on Wed Apr 08, 2009 12:09 pm

Thanks, and Yes my problem has been with my XFX GeForce Mobo all along but Nvidia has no new bios and their new drivers are for windows. (no more nvidia for me) So I've installed the Western Digital HD on old AMD 2600 based board and its working fine, meanwhile I'll boost it's mem to 2g. The thing is I want a Linux OS PC on about the machine as my Visa OS which is duel core and 4g of mem. To do that it's now going to take about $100 for a comparable Mobo.

Thanks again
bobv
Level 1
Level 1
 
Posts: 9
Joined: Thu Apr 02, 2009 3:18 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 10 guests