audio car problem, earphone plugged, speaker on

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

audio car problem, earphone plugged, speaker on

Postby rent on Fri May 08, 2009 10:16 am

Hi,
I have installed linux mint on an MSI laptop, the audio card is ATI Technologies Inc RS780 Azalia controller

under windows pluggin the earphone a message pops up warning that a jack has been plugged....
this doesn't happen under linux and whean I plug the jack the laptop speaker are not muted, so the audio comes out from the earphone and from the spkeaker at the some time....

any idea how to solve? is that a driver problem?

TIA

rent
rent
Level 1
Level 1
 
Posts: 3
Joined: Fri May 08, 2009 10:08 am

Linux Mint is funded by ads and donations.
 

Re: audio car problem, earphone plugged, speaker on

Postby Husse on Sat May 09, 2009 1:05 pm

The Azalia is a bit strange and there can be strange problems because if the internal wiring (there is a post in the forum about it)
However your problem is not uncommon unfortunately
The Azalia is in fact an Intel HDA so the standard solution for HDA is applicable
viewtopic.php?f=48&t=17801&p=107982&hilit=ich8+alsa#p107982
Of course you change to model=msi
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: audio car problem, earphone plugged, speaker on

Postby rent on Wed May 13, 2009 7:00 am

I followed this instruction, the chip codec si alc888, found in this list, modified alsa-base file...but still jack insertion is not detected and speakers sound with earphone plugged :/

http://ubuntuforums.org/showpost.php?p= ... ostcount=2

mmhh thx for the help, next time i'll buy a laptop i will first check for full compatibility with linux

bye
rent
rent
Level 1
Level 1
 
Posts: 3
Joined: Fri May 08, 2009 10:08 am

Re: [SOLVED]audio car problem, earphone plugged, speaker on

Postby rent on Wed May 13, 2009 8:40 am

:) yes yes yes !! I didn't give up.... googling better, I found the solution....

the error was model=targa-dig for my msi laptop

thx for help!!!
rent
Level 1
Level 1
 
Posts: 3
Joined: Fri May 08, 2009 10:08 am

Re: audio car problem, earphone plugged, speaker on

Postby Husse on Thu May 14, 2009 5:44 am

:) I should explain better which choice for model you should do in my answers :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 10 guests