Getting the Soundblaster X-fi Surround 5.1 to Work

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Getting the Soundblaster X-fi Surround 5.1 to Work

Postby dL_dt on Fri May 22, 2009 10:26 am

I've checked the forums and I don't think this is posted yet, here goes:

Hello everyone, a newbie here. So I've been fiddling around with Linux Mint and searching through the forums, and would like to know if they got their X-fi Surround 5.1card (USB version) to work on other applications besides Rhythmbox. I've pretty much installed all the drivers and all, but only got it working there. If anyone has it working perfectly on anything else, please tell me!

Oh, fyi, I'm using Linux Mint 6 Felicia...
dL_dt
Level 1
Level 1
 
Posts: 1
Joined: Fri May 22, 2009 9:43 am

Linux Mint is funded by ads and donations.
 

Re: Getting the Soundblaster X-fi Surround 5.1 to Work

Postby rivenathos on Fri May 22, 2009 11:50 am

While not an exact answer to your problem, I read over the past few days that the SoundBlaster drivers are now being included in the newest Linux kernels. You may wish to research this news further. It appears to be just the fix for everyone having to use workarounds with SoundBlaster.

In the meantime, if you search this forum or the Ubuntu forum for "SoundBlaster," you will find plenty of threads. I know I saw a thread over at Ubuntu where a step-by-step for enabling 5.1 sound was posted, but I do not know if it was specifically for SoundBlaster or not.
Debian 7 with GNOME 64-bit
User avatar
rivenathos
Level 6
Level 6
 
Posts: 1066
Joined: Wed May 06, 2009 7:32 am
Location: USA

Creative X-Fi - howto install drivers

Postby pdc_2 on Fri May 22, 2009 2:31 pm

see if there is anything in this OpenSuse post that might be of help to you: a user reports getting an X-Fi card running in Gnome, and seems pleased

http://forums.opensuse.org/hardware/414 ... -11-a.html

and he refers folks on to this

http://forums.opensuse.org/hardware/400 ... ost1908843

for how to tweak;
pdc_2
Level 6
Level 6
 
Posts: 1065
Joined: Mon May 11, 2009 1:21 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 8 guests