Low screen resolution

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Low screen resolution

Postby MintSJ on Fri Jun 12, 2009 5:05 am

I am trying to increase the screen resolution on my brother's PC. I get the message
"It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?"
when I choose "yes" I get the message
"You do not appear to be using the Nvidia X driver, please edit your X configuration file (just run "Nvidia X config" as root), and restart the X server.

Well if I had a clue what it is then I would! How do I edit the X config and then restart the X server?
MintSJ
Level 1
Level 1
 
Posts: 10
Joined: Wed May 27, 2009 11:15 am

Linux Mint is funded by ads and donations.
 

Re: Low screen resolution

Postby Husse on Sun Jun 14, 2009 6:15 am

A message somewhat lacking in clarity - edit how? :o
Begin with booting into Recovery mode
Then run the "Fix X option" there - this may do it
Do you use the Restricted driver? That is have you installed a driver?
If not use Hardware Drivers from the menu to install it
If you still have problems some editing may help
You have not told us which Mint you use - please always include version and edition
I'll assume you have the main edition and Elyssa or newer
Code: Select all
gksu gedit /etc/X11/xorg.conf

(In a terminal)
Begin with copying (mark all > Copy > paste in an empty file)
There is not much in that file but there should be a line
Driver "nvidia"
if you use the restricted driver or
Driver"nv"
if you use the open source driver
If not edit or add the line in
Section "Device"
In Section "Screen" add
SubSection "Display"
Depth 24
Virtual 1280 1024
EndSubSection
Remove the Depth 24 already present
Instead of 1280 1024 use the resolution you want if this was not it
Save your edit and reboot
Hopefully you have the resolution you want now
If not tell us which Mint you use - include version and edition and post lspci (l is a lower case L)
There is more we can do, but IO hope we don't have to use that
You asked how to restart X - Ctr+Alt+Backspace
Disabled in Ubuntu form Jaunty
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Low screen resolution

Postby SilverRain79 on Sat Oct 17, 2009 3:50 pm

Hi,

Sorry to reopen this topic but I'm having some trouble with my screen resolution as well but the fix described in this post hasn't worked for me. It worked for my other, smaller, CRT monitor. However I just purchased a bigger CRT Monitor and when I went to change the resolution b/c I didn't like 1024x768 so I switched it to 1152x864 and still didn't like that either. The only other option is 1360x768 which is a wide screen resolution and obviously won't do. My new monitor is a Compaq Presario MV 900 which is supposed to have a resolution up to 1600x1200. I edited the xorg.config file, rebooted, tried restarting the x server, blah...blah...blah... And the highest resolution I can get is 1152x864, which I guess is fine. It's just that I have a huge screen that could be better utilized with a higher resolution. *sigh* Any help would be appreciated.

I'm using Linux Mint - Gloria 64bit
Linux Kernel 2.6.28-15-generic
GNOME 2.26.1
I'm using the suggested restricted Nvidia driver.

Thanks,
SilverRain

*edit*
And now it seems every time I play Alien Arena my screen resolution resets to auto. When I put it back then close the window out the button on my taskbar, for the display functions windows which I just closed, is still there. It won't go away. And if I click on it it brings up the window that's beside it in the task bar and so on screwing up the entire task bar. Also, all of the settings I changed for my task bar now seem to have reverted as well. 0.o
SilverRain79
Level 1
Level 1
 
Posts: 7
Joined: Tue Aug 25, 2009 12:27 pm


Return to Hardware Support

Who is online

Users browsing this forum: YaCy [Bot] and 19 guests