Mint 7 not working with HD 4670?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Mint 7 not working with HD 4670?

Postby gitsum on Wed Jun 17, 2009 3:25 pm

Mint 6 worked perfectly with my HD 4670. Mint 7 will not post any video with an HD 4670. It works fine with an HD 4830 which takes the same windows driver.

I switched to an old 7900GS and Mint 7 works fine. Also tried a 9600GSO 768MB and it works fine also.

Ubuntu 9.04 won't work with the HD 4670 as well.

I love MInt, but if a device doesn't work correctly I am clueless on how to fix it.

I also have an old HD 3850 that I will try, but I really want the low power 4670 to work!
gitsum
Level 1
Level 1
 
Posts: 24
Joined: Thu Apr 23, 2009 10:54 am

Linux Mint is funded by ads and donations.
 

Re: Mint 7 not working with HD 4670?

Postby Husse on Tue Jun 23, 2009 5:43 am

With the new Xserver in Jaunty/Gloria problems were introduced for Intel an ATI cards
Older ATI cards cannot use the proprietary ATI drivers, but this is a relatively new card that is still supported
There are problems with it as you can see here
Try to start the CD in Compatibility mode - press any key while it counts down
Seems like this card could only use Vesa or the proprietary driver
So if it works in Compatibility mode you could install Gloria and then activate the restricted driver - should work but I have no 4670 to experiment with
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: Pyro2577 and 18 guests