SD cardreader (and webcam) don't work on acer aspire 9410

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Mon Jul 13, 2009 3:43 pm

Hi

I've installed Gloria on the acer aspire 9410 of my girlfriend because her laptop was always crashing with windows (even after a fresh install and a lot of visits to a computerspecialist). I've already googled the problem and tried the irc channel but without succes. My girlfriend is a huge fotofan and absolutly wants the cardreader working.

Here some output of some terminal code I ran for the conversation on irc.

Code: Select all
lien@lien-laptop ~ $ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
0a:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0a:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0a:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller


Code: Select all
lien@lien-laptop ~ $ sudo fdisk -l
[sudo] password for lien:

Schijf /dev/sda: 160.0 GB, 160041885696 bytes
255 koppen, 63 sectoren/spoor, 19457 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Schijf-ID: 0xeb1ddf44

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1         182     1461883+  82  Linux wisselgeheugen
/dev/sda2             183       19457   154826437+   5  Uitgebreid
/dev/sda5             183         790     4883728+  83  Linux
/dev/sda6             791       19457   149942646   83  Linux


Code: Select all
lien@lien-laptop ~ $ dmesg| tail
[ 1276.930285] wlan0: authenticate with AP 00:12:bf:12:33:40
[ 1276.931961] wlan0: authenticated
[ 1276.931965] wlan0: associate with AP 00:12:bf:12:33:40
[ 1276.933963] wlan0: authenticate with AP 00:12:bf:12:33:40
[ 1276.936794] wlan0: authenticated
[ 1276.936797] wlan0: associate with AP 00:12:bf:12:33:40
[ 1276.938633] wlan0: RX ReassocResp from 00:12:bf:12:33:40 (capab=0x461 status=0 aid=5)
[ 1276.938636] wlan0: associated
[ 1282.121037] wlan0: no IPv6 routers present
[ 1809.689140] CE: hpet increasing min_delta_ns to 22500 nsec


Code: Select all
lien@lien-laptop ~ $ lsmod| grep -i sd
sdhci_pci              15232  0
sdhci                  23940  1 sdhci_pci


Code: Select all
lien@lien-laptop ~ $ lsmod| grep -i mmc

there was no output here


Code: Select all
lien@lien-laptop ~ $ lsmod| grep -i tifm
tifm_7xx1              13824  0
tifm_core              15900  1 tifm_7xx1


That's all I have. If you need more output, just ask. There were also some issues with her webcam, but to have her cardreader working is the most important thing.

Oh, i have a toshiba satellite A300-16I and the SD card also doesn't mount on my system but if I mount on XP, it works out-of-the-box.

Thanks in advance
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Linux Mint is funded by ads and donations.
 

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby lagagnon on Mon Jul 13, 2009 4:02 pm

Remove the SD card from the reader, open a terminal and type "tail -f /var/log/messages". Insert the SD card. Post the messages. Doesn't the card show up as a device when you now click the "Computer" icon on the top left of your screen?

Re: webcam - tell us exact make and model, and/or run "lsusb" when the webcam is connected.
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Mon Jul 13, 2009 4:49 pm

hi,

Here is the output you asked.

Code: Select all
lien@lien-laptop ~ $ tail -f /var/log/messages
Jul 13 21:23:38 lien-laptop gnome-screensaver-dialog: pam_sm_authenticate: Called
Jul 13 21:23:38 lien-laptop gnome-screensaver-dialog: pam_sm_authenticate: username = [lien]
Jul 13 21:23:38 lien-laptop gnome-screensaver-dialog: Warning: Using default salt value (undefined in ~/.ecryptfsrc)
Jul 13 21:32:32 lien-laptop kernel: [ 1809.689140] CE: hpet increasing min_delta_ns to 22500 nsec
Jul 13 21:33:36 lien-laptop sudo: pam_sm_authenticate: Called
Jul 13 21:33:36 lien-laptop sudo: pam_sm_authenticate: username = [lien]
Jul 13 21:33:36 lien-laptop sudo: Warning: Using default salt value (undefined in ~/.ecryptfsrc)
Jul 13 21:36:00 lien-laptop kernel: [ 2017.877137] ACPI: EC: missing confirmations, switch off interrupt mode.
Jul 13 22:02:35 lien-laptop -- MARK --
Jul 13 22:22:35 lien-laptop -- MARK --
Jul 13 22:42:35 lien-laptop -- MARK --
Jul 13 22:42:47 lien-laptop kernel: [ 6025.100154] tifm_core: MemoryStick card detected in socket 0:0


The device doesn't show in 'computer' (that's the problem)
It looks like it detects the card but can't read it or something. I don't know.

The webcam is build-in.
Code: Select all
lien@lien-laptop ~ $ lsusb
Bus 001 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0a5c:2101 Broadcom Corp. A-Link BlueUsbA2 Bluetooth
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


I think it's the orbicam.

thanks for trying to help
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Tue Jul 14, 2009 6:28 am

Maybe I could try to mount the cardreader mannually (in terminal)? Somebody knows how I should do that?
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby lagagnon on Tue Jul 14, 2009 11:27 am

In the messages log I see no messages whatsoever that the SD card has even been recognized. Are you sure the reader even works, that the SD card is valid, that there is a filesystem on the SD card, that you inserted it completely and that you are posting the log messages seen after inserting the card? Try it again with "tail" as you insert the SD card.
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Tue Jul 14, 2009 2:44 pm

I Don't understand. The line below shows up when I insert the SD card. Doesn't that suggest that it detects an SD card?
Code: Select all
Jul 13 22:42:47 lien-laptop kernel: [ 6025.100154] tifm_core: MemoryStick card detected in socket 0:0


Her card worked on windows so I guess there is nothing wrong with the card.


edit: And because the fact its was windows on the same laptop I think there is also nothing wrong with the cardreader.
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby Cariboo on Tue Jul 14, 2009 3:57 pm

Hi,
Just a thought...
Is the memory card a SD only or is it a SDHC card?
I had a similar issue with the Card reader of my HP Pavilion dv4 1320ca...
seeHERE
Self-built MSI-785GM-E51 Desktop, Dual boot: LM15-64bit-Cinnamon and Win7-64bit , Samsung Galaxy S4 un-locked.
User avatar
Cariboo
Level 4
Level 4
 
Posts: 203
Joined: Sun Jan 13, 2008 10:00 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Tue Jul 14, 2009 5:04 pm

On the card is written 'memory stick pro duo', So I don't think its a SDHC. I've read your tread. Maybe there is something wrong with the card (the way it's formatted or something). My toshiba also can't read the card, maybe it's no coincicence. Maybe, I should try to reformat somehow the card? I don't know, I'm not very into that stuff (yet).
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby lagagnon on Wed Jul 15, 2009 10:12 am

It really seems quite simple to me now that I've seen the log messages. The card is detected but it is either faulty or does not have a valid partition/filesystem on it (probably the latter).

Install "gparted" and make a partition and FAT32 filesystem on that stupid thing :wink:
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Wed Jul 15, 2009 11:14 am

Okey, I just tried but Gparted also doesn't find the SD card. (I tried to find a usb stick with geparted and that he can find)


Maybe the driver is not good enough?
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby lagagnon on Wed Jul 15, 2009 1:23 pm

Your SD card is faulty - bin it.
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Mon Jul 20, 2009 4:32 am

Hi,

First, I want to say sorry for my late answer but I was not at home for 4 days (some hiking) :D
secund, I thank you for helping me.

Third, I don't really know what you mean with binning my SD card? Is that an other format? How do I do that? And will it be compatible with my camera?

thanks
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby lagagnon on Mon Jul 20, 2009 10:16 am

"Bin it" means throw it in the garbage. See my previous post.
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby proxima_centauri on Mon Jul 20, 2009 10:42 am

adder wrote: Oh, i have a toshiba satellite A300-16I and the SD card also doesn't mount on my system but if I mount on XP, it works out-of-the-box.

adder wrote:Her card worked on windows so I guess there is nothing wrong with the card.

lagagnon,
I read over this quickly so forgive me if I missed something but;
Internal SD readers can be finicky on certain laptops with Linux. No offence, but I am absolutely refuting your advice, the SD card works in XP. I can't see any reason to "bin" it. Please use cautious discretion when suggesting such measures for a user.

I will investigate in depth when I get a chance addler, I was doing some reading on this a couple weeks ago and remember finding how-to's. I'm sure you won't - but for the love of God do not throw the SD card out :)

Can you clarify if I have this right? The SD card works in your friends Windows laptop, but does not work on yours in both Windows or Linux?
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Mon Jul 20, 2009 1:26 pm

Okey, I just realized something big.

It's no SD card but a memory stick pro duo of SanDisk. I use an adaptor to insert it into my laptop. I had today a real SD card in my hands and I realised that it's bigger then a pro duo. If I insert the SD card, it can read it. A pro duo not. I'm sorry for the inconvenience!

It works on my dualboot vista/mint Toshiba laptop in vista but not in mint. It doesn't work on the acer laptop of my girlfriend in mint. It doesn't work on a packard bell laptop in ubuntu and It doesn't work on a desktop in mint. all the latest versions.

I'm really really sorry!
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby proxima_centauri on Mon Jul 20, 2009 1:39 pm

Quickly found this thread might be of use -> http://ubuntu-virginia.ubuntuforums.org ... p?t=797031
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Mon Jul 20, 2009 6:54 pm

I tried the script in the thread you found.
The script:
Code: Select all
#!/bin/sh
if [ "$1" = "" ]; then
echo "You haven't give me the computer's architecture name e.g. for Intel: i386 , for AMD64: amd64"
return
fi
cd tmp_kernel_files && echo "I need to be runned in a directory where is no tmp_kernel_files named subdirectory" && return
echo "Creating temporary directory: ./tmp_kernel_files"
#0.) Creating temporary directory: ./tmp_kernel_files
mkdir tmp_kernel_files
cd tmp_kernel_files
#1.) Download the latest linux kernel source:
apt-get build-dep linux-image-`uname -r`
apt-get source linux-image-`uname -r`
cd linux-`uname -r` || cd linux-`eval "uname -r" | cut -f1 -d-`
#2.) Add "CONFIG_MEMSTICK=m" to debian/config/i386/config
echo CONFIG_MEMSTICK=m >> debian/config/$1/config || return
#3.) Build the whole kernel actually:
AUTOBUILD=1 NOEXTRAS=1 skipabi=true fakeroot debian/rules binary-generic
#4.) Copy the generated Memory Stick driver to the system kernel:
cp -r debian/linux-image-`uname -r`/lib/modules/`uname -r`/kernel/drivers/memstick /lib/modules/`uname -r`/kernel/drivers/
#5.) Apply changes to the system:
depmod -a
#6.) Clean up temporary files
cd ..
cd ..
rm -r -f tmp_kernel_files
echo "Temporary directory: ./tmp_kernel_files deleted"


But I get next output:

Code: Select all
adriaan@adriaan-laptop ~/Bureaublad $ sudo ./MemoryStick.sh i386
cd: 6: can't cd to tmp_kernel_files
Creating temporary directory: ./tmp_kernel_files
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
E: Uw bronnenlijst (/etc/apt/sources.list) dient minstens 1 bron-URI te bevatten
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
E: Uw bronnenlijst (/etc/apt/sources.list) dient minstens 1 bron-URI te bevatten
cd: 14: can't cd to linux-2.6.28-11-generic
cd: 14: can't cd to linux-2.6.28
./MemoryStick.sh: 16: cannot create debian/config/i386/config: Directory nonexistent


I think that there is a map that the script doesn't find. Maybe I can adjust the script a bit and make it find the right location? A search after some 'linux' map doesn't bring me much further. Somebody an idea? thanks
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Re: SD cardreader (and webcam) don't work on acer aspire 9410

Postby adder on Fri Jul 24, 2009 9:57 am

bump


Nobody a clue? it's going wrong at the 14th line of the script. It can't find the map 'linux...' (see the last three lines of my output) If I download the kernel source, where is it located? Maybe I can tweak the script code a bit.
adder
Level 1
Level 1
 
Posts: 18
Joined: Fri Jun 19, 2009 6:32 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 8 guests