No sound from digital out (SOLVED!)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

No sound from digital out (SOLVED!)

Postby Lolo Uila on Wed Jul 15, 2009 4:47 pm

Shuttle SB75G2, P4 3.4GHz, 2GB PC3200
Intel 875P/ICH5-R motherboard
Realtek ALC650 six channel audio
Primary boot OS Linux Mint5 Elyssa (SATA RAID)
Secondary boot OS (Window XP Pro (SATA RAID)
Backup/Test boot OS Mint7 Gloria (primary IDE master)

Analog audio out works. Digital does not. Digital has worked fine in previous versions of Mint (Cassandra, Celena, currently running Mint5 Elyssa as my primary OS). Usually all I have to do is enable the digital audio device and turn the volume all the way up. This does not work in Gloria, unfortunately.

Been beating on this for more than an hour now and I'm out of ideas. Tried all the options in the Volume Control panel and the Mint Control Center. Changing various options either gives me analog audio only, or no sound at all. :( Ran all the level 1,2,3 updates, no difference.

Help?
Last edited by Lolo Uila on Wed Jul 15, 2009 11:19 pm, edited 1 time in total.
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Linux Mint is funded by ads and donations.
 

Re: No sound from digital out

Postby zombiemaster223 on Wed Jul 15, 2009 9:26 pm

GO TO TERMINAL
TYPE ALSAMIXER
ENTER

YOU WILL GET A GRAPHICAL SCREEN, THE LEFT RIGHT ARROWS ON YOUR KEYBOARD MOVES THE SELECTION CHOICE TO EACH, YOU CAN THEN JACK UP THE VOLUME TO MAX USING UP ARROW, THEN DO THE NEXT ONE,
NOW..VERY IMPORTANT, HIT THE ESC KEY, THEN DO CONTL X AND IT WILL SAVE THE SETTINGS...

THIS WORKS FOR NO AUDIO ON MOST MINT INSTALLS...INSTANTLY

GOOD LUCK

OH... THERE IS A HDA OUT THERE THAT ISNT DRIVER SUPPORTED IN MINT, OR WASNT AS OF ELYSA, ITS THE INTEL HDA USING REALTEC DRIVER... I SOLD MY NEW HD LAPTOP BECAUSE OF THAT PROBLEM...
GOT A EEPC H1000 NETBOOK, IT LOVES MINT, EVERYTHING WORKS....
zombiemaster223
Level 1
Level 1
 
Posts: 2
Joined: Wed Jul 15, 2009 9:07 pm

Re: No sound from digital out

Postby Lolo Uila on Wed Jul 15, 2009 11:19 pm

Thanks for the tips, but I found the combo of settings that got the digital going. Some of them seem counter-intuitive, but it works.

Go into the Volume Control panel and then Preferences.

For the Realtek ALC650F (OSS Mixer) add the following switch:
Digital-1 (and turn it all the way up!)

Under previous versions of Mint the above was all that was needed. But for Gloria you also need to make some adjustments to the Alsa mixer.

For the Intel ICH5 (Alsa mixer) add the following switches:
IEC958: (check this one to enable it)
Analog to IEC958 Output: (make sure this one is UNchecked to disable it)
Under playback add the IEC958 Playback AC97-SPSA control then turn it all the way DOWN and/or mute it.

Digital audio is rocking for me now. Hope this helps someone else.

Aloha, Tim
User avatar
Lolo Uila
Level 5
Level 5
 
Posts: 547
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii


Return to Hardware Support

Who is online

Users browsing this forum: 03927e9c and 22 guests