mouse scrolling not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

mouse scrolling not working

Postby pandanese on Sun Jul 19, 2009 7:43 am

hey there,

using linuxmint since yesterday and im really impressed so far, loving it :-)

when i first installed it there was no problem with using my mousewheel to scroll down menus/firefox and stuff, though i couldnt use button4/5 to go back and forth in explorer.. so i tried to get figure that out and googled around and one of the suggested solutions i found was this: http://fedorasolved.org/Members/IvarDah ... hterm=None

i did as i was told there, my xorg.conf now looks like this:
Code: Select all
Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Device" "/dev/input/mice"
    Option "Buttons" "10"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "false"
    Option "ButtonMapping" "1 2 3 6 7 8 9 10 4 5"
EndSection

Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Mouse0" "CorePointer"
EndSection

i added the last section "ServerLayout" manually btw, maybe that matters.. ;)

well the output of this whole action is that i cant scroll down any window anymore, neither in the system menus nor firefox, mousewheel up is going back one page in firefox and mwheel down is going forth and im pretty irritated by that.

i would like to have it all working, not only the scroll thingy as it was at the beginning.

thanks in advance for your help, greetings panda

EDIT
just had some issues with an fps game (didnt start but resolution changed and suddenly my nvidia drivers were not recognized.. did nvidia-xorg then and my xorg.conf now looks like this:
Code: Select all
Section "Monitor"
   Identifier     "Monitor0"
   VendorName     "Unknown"
   ModelName      "Unknown"
   HorizSync       28.0 - 33.0
   VertRefresh     43.0 - 72.0
   Option         "DPMS"
EndSection

Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "Monitor0"
   DefaultDepth    24
   SubSection "Display"
      Depth       24
   EndSubSection
EndSection

Section "Module"
   Load           "dbe"
   Load           "extmod"
   Load           "type1"
   Load           "freetype"
   Load           "glx"
EndSection

Section "InputDevice"
   Identifier     "Mouse0"
   Driver         "mouse"
   Option         "Protocol" "auto"
   Option         "Device" "/dev/psaux"
   Option         "Emulate3Buttons" "no"
   Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
   Identifier     "Keyboard0"
   Driver         "kbd"
   # generated from default
EndSection

Section "ServerLayout"
   Identifier     "Layout0"
   Screen      0  "Screen0"
   InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
EndSection

Section "ServerFlags"
   Option   "DontZap"   "False"
EndSection

now the scrolling works again, mouse4/5 to go back/forth in firefox does also work again, but still not in file browser.
pandanese
Level 1
Level 1
 
Posts: 2
Joined: Sun Jul 19, 2009 6:51 am

Linux Mint is funded by ads and donations.
 

Re: mouse scrolling not working

Postby lagagnon on Sun Jul 19, 2009 10:13 am

User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Re: mouse scrolling not working

Postby pandanese on Sun Jul 19, 2009 11:41 am

mousebutton4 and 5 do work in firefox again, its the file browser where i want it to also work ;)

thanks for that suggest though :)
pandanese
Level 1
Level 1
 
Posts: 2
Joined: Sun Jul 19, 2009 6:51 am


Return to Hardware Support

Who is online

Users browsing this forum: Bing [Bot] and 11 guests