Installing ALSA driver

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Installing ALSA driver

Postby jlr1701 on Wed Jul 22, 2009 7:11 pm

I am attempting to install the newest ALSA driver on a clean install of Mint 7 so I can use my Sound Blaster X-Fi sound card. I have installed it successfully before on my other Mint 7 install which boots from another hard drive. However, on this clean install of Mint, I get these errors when I type "make" after I run "configure":

jeff@jeff-desktop ~/Desktop/alsa-driver-unstable $ make
make dep
make[1]: Entering directory `/home/jeff/Desktop/alsa-driver-unstable'
make[2]: Entering directory `/home/jeff/Desktop/alsa-driver-unstable/acore'
copying file alsa-kernel/core/info.c
/home/jeff/Desktop/alsa-driver-unstable/utils/patch-alsa: 24: patch: not found
make[2]: *** [info.c] Error 1
make[2]: Leaving directory `/home/jeff/Desktop/alsa-driver-unstable/acore'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/home/jeff/Desktop/alsa-driver-unstable'
make: *** [include/sndversions.h] Error 2


Same download of the driver. The only difference is that this is on a clean install of Mint.

Any help would be greatly appreciated!

Thanks,

Jeff
Asus Sabertooth X79 mobo/i7-3930k/Cooler Master Hyper 212 EVO/32GB Corsair Vengeance DDR3 RAM/Nvidia GTX670/Crucial 128GB SSD/Samsung 540GB SSD/ 2 1TB WD hard drives
User avatar
jlr1701
Level 4
Level 4
 
Posts: 235
Joined: Mon Jul 13, 2009 3:22 am
Location: Anchorage, AK

Linux Mint is funded by ads and donations.
 

Re: Installing ALSA driver

Postby richyrich on Wed Jul 22, 2009 8:01 pm

Have you installed "build-essential" from Synaptic?
User avatar
richyrich
Level 13
Level 13
 
Posts: 4677
Joined: Mon May 04, 2009 8:31 pm
Location: Somewhere in northern Saskatchewan, Canada


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 10 guests