Jumping Cursor/Insertion Point While Typing *FIXED*

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Jumping Cursor/Insertion Point While Typing *FIXED*

Postby samadhi on Mon Sep 21, 2009 9:55 pm

Mint 7 Gnome. Compaq Notebook. Cursor/insertion point jumps erratically while typing.

Some adjustments are available using Control Center options. But this one feature of the cursor/insertion point jumping around the page while typing is not improved. This problem is discouraging my use of Mint, which otherwise I like.

This is not a new problem for notebook computers. When I first installed Windows OS on the different Compaq Notebooks I"ve owned, the same problem occurs. So the default drivers provided by MS also have this problem. Fortunately, the folks at Compaq provided a new touchpad/keyboard driver from Synaptics and the problem was solved.

Any chance that an improved driver can be forthcoming from the good people at Synaptics or other source?
Last edited by samadhi on Sat Oct 10, 2009 3:35 am, edited 1 time in total.
samadhi
Level 1
Level 1
 
Posts: 20
Joined: Fri Aug 14, 2009 10:04 am
Location: Himalayas

Linux Mint is funded by ads and donations.
 

Re: Jumping Cursor/Insertion Point While Typing

Postby smsmith on Tue Sep 22, 2009 6:34 am

I doubt a driver will be available any time soon. In the time I have owned my laptop (2 years), there's only been one driver update for the touchpad and I recall it being a while ago.

But, you might find this tutorial handy. It describes how to turn off the touchpad when you are typing.
How to make the touchpad turn off automatically when typing
I like poetry, long walks on the beach and poking dead things with a stick.
User avatar
smsmith
Level 3
Level 3
 
Posts: 157
Joined: Thu Jul 23, 2009 1:30 pm
Location: Illinois

Re: Jumping Cursor/Insertion Point While Typing *FIXED*

Postby samadhi on Sat Oct 10, 2009 3:44 am

This recommendation by Husse works Great!!
In Mint 7 Gnome, I just entered the syndaemon -i -d command in the Startup Applications utility, saved, and it was done.
[ I recommend the -i switch to limit delay to 1 second ]

How to make the touchpad turn off automatically when typing
Post by Husse on Sun Aug 09, 2009 4:09 pm
I've been looking for a solution for this off and on for a long time - and now I found it
There's a handy little CLI tool called syndaemon that does this for you
Code: Select all
syndaemon -d

Shuts off the touchpad when you type and enables it two seconds after the last keystroke
If you add -t you only disable tapping and scrolling, not mouse movement (Just for your info - mostly it's the movement you want to disable)
If you add -i 1 it's enabled after one second

To make syndaemon start automatically add the command to the "Startup Applications" (for Gnome)
Open the menu and type star and you see it
Click the add button and enter syndaemon -d and give it a name (Notouch perhaps?)

In KDE 4 (Gloria) it is Applications > System > System settings > the Advanced tab > Autostart
Click Add program and enter syndaemon -d
To make sure that it works you should enable SHMConfig
In all editions except main and KDE you have to install SHMConfig

For Gnome
Code: Select all
gksudo gedit /etc/hal/fdi/policy/shmconfig.fdi

For KDE
Code: Select all
kdesudo kate /etc/hal/fdi/policy/shmconfig.fdi

This brings up an empty file
Add the following to that file

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<device>
<match key="input.x11_driver" string="synaptics">
<merge key="input.x11_options.SHMConfig" type="string">True</merge>
</match>
</device>
</deviceinfo>

Save, close the file and reboot and you should be done
Note - for versions earlier than Felicia (Mint 6) this is added to xorg.conf
In
Section "InputDevice"
you add
Option "SHMConfig" "true"
samadhi
Level 1
Level 1
 
Posts: 20
Joined: Fri Aug 14, 2009 10:04 am
Location: Himalayas


Return to Hardware Support

Who is online

Users browsing this forum: AUserInEssex and 16 guests