Graphics Drivers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Graphics Drivers

Postby rippedcb on Mon Oct 05, 2009 4:33 pm

I am one of those unfortunate one's who got stuck with integrated ATI graphics before i switched over to linux. Needless to say, the graphics performace was HORRIBLE even using the propreitary driver option with mint. I remember i had read somewhere that there were new ATI drivers available and today i stumbled on this site:
http://support.amd.com/us/gpudownload/Pages/index.aspx

This site will tell you which driver you need, let you download them and instructions on how to install them. I just finished deactivating the FGLRX and installing the correct driver recommended and downloaded thru that site and what a difference :)

thought this would be helpful to nOOb's like me who might not wanna wait till Mint 8 for the new drivers to be incorporated into the kernel.

Regards,
CB
I have a simple philosophy: Fill what's empty. Empty what's full. Scratch where it itches.
~Alice Roosevelt Longworth ~
User avatar
rippedcb
Level 3
Level 3
 
Posts: 123
Joined: Tue Jul 28, 2009 4:12 pm
Location: Great White North - Van City

Linux Mint is funded by ads and donations.
 

Re: Graphics Drivers

Postby sysst on Tue Oct 06, 2009 6:56 am

Hi
I tried the driver "ati-driver-installer-8.28.8.run" and when I run it, it exits right away with an error:
Code: Select all
~ $ sudo sh ~/Desktop/ati-driver-installer-8.28.8.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.28.8.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
-e ==================================================
-e  ATI Technologies Linux Driver Installer/Packager
-e ==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: unable to detect
Removing temporary directory: fglrx-install

When I run Xorg -version i get this:
Code: Select all
~ $ Xorg -version

X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux mint 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686
Build Date: 09 April 2009  02:10:02AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@rothera.buildd)
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.

What is the problem?
I'm running MInt Gloria 7, KDE 4.2.4
Code: Select all
Linux mint 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
sysst
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 05, 2009 9:36 am

Re: Graphics Drivers

Postby rippedcb on Tue Oct 06, 2009 6:15 pm

did you uninstall the current driver?? are you following the exact directions from the website??
i didn't have any problems as i followed everything step by step..
CB
I have a simple philosophy: Fill what's empty. Empty what's full. Scratch where it itches.
~Alice Roosevelt Longworth ~
User avatar
rippedcb
Level 3
Level 3
 
Posts: 123
Joined: Tue Jul 28, 2009 4:12 pm
Location: Great White North - Van City


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 11 guests