Vertical scrolling for a Synaptics Touchpad?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Vertical scrolling for a Synaptics Touchpad?

Postby subversiveasset2.0 on Sat Jun 30, 2007 3:33 am

I installed gsynaptics, and that lets me turn on the feature, but it doesn't do anything...there should be a way to just add code to xorg.conf, right?

This is what I have so far for the synaptics touchpad:

Code: Select all
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"        "/dev/psaux"
        Option          "Protocol"      "auto-dev"
        Option          "HorizScrollDelta"      "0"
        Option          "SHMConfig"     "true"
EndSection
Last edited by subversiveasset2.0 on Sun Jul 29, 2007 6:32 pm, edited 3 times in total.
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Linux Mint is funded by ads and donations.
 

Postby Husse on Sat Jun 30, 2007 6:40 am

The search is useful :)
In your case search for touchpad and you will find....
http://www.linuxmint.com/forum/viewtopi ... pad&t=2723
The first four posts has the solution I think - install gsynaptics....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby subversiveasset2.0 on Sat Jun 30, 2007 1:29 pm

It seems I was a step ahead :)...I've already installed gsynaptics. It doesn't do anything
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby Husse on Sat Jun 30, 2007 1:40 pm

OK :)
Study the link and you'll see that in there it is
Option "SHMConfig" "on"

not Option "SHMConfig" "true" as you have. I have honestly no idea if that solves it but there's a difference :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby subversiveasset2.0 on Sat Jun 30, 2007 1:42 pm

Ok, i'll change it and see what happens; Gsynaptics itself is what said to put it on true :o

Ok, so I changed it to "on", but that doesn't help: changing options in gsynaptics still does not change actual touchpad performance
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby Husse on Sun Jul 01, 2007 6:43 am

OK the first attempt failed :(
Give us some more information, such as the model of your laptop. As the "giants" reuse names the year it was made would also be helpful
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby subversiveasset2.0 on Sun Jul 01, 2007 5:24 pm

I have an HP Compaq Presario V4000T from hmm...I dunno...2005? Yeah, that's the year I don't have any specific info on the touchpad though...
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby gcc on Sun Jul 01, 2007 6:04 pm

mine (HP dv9000) is as follows:

Code: Select all
Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizScrollDelta" "0"
EndSection


works for me, but you may want to try qsynaptics, which seems to work for some people.

Miscellaneous advice:

Check to make sure that in your serverLayout section that you have a line that looks like:

Code: Select all
 InputDevice     "Synaptics Touchpad"


Another question may be the maker of the touchpad. I believe that on my old laptop I had to set the value of the "Device" "/dev/psaux" line to:

Code: Select all
     Option         "Device" "/dev/input/<event>"


where <event> is the code corresponding to the touchpad from the output of:

Code: Select all
cat /proc/bus/input/devices


Ill add more later as it occurs to me. Hope it helps.
gcc
Level 1
Level 1
 
Posts: 40
Joined: Thu Jun 14, 2007 9:45 pm

Postby subversiveasset2.0 on Mon Jul 02, 2007 2:49 am

gcc wrote:...

Another question may be the maker of the touchpad. I believe that on my old laptop I had to set the value of the "Device" "/dev/psaux" line to:

Code: Select all
     Option         "Device" "/dev/input/<event>"


where <event> is the code corresponding to the touchpad from the output of:

Code: Select all
cat /proc/bus/input/devices


Ill add more later as it occurs to me. Hope it helps.


This was the only major thing that I could find was different...so I tried changing it. It didn't help, but helped me find more information about the model of the touchpad.

Code: Select all
I: Bus=0011 Vendor=0002 Product=0008 Version=7321
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio4/input0
S: Sysfs=/class/input/input4
H: Handlers=mouse3 event4 ts3
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003


is the specific information
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby gcc on Mon Jul 02, 2007 1:24 pm

try /dev/input/event4, with protocol "event". apparently some alps touchpads have issues. also, try http://ubuntu.wordpress.com/2005/11/15/fixing-my-alps-touchpad-with-the-synaptics-driver/, as it describes a scenario close to what you are having. Make sure and read the posts, there is an error or two with the config as presented. It does helpfully list a llot of the more commonly used options though- circular scrolling, pointer acceleration, etc.
gcc
Level 1
Level 1
 
Posts: 40
Joined: Thu Jun 14, 2007 9:45 pm

Postby subversiveasset2.0 on Mon Jul 02, 2007 5:18 pm

yes, making it event4 didn't do anything; that's what I had tested.

let me check the site though...
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby subversiveasset2.0 on Mon Jul 02, 2007 5:46 pm

And....the site doesn't help.

Adding a section for Alps (with all the options) as well as redoing ServerLayout to use that new section gives me nothing new. I'm not breaking anything...but I'm not fixing anything either.

:/ When I used to use Mandriva, it would automatically set up vertical scrolling...but I didn't save the xorg.conf from mandriva and never figured out how to get vertical scrolling working in gentoo either.
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby subversiveasset2.0 on Thu Jul 05, 2007 10:08 pm

The problem is solved. I don't know what was the solution that finally worked, but when I restarted twice, the scrolling started working.

:/ these things are so fickle.
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby subversiveasset2.0 on Thu Jul 19, 2007 7:19 pm

OK, after having messed up my xorg.conf (it seems it resets every time you get change drivers via envy or restricted package manager,) and having to get support again, I realized that what actually fixed it was actually putting these lines in:

Code: Select all
        Option "LeftEdge" "120"
        Option "RightEdge" "830"
        Option "TopEdge" "120"
        Option "BottomEdge" "650"
        Option "FingerLow" "14"
        Option "FingerHigh" "15"
        Option "MaxTapTime" "180"
        Option "MaxTapMove" "110"
        Option "ClickTime" "0"
        Option "EmulateMidButtonTime" "75"
        Option "VertScrollDelta" "10"
        Option "HorizScrollDelta" "0"
        Option "MinSpeed" "0.45"
        Option "MaxSpeed" "0.75"
        Option "AccelFactor" "0.020"
        Option "EdgeMotionMinSpeed" "200"
        Option "EdgeMotionMaxSpeed" "200"
        Option "UpDownScrolling" "1"
        Option "CircularScrolling" "0"
        Option "CircScrollDelta" "0.1"
        Option "CircScrollTrigger" "2"
        Option "SHMConfig" "true"


the gsynaptics and qsynaptics both don't do anything, so just putting Option "SHMConfig" "true" OR "on" does not do anything.
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby subversiveasset2.0 on Sun Jul 29, 2007 6:32 pm

:/ doesn't work with another restart.

I really don't know what the problem is...now editing xorg.conf or using gsynaptics, qsynaptics, or ksynaptics does nothing.
User avatar
subversiveasset2.0
Level 1
Level 1
 
Posts: 32
Joined: Thu Jun 28, 2007 7:19 pm

Postby xaser on Wed Sep 12, 2007 9:13 pm

hi!

I have an similar issue, so may be help to read this topic...

http://www.linuxmint.com/forum/viewtopi ... 3419#33419

by the way, may You try to boot RECOVERY mode and then normal in order to see if it resets your issue too...

best regards!
xaser
Level 1
Level 1
 
Posts: 18
Joined: Tue Sep 11, 2007 5:02 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 17 guests